LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-04-2005, 06:06 PM   #1
apony4me
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 10.0, Debian
Posts: 3

Rep: Reputation: 0
Suse 9.2 -> 10.0-- Now have unwanted Mouse Gestures.


I just upgraded from Suse 9.2 (w/ KDE 3.4) to Suse 10.0. The biggest problem is now Firefox acts like it has mouse gestures installed-- As far as I can tell it's not. It's getting annoying rather quickly when I want to select text and the browser goes 'back' or 'forward'.

I went into KHotKeys and told checked on the 'Disable mouse gestures globally.' That had no effect. I also, tried reinstalling Firefox thru YaST. I've tried everything I could think of, but am getting nowhere fast. If you can help me kill that feature, I'd appreciate it.

Thanks,
Anthony
 
Old 11-05-2005, 04:08 PM   #2
rjwilmsi
Member
 
Registered: Mar 2005
Location: UK
Distribution: opensuse 12.2 x86_64
Posts: 563

Rep: Reputation: 38
Well let's start with something obvious:
do you have any Firefox extensions installed relating to mouse gestures?

Next:
what version of Firefox are you using. Have you tried using 1.5RC1 to see if that fixes it? [This runs simply by unzipping the download and doubleclicking the firefox shell script, so no problems about installing]

Also, my killer question:
are you using a laptop with a touchpad?

If the answer to the laptop question is yes, then this is your problem. See http://www.vectified.com/2004/11/hor...in-firefox.php for the answer.
 
Old 11-05-2005, 04:19 PM   #3
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
the firefox gestures and the khotkeys are not related.

You need to click tools->extensions in firefox, and disable the appropriate extension causing the problem.

Khotkeys control kde apps, not firefox.
 
Old 11-05-2005, 06:09 PM   #4
apony4me
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 10.0, Debian
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by rjwilmsi
Also, my killer question:
are you using a laptop with a touchpad?
Yes, I am using a laptop touchpad, which is probably what made it more annoying than it should have been. Actually, I meant to post a reply eariler saying that I fixed it- by using that option in Firefox. I didn't realize touchpads could horizontal scroll, not to mention scrolling wasn't enabled at all in my 9.2 install-- so I didn't think of that before I originally posted.

After I did that, I noticed that it would flip through the open windows if you 'clicked and moved' on the Taskbar. So I figured, it that was related to the horizontal scroll also. Since it's too easy to accidently horizontal scroll on a touchpad, I decided that I'd just turn it off. Initially, I tested to make sure horizontal scrolling was the problem using Ksynaptics. Turning it off in KSynaptics, told me I was correct. Since I would rather fix it properly so it didn't happen in any window manager-- I researched how to shut off horizontal scrolling in xorg.conf. I managed to turn it off and correct the border size of the touchpad (the vertical scroll side of the mouse was starting early.). So far everything seems to be working just fine.
 
Old 12-03-2005, 05:12 PM   #5
grayeul
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
Thanks! I've been trying to track this down for a while now. I figured it was related to the touch pad, but didn't see any options for gestures. I didn't realize that the horizontal and/or vertical scrolling was the issue there. After disabling these, I can use a browser without going crazy again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
konqueror mouse gestures - how do i activate? puloxor Linux - Software 1 07-19-2005 05:52 PM
window manager with mouse gestures sterrenkijker Linux - Software 4 10-24-2004 09:35 AM
Firefox and Mouse Gestures jrdioko Linux - Software 4 06-21-2004 02:05 PM
khotkeys and mouse gestures? apberzerk Linux - General 0 03-04-2004 09:14 PM
Mozilla + Mouse Gestures RefriedBean Linux - Software 2 07-12-2002 10:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 12:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration