LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   SuSE 9.1, screen goes black (https://www.linuxquestions.org/questions/suse-opensuse-60/suse-9-1-screen-goes-black-249709/)

Odin5578 11-01-2004 02:24 AM

SuSE 9.1, screen goes black
 
At the end of the suse 9.1 installation, it says configuring hardware, and then the screen goes black. Nothing happens after this in ordor to get everything going again, I must restart the computer it then starts up in SuSE, I have a graphical interface and everything, but then it says that my monitor didn't send it's x y coordinates or size to it and asks me if I wish to configure it. I click yes and the screen goes black, only way to continue is to restart, it does the same thing when I try to configure my video card.

Here's my system:
Intel Celeron 1095mhz
382 mb ram
32 meg nVidia Geforce 2 MX/MX 400 video card
my monitor is a Gateway EV700

I'm trying to install suse 9.1 personal. Please help, i'm tired of windows.

casperghst42 11-01-2004 10:25 AM

Try to say no - it should then default to 640x480, and then you can fix it in YaST after you finished the installation.

Also I've seen that it's sometimes a bogus message - where you will see it the first time after you login and then never again.

stormadvisor 11-02-2004 02:31 AM

I am having a similar problem with Suse 9.1 personal and Gateway EV700. I went throught the installation (not graphical) and chose my monitor during install. I can't remember the screen resolution but I know I didn't change it. I never get to a GUI. How would I change screen resolution now? I beleive that is my problem. I think.

I am running (old machine)
SuSe 9.1 personal
P 133mhz
64 mg ram
3 gig hdd
EV700 Gateway monitor

I am also a newbie to Linux. Thanks for your help.

p.s.
Odin5578 - I hope you got yours running!

stormadvisor 11-02-2004 03:02 AM

I have been reading more posts and I have a screen! I hit ctrl, alt, f2 then f3 and I have text/command line. No GUI though. Where do I go from here? As in the post before, I am thinking I may have to change my resolution. How do I do this from the command line?

Thanks

casperghst42 11-02-2004 03:44 AM

Use YaST or Sax2 to setup X.

I sometimes found that using the vesa driver helps.

stormadvisor 11-02-2004 03:55 AM

How do I get to Yast or Sax2 from the command line?

I am in failsafe mode right now.

ubuntu-addict 11-02-2004 04:23 AM

type in sax2 and yast to access them

stormadvisor 11-02-2004 04:32 AM

sax2 is running now! I did not type it in correctly. I'll get back to you.

stormadvisor 11-02-2004 04:47 AM

OK, I used sax2 and changed the resolution but when I tested it the screen is still goes to blk and the monitor goes into standby mode.

I tried the VESA drivers and it wouldn't even let me test. Will 'yast' show different results? I may try it to find out.

Any other ideas?

Is there other drivers to use? I just downloaded Suse last week. That should be up to date right?

stormadvisor 11-02-2004 04:54 AM

Something new. I tried going back to the gateway settings again and tested. I got the following error

X server test information.....
X server test failed
(xx) opened APM failed (dev/apm/_bios) (no such device)
(kk) no device detected.

Will this help to trouble shoot?

casperghst42 11-02-2004 05:17 AM

Add "apm=off" as a kernel parameter when you boot. Or you can modify /boot/grub/menu.lst

stormadvisor 11-02-2004 05:21 AM

/boot/grub/menu.lst gave me permission denied

How can i add the apm=off when I boot?

BTW what does 'apm=off' do?

abisko00 11-02-2004 05:27 AM

Quote:

How can i ass the apm=off when I boot?
Just type it when the grub boot menu appears. Or log in as root first and then change /boot/grub/menu.lst

BTW:what graphics card do you use? The nvidia drivers may need to be installed first. You could do this via YOU.

stormadvisor 11-02-2004 05:33 AM

I have the S3 trio64v2/dx built onboard . THis is an old packard bell machine.

I did type in /boot/grub/menu.lst at root/. It still gave me denial.

Hold On........!

I just turned around and I saw the green grub screen with no options. I hit "ctrl alt del" and the kde 3.2 box popped up. I am now looking at a GUI desktop!?

I don't know why though??

stormadvisor 11-02-2004 05:38 AM

How can I check the settings. Through Sax2 or is there an option like windows has?


All times are GMT -5. The time now is 02:10 AM.