LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   SUSE 11 RC1 is terribly slow (https://www.linuxquestions.org/questions/suse-opensuse-60/suse-11-rc1-is-terribly-slow-647372/)

riba43 06-06-2008 03:56 AM

SUSE 11 RC1 is terribly slow
 
Hi,
I have decided to install SUSE 11.0 RC1. And I did yesterday. Installation was smooth and quick. Everything worked well. I installed repos and upgraded the system. Then it happened. When I want to open a file, nothing happened. Gkrellm indicates that the processor is on 100%. CTRL + ESCAPE (after a. 10 minutes it opened) shows that Plasma and Xorg are guilty for the enormous use of the processor power. Plasma 50% and Xorg 50%. I killed plasma and Xorg went down too and on Gkrellm the processor usage was normal 4%. But I lost my Desktop, the monitor was white, no icons no tool bar, nothing, only gkrellm was there, showing that everything is running. So my question is, what cause that and what to do to prevent. I have to tell that Yesterday evening I decided to reinstall SUSE this morning. But, when I start my comp, SUSE responded normally, everything is normal and that for 1 hour or so. Then it started again, programs are slow when I try to open it and then again I noticed that Plasma and Xorg are again using CPU.

reddazz 06-06-2008 04:06 AM

This is a development build, so I think its best to file a bug report at bugzilla.novell.com so that the problem is fixed before the final release. Before submitting the bug report, run online updates because the issue may have been fixed since the release of the rc.

riba43 06-07-2008 03:20 AM

I have made some experimenting last day. I think that the problem causes upgrade/update of the kernel and installing kernel source. I did reinstall SUSE four times and last time, I only upgrade the kernel and install source kernel. And system almost stops responding. To open Firefox or e-mail or any file, takes a lot of time (from 10 minutes up). What I noticed is that the installation is excellent every time I installed SUSE with only the packages on DVD. I then included the Packman repo and still everything is OK. I added some packages from Packmann and still OK. Then I installed the kernel - source (version 2.6.25.4-10),which is one grade higher than the kernel-default ( version 2.6.25.4-8) and we are back again - very slow response of the system.

reddazz 06-07-2008 06:59 AM

There is a new kernel and kernel-source (version 2.6.25.4-10), so try those.

riba43 06-07-2008 10:24 AM

Yes reddazz, that is exactly what I am saying. Original kernel-default from DVD is version 2.6.25.4-8. And there is no kernel - source installed. But, the only version of kernel-source is 2.6.25.4-10 and there is also the same available version of kernel-default for upgrade. The problem is , when I do that, install the kernel-source and upgrade the kernel-default, the problem is here. This is what my "experiments" are proving. I have again reinstalled SUSE and upgraded all packages (marked blue) except the kernel-default and I did not install the kernel-source. All is working normal, no delay in opening files. But because there is no kernel-source, I have some problems (I cant install some drivers e.g. spca5xx etc).Disregarding this problems, the distro is great.Hope that there will be all problems solved in the final version.

dth1 06-07-2008 03:09 PM

Had no speed problems here with rc1 & kernel 10. Maybe I've been lucky.

You can get the kernel-source file for your kernel version from:-

http://ftp.gwdg.de/pub/opensuse/update/11.0/rpm/

riba43 06-09-2008 12:38 AM

I have now no problem with the speed of the system. I updated the kernel-default and then downloaded all available updates After that I installed kernel-source waiting the system to slow down. But no, the system is now working as it has to work. I noticed now another, also annoying behaiviour. When I started (switch on) my computer, after login screen, instead of desktop, there is only black screen with cursor arrow and nothing else. I can enter into a text mode (CTRL+Alt*F2)and then try sax2. There is something wrong with Xorg, I cant change the settings there, but after shutdown -r now, the system boot normally. That is happening every time after I switch off/on .

riba43 06-10-2008 01:03 AM

I have been trying to resolve the above mentioned problem without success. The probelem remains. I have to reboot if I want to start SUSE 11.0 RC1. Another problem arose when I try to install VariCAD package. I cant, due to the error message, which says that "libpng.so.3" is missing. But it is not. It is properly installed, only SUSE doees not see it. And because of that too, I got SIGABRT (6) signal when I reboot.


All times are GMT -5. The time now is 09:07 PM.