-   SUSE / openSUSE (
-   -   suse 11.2 domU creation on lvm fails (

seuchato 02-08-2010 05:22 AM

suse 11.2 domU creation on lvm fails
Hi all

I got this setup:
- Asus M2N32, Athlon X2, 4G Ram, Raid 5
- dom0 on lvm, boots always
- tried to create a domU using dirinstall
- creating a volume lamp in group VGsys with 5G and ext4
- mount /dev/VGsys/lamp /var/tmp/dirinstall
- yast dirinstall: fails when calling dirinstall_finish
- tried to create a domU using vm-install
- creating a volume lamp2 in group VGsys with 5G and ext4
- vm-install fails too
- tried to make an image on susestudio, successfully, but that does not boot, failing when trying to mount the rood partition
- copied the dom0 image to a domU disk

none of these domU booted sucessfully, all of them showed the following messages:
register_blkdev: cannot get major 8 for sd
Volume group "VGsys" not found

- kernels used and kotd give same results

I am told to disable scsi subsystem in the kernel, I have compiled a kernel before, but

1) I cannot believe I am the only one having this issue or I miss something truely obvious (then what do I miss, please?)
2) dirinstall and vm-install worked in 11.1, there were issues, but recoverable, why now not in 11.2?

I really need a helping hand here



seuchato 02-09-2010 06:19 AM

It is sorted out
Sucess using KOTD kernel-xen- and a suse studio image plus hda1 instead of sda1 as root=/dev/hda1 in vm config file did the trick



All times are GMT -5. The time now is 03:29 AM.