-   SUSE / openSUSE (
-   -   SUSE 10, Samba + Open Office (

EclipseAgent 10-27-2005 02:13 PM

SUSE 10 Samba + Opening Streaming Open Office Files Mounting Questions
Ok, well I have Samba working (which isn't a problem).

But when I try to open a document in OpenOffice (either calc, ooffice) anything, I get an error.

It wants me to put in some new credentials, and when I do. I get an "Read-Error" Error reading file.

Also, why does it ask for new credentials? It doesn�t when I open, say a txt in kwrite, or within the Konqueror view.

Any idea why?


RedShirt 10-28-2005 08:06 AM

Samba + OO, makes me think you are network browsing, and trying to open a file over the network in OO, yes? It is probably considered streaming...and most likely even if it would open, you certainly wouldn't have write access to those files. You need to mount the folders your are browsing to in Samba as drives, like mapping in Windows. Then you should be set.

EclipseAgent 10-28-2005 11:10 AM

Humm.. I tried to mount it using

mount -t smbfs -o username=username //winserver /mnt/mountdirname

Of course the Username was my Username, the winserver was the server I was trying to mount, and the mnt/mountdirname is the mount location.

Is /mnt/... the wrong location? Also, since I would be using domain credentials, should I add workgroup=domainname also?

And last but not least, for simplicity should I do automount in my fstab?

BTW, I am running SUSE 10

EclipseAgent 10-28-2005 04:28 PM

Ok, I finally got it to mount, and you were right. It was the "Streaming" that caused it not to open unless mounted. For mounting I did:

smbmount \\\\WinServName\\Share /MountPoint -o username=username,workgroup=DomainName (It didn't take the Default Domain name I entered in YaST).

So is there a way you can map to the \ level of the server so it shows all drives? I tried mounting it as \\\\WinServName\\ and that said invalid share.

Any ideas?

All times are GMT -5. The time now is 01:32 AM.