-   SUSE / openSUSE (
-   -   suse 10 kernel update breaks gcc (

debbedcorpse 08-25-2006 02:24 AM

suse 10 kernel update breaks gcc
on suse 10 - i have a sagem fast modem. after a clean install, i install gcc and cpp (and all that shizz) from the cd and compile eagle-usb-2.3.2 easily. all works great! however after doing an online update on the kernel, eagle-usb stops working. i expect this, as ive seen it before. however, trying make uninstall fails with errors.
trying to ./configure the source creates a /bin/sh - bad interperator error, which confuses me, as i don't see how it could effect sh!
anyway, being belligerent, i `sh configure` and the script runs, but cuts out with a "configure... gcc can't make a runnable program error". (that error is not a perfect quote, sorry)
i'm sure if i scratch my head, i could go back to the old kernel permanantly, but i don't want to do that.
any ideas?

debbedcorpse 08-25-2006 06:49 AM

switched back to the old kernel, same error. reinstalled gcc etc, same error.

checking whether the C compiler works... configure: error: cannot run C compiled programs.

still wouldn't configure. but the make file hadn't changed, since i hadnt been able to get configure to run. so i ran make anyway, and it all worked...
strange! happy the system isn't broken. unhappy i don't have the new kernel. i'm going to add an online software repositary, and see if i can get a new kernel and a newer gcc.

abisko00 08-27-2006 11:16 AM

How about re-installing the sources? I have had similar problems before with broken sources. Otherwise no clue.

All times are GMT -5. The time now is 09:11 AM.