LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 05-21-2006, 11:42 PM   #1
Doji Grovesai
LQ Newbie
 
Registered: Aug 2005
Distribution: SuSE 10.1
Posts: 13

Rep: Reputation: 0
Suse 10.1 internet problems


Well, I'm pretty new to Linux. I've used Mandriva 2006 Powerpack edition on an old Dell Laptop. I went to turn my desktop machine to dual boot WinXP and Suse10.1. Everything installed fine, I suppose, but I have no internet access. My internet runs as follows:

Internet->Linksys WAP/Router-> Desktop.

YaST says that the network card has installed fine, but I can't access anything outside of the computer. Even putting in 192.168.1.1 to access the router fails. I'm kind of at a loss here, so all info is appreciated.

Thanks
 
Old 05-22-2006, 02:11 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu, mint, suse
Posts: 1,586

Rep: Reputation: 145Reputation: 145
maybe the firewall restircts too much. switch it off to see. you can configure everything in yast=>security, =>networking, =>network services ...
 
Old 05-22-2006, 02:58 AM   #3
AdamCo
Member
 
Registered: Aug 2004
Distribution: Suse 10
Posts: 126

Rep: Reputation: 15
Here is how mine is set up:

1) Open Yaston
2) On the right, click Network Devices
3) On the left, click Network Card
4) Select your network card and click edit
5) Click Hostname and Name Server
6) Uncheck Update Name Servers and Search list via DHCP
7) For Name Server 1 and Name Server 2 enter your ISP's primary and secondary DNS addresses and click OK
8) Click Routing
9) For your default gateway enter 192.168.1.1 and click OK
10) Click Next
11) Click Next again

I hope this helps you, it worked for me.
 
Old 05-22-2006, 03:59 PM   #4
Doji Grovesai
LQ Newbie
 
Registered: Aug 2005
Distribution: SuSE 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
Still no dice

Well, first I tried disabling the firewall. Still nothing.

Then I went in and attempted to configure the network card as Adamco described. Nothing.

I'm really stumped. Is there anything else I can try?
 
Old 05-22-2006, 04:11 PM   #5
AdamCo
Member
 
Registered: Aug 2004
Distribution: Suse 10
Posts: 126

Rep: Reputation: 15
I don't know, another thing I can say is to check and make sure the DNS servers you entered in yast are being written to the /etc/resolv.conf file. I've had problems sometimes with saving my information to yast and then that file would be empty.
 
Old 05-22-2006, 10:18 PM   #6
scofeld
LQ Newbie
 
Registered: Aug 2003
Distribution: SusE 10.0/10.1 / Fedora Core 5 / Knoppix / DSL
Posts: 8

Rep: Reputation: 0
Are you running the K network manager? I had the same problem and disabled the network manager, which got me back to the old way of doing things.

open a terminal and type:

# sudo ifdown eth0
# sudo ifup eth0

and try the internet. That was all I had to do to get online.

(if you don't want to manually reset the network with the above lines, you can disable the KNetwork Manager then reboot.)
 
Old 05-22-2006, 11:06 PM   #7
Doji Grovesai
LQ Newbie
 
Registered: Aug 2005
Distribution: SuSE 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
Well, everything is appearing as it should in resolv.conf, and I can't find any other "errors" going on.

I'll try doing that terminal thing. But first, how do I disable KNetworkManager?
 
Old 05-22-2006, 11:09 PM   #8
Wavz
Member
 
Registered: Mar 2004
Location: Jacksonville, FL
Distribution: SuSE 10 / SuSE 10.1
Posts: 90

Rep: Reputation: 15
Just what I was about to ask, "how do I disable KNetworkManager?"



Wavz

I'm having similar probs
 
Old 05-23-2006, 11:12 AM   #9
scofeld
LQ Newbie
 
Registered: Aug 2003
Distribution: SusE 10.0/10.1 / Fedora Core 5 / Knoppix / DSL
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by Wavz
Just what I was about to ask, "how do I disable KNetworkManager?"



Wavz

I'm having similar probs
Go to YaST and click on Network Devices.

then click on Network Card

It will go through the network detection, then in the center will ask "Network Setup Method"

Select "Traditional Method with ifup"

If I remember right when I changed it to the traditional method, the network started working right away, without an ifdown/ifup reset of the network. But if necessary, do the network reset, or reboot after changing to the traditional method.

Hope it helps!
 
Old 05-23-2006, 12:26 PM   #10
Wavz
Member
 
Registered: Mar 2004
Location: Jacksonville, FL
Distribution: SuSE 10 / SuSE 10.1
Posts: 90

Rep: Reputation: 15
Ok it was my own forgetfulness! Everything came down to a missing file for the wireless card. IPW-Firmware is the one thing I forgot to download so that the wireless card would work. One look under Hardware , network card , and under the wireless card then , requires, told me all I needed to know. I hadnt loaded a new version of SuSE in a long time and had forgotten all about my sony vaio's (PCG-Z1WA) network card needing that file. Thank you for your help scofeld & Doji Grovesai!
Wavz
 
Old 05-25-2006, 09:49 PM   #11
Doji Grovesai
LQ Newbie
 
Registered: Aug 2005
Distribution: SuSE 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
No dice. tried ifdown/ifup, and I got an error at the ifdown stage saying "sudo:ifdown:command not found"

I'm thinking I should just re-try the suse installation
 
Old 05-25-2006, 11:00 PM   #12
scofeld
LQ Newbie
 
Registered: Aug 2003
Distribution: SusE 10.0/10.1 / Fedora Core 5 / Knoppix / DSL
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by Doji Grovesai
No dice. tried ifdown/ifup, and I got an error at the ifdown stage saying "sudo:ifdown:command not found"

I'm thinking I should just re-try the suse installation

That may work, but you will learn so much more about linux by making it work. There are so many things about linux that are a little more complicated than usual, and by re-installing, you won't get the chance to figure out a part of the system.

For example, some commands don't work directly with sudo (I believe it has to do with SuSE not loading the root profile with sudo by default.)

ifdown must be one of those. I personally usually just start a root shell with "sudo su" which gives me all the priveledges of the root account. Give that a shot. Alternatively, if you go to System/Terminals there is a terminal there that will start a root shell automatically.

Or you can try this:

$sudo su

#ifdown eth0
#ifup eth0

Or as I said earlier, you can just reboot the system after disabling the kNetwork manager.

All I know is that I had a very similair problem as you did, and that is what I did to fix it.
 
Old 05-25-2006, 11:40 PM   #13
Doji Grovesai
LQ Newbie
 
Registered: Aug 2005
Distribution: SuSE 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
Well, I tried disabling the KNetwork, and then did sudo again, and that didn't work. So I just rebooted, and that didn't work, either. It dawned on me though, I have a wireless card installed on the machine as well. I totally forgot about it (since I don't need it anymore - the router sits on top of the PC) and never took it out. Windows has no problem ignoring it. Could Linux be running into conflicts? If so, how do I tell? And if that is the problem, can I just delete the hardware profile, or do I have to physically remove the card?

Thanks so much for your help (and patience!)
 
Old 05-31-2006, 01:28 AM   #14
scofeld
LQ Newbie
 
Registered: Aug 2003
Distribution: SusE 10.0/10.1 / Fedora Core 5 / Knoppix / DSL
Posts: 8

Rep: Reputation: 0
I don't have wireless, haven't had to work around those complications. But I know this:

The network card is listed as ath0 vs eth0, do an "ip addr" command and see what ip addresses your cards have. It may point you in the right direction.

Play around with the KNetwork Manager, it may allow you to diable the wireless network and enable the wired network. Sorry I can't help further. Good luck!
 
Old 06-15-2006, 04:19 PM   #15
Doji Grovesai
LQ Newbie
 
Registered: Aug 2005
Distribution: SuSE 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
I took out (physically) the wireless card that I don't use. Then I reinstalled SuSE, but I have the same problem. I did, however, get an extra message, which said DHCP Client is already running on eth0.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet problems in SUSE 10.0 AlcoholicDoc Linux - Networking 3 12-18-2005 10:05 PM
SuSE 9.2 Internet Problems :S kipper2258 SUSE / openSUSE 2 03-16-2005 04:23 AM
SUSE Internet Problems t0rek Linux - Distributions 1 09-25-2004 06:40 PM
Suse 9.0 internet problems (yes, still) ibreaktheglass Linux - Networking 1 09-25-2004 09:09 AM
Suse 9.0 internet problems. ibreaktheglass Linux - Networking 2 03-08-2004 03:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 10:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration