LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-13-2006, 12:07 AM   #16
Delpheno
Member
 
Registered: Oct 2005
Posts: 40

Rep: Reputation: 15

Well doesn't it matter if it runs below 600mhz? If it saves power, and performs without any lag, then it would make sense that it's less than 600.
 
Old 06-13-2006, 08:13 AM   #17
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Delpheno
Well doesn't it matter if it runs below 600mhz? If it saves power, and performs without any lag, then it would make sense that it's less than 600.
It matters hugely that it runs at only 600MHZ. If I wanted 600MHZ, I would buy 600MHZ. If I am running on AC, I would like it if my computer ran at 1600MHZ, it would also help my performance of Video and VMWare greatly
 
Old 06-13-2006, 12:46 PM   #18
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
i think the issue has something to do with me not being able to load the module:

speedstep_centrino

or

acpi_cpufreq

Both report "No device found".. I am going to look into the speedstep_centrino and see what i can find in there.

Note that toshiba_acpi loads just fine.
 
Old 06-13-2006, 11:08 PM   #19
1madstork
Member
 
Registered: Aug 2004
Location: Southaven, Mississippi, USA
Distribution: Debian Etch
Posts: 108

Rep: Reputation: 15
Yeah, I think it's kernel compile time. I'm pretty sure that setting cpufreq to userspace in the kernel will allow you to be able to modprobe speedstep_centrino.
 
Old 06-14-2006, 08:43 AM   #20
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by 1madstork
Yeah, I think it's kernel compile time. I'm pretty sure that setting cpufreq to userspace in the kernel will allow you to be able to modprobe speedstep_centrino.
I had an extra HDD that I installed SuSE 10.1 on (first tried FC4, and FC5 to verify both have the problem) and compiled the kernel without a bunch of the other modules in it, but now I am going to try with userspace as default gov.

For some reason I can't compile kernels on this computer, gives me a QT error (stupid.. QT is installed Doh!).
 
Old 06-14-2006, 01:15 PM   #21
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Whelp, recompiled the kernel and changed default governer to userspace, and still 600mhz.. damn..

I have bug report to bugzilla.novell.com and I think it may be an ACPI issue.

Let me try to upgrade my kernel.. blah..
 
Old 06-15-2006, 05:19 AM   #22
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
Mine as I posted runs perfectly - however I've switched ACPI off as it seems to get it's knickers in a twist -- my external mouse(usb) and network cards stop working.

With ACPI=OFF everything runs fine --of course when I shut down the system I have to switch the computer off manually at the end of the shutdown --but that's a very small inconvenience for a working system.

Cheers
-K
 
Old 06-15-2006, 07:54 AM   #23
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by 1kyle
Mine as I posted runs perfectly - however I've switched ACPI off as it seems to get it's knickers in a twist -- my external mouse(usb) and network cards stop working.

With ACPI=OFF everything runs fine --of course when I shut down the system I have to switch the computer off manually at the end of the shutdown --but that's a very small inconvenience for a working system.

Cheers
-K
I have booted with acpi=off with the same results posted.

What kernel version are you running? Can you send me a copy of your lsmod, dmesg, speedstep_centrino.c and acpi_cpufreq.c

I want to compare them, and see if there is something different with some of the files, thanks.

Email is ben.kevan (at) gmail(dot)com
 
Old 08-10-2006, 02:38 PM   #24
eespenh
LQ Newbie
 
Registered: Jun 2004
Location: Norway
Distribution: Fedora Core 2/Mandrake 10
Posts: 3

Rep: Reputation: 0
Any news?

After installing SUSE 10.1 a week ago, I discovered that I have the same problem;
the CPU never runs at any speeds higher than the lowest possible, 600KHz.

scaling_max_freq is equal to scaling_min_freq, at 600000, even though
cpuinfo_max_freq is 2000000. And whenever I do an
echo 2000000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
or
echo 2000000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
(under userspace governor), the change is overwritten or never picked up,
at least I am unable to change it.

I never had this problem with for example SUSE 10.0, and there is no settings in BIOS
to set specific frequencies, just to disable speedstep (which would leave the cpu
running at lowest speed, according to the BIOS info, so I haven't tried that). Admittedly,
I have the orignal A00 version of this BIOS.

I saw it was mentioned that there'd been a bug reported to Novell for this, but I
didn't see it in their bug system; has it been reported as a bug?

My system:
Dell Inspiron 9200
SUSE 10.1 2.6.16.21-0.13-default

# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 2.00GHz
stepping : 6
cpu MHz : 600.000
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe est tm2
bogomips : 1197.77

Espen
 
Old 08-10-2006, 03:10 PM   #25
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
What happens when you try:

cpufreq-set -g performance

or whats the output of cpufreq-info

Also, please post output of:

uname -r
 
Old 08-10-2006, 05:48 PM   #26
cevans
LQ Newbie
 
Registered: Jan 2003
Distribution: Debian (ppc and x86) with Gnome CVS HEAD
Posts: 6

Rep: Reputation: 0
If scaling_max_freq == scaling_min_freq, changing the governor will have no effect on the frequency. This is a problem with ACPI, where the (if my memory serves me right) _PPC gives an incorrect value for the maximum frequency in certain situations (I suspect it may be a race problem), and cpufreq becomes locked in this situation forever. It was fixed, I believe, by a patch that was included in the vanilla 2.6.17rc2. There is more information about it on the Ubuntu bug report about the issue, on launchpad. My attempts to backport the patch did not resolve the issue, unfortunately. If you are able, and are not already running it, upgrade your kernel to 2.6.17 or above, and see if this fixes the problem.

You can also try the other suggestion given there, about max_cstate. I haven't tried it myself.

Edit: I just noticed that you appear to be running 2.6.16. This is nearly certainly your problem, and 2.6.17 should nearly certainly fix the problem.

Last edited by cevans; 08-10-2006 at 05:50 PM.
 
Old 08-10-2006, 11:44 PM   #27
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by cevans
If scaling_max_freq == scaling_min_freq, changing the governor will have no effect on the frequency. This is a problem with ACPI, where the (if my memory serves me right) _PPC gives an incorrect value for the maximum frequency in certain situations (I suspect it may be a race problem), and cpufreq becomes locked in this situation forever. It was fixed, I believe, by a patch that was included in the vanilla 2.6.17rc2. There is more information about it on the Ubuntu bug report about the issue, on launchpad. My attempts to backport the patch did not resolve the issue, unfortunately. If you are able, and are not already running it, upgrade your kernel to 2.6.17 or above, and see if this fixes the problem.

You can also try the other suggestion given there, about max_cstate. I haven't tried it myself.

Edit: I just noticed that you appear to be running 2.6.16. This is nearly certainly your problem, and 2.6.17 should nearly certainly fix the problem.
I was able to get it running under 2.6.16 , I am sure when he posts results of commands above it'll show that CPUFREQ isn't running.
 
Old 08-13-2006, 10:07 PM   #28
drsketch1
Member
 
Registered: Apr 2006
Distribution: CentOS 6.X, pclinuxos
Posts: 50

Rep: Reputation: 15
I have always thought that the P M Line is ripping people off. I have bever seen my old one raise up above the idle even when under a heavy load
 
Old 08-14-2006, 05:29 AM   #29
eespenh
LQ Newbie
 
Registered: Jun 2004
Location: Norway
Distribution: Fedora Core 2/Mandrake 10
Posts: 3

Rep: Reputation: 0
I've tried using cpufreq-set as well, both setting the performance governor -
which did update the corresponding scaling_governor /sys/devices-entry (I don't have the laptop
available right now, so I don't remember the exact name), but that of course doesn't help
since max-freq is fixed at 600000 - and by trying, with userspace governor running, to set
it explicitly with cpufreq-set -f 2000000.

By the way, I checked with modprobe to make sure the relevant (speedstep/centrino userspace/performance) modules were available, as well.

Espen
 
Old 09-28-2006, 03:43 AM   #30
hedvule
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Rep: Reputation: 0
The same problem

Hi,

I'm having exactelly the same problem. I'm running SUSE 10.1 and here is my cpuinfo file.

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.50GHz
stepping : 6
cpu MHz : 600.114
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe est tm2
bogomips : 1207.22

hedwule@wireless-pc-61-138:/proc> uname -r
2.6.13-15-default

It never runs on more than this 600MHz, no matter how much I push it. And in addition yo this, my Kpowersave allways says that I'm running on batteries. Really don't know what to do.

Hedvule.
 
  


Reply

Tags
kpowersave, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
intel mobile centrino scripttron75 Linux - Networking 2 03-29-2006 01:35 AM
LXer: Psychsoft announces the 64 Bit Psyborg Extreme Workstation with Intel Dual Core Processor featuring SUSE Linux 64 LXer Syndicated Linux News 0 02-02-2006 04:01 AM
Can't Connect To Access Point On SuSe 9.2 Personal With Intel Centrino 2200BG dac0braman SUSE / openSUSE 11 02-16-2005 07:26 PM
Intel Centrino Petition forceflow2 Linux - Laptop and Netbook 2 08-01-2003 01:31 PM
Centrino Mobile processor Jane Delawney Linux - Laptop and Netbook 2 06-12-2003 01:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 01:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration