-   SUSE / openSUSE (
-   -   SUSE 10.0 (OSS) - Sound cards/hydrogen/jack... basically multimedia! (

JustInterested 04-11-2006 10:56 PM

SUSE 10.0 (OSS) - Sound cards/hydrogen/jack... basically multimedia!
Hi All

I've just installed SUSE 10.0 (OSS) and all went well... me thinks! Desktop is KDE.

My PC has two sound cards - onboard sound and a PCI card. Onboard sound uses the intel_x80 driver, the PCi is a MAudio Delta 24/96 using ICE1712 driver.

I have some cheap speakers attached to the onboard sound.

The system sounds can be heard (shutdown, etc) but when I use hydrogen a warning message appears that "no sound cards configured or no sound device...". I start up QJackctl before hydrogen and I can start the sound server... but still get the warning message. Worse still is when I continue (message allows me to continue or abort) hydrogen crashes...

Regarding the "no sound cards" configured I can open the Envy24Control (application for the MAudio sound card) and all is well.

I've run alsaconf and can select either of the two detected sound cards and configure these... still to no avail with hydrogen.

Anyone got any ideas?

All works ok with my Gentoo installation...

Linux.tar.gz 04-12-2006 07:41 PM

You have to shutdown the artsd sound system, which is enabled by default in KDE (bad idea, imho).
You can do it in kcontrol.
Then start jack and select jack audio driver in hydrogen and pa ta poum!

JustInterested 04-12-2006 09:42 PM

:) Cool! I was thinking along those lines... late last night but didn't get a chance to try it.

Thanks for the advice . I will do it tonight when I get home from work and post back results.

Will I also be able to turn it off permanently in kcontrol?

cheers! :D

Linux.tar.gz 04-12-2006 10:15 PM

Yes. If you like music programs, you should try this live-cd:
This is a full home-studio, from recording to cd burning.
Oh, btw, i also have an ICE1712, the audiophile one. Very good chipset :D.

JustInterested 04-12-2006 10:49 PM

:cool: I'll check out that link you gave me, thanks a lot!

Yep the audiophile card is a nice one - a card that lies somewhere between a professional and consumer one. Good choice! ;)

Another question - in my Gentoo installation when I open Kamix both cards are displayed for tweaking. But I don't think this is the case in my SUSE installation. Any ideas?

JustInterested 04-15-2006 07:32 AM

:confused: Hmmm.. I turned off the arts sound in kcontrol and rebooted.. but hydrogen still shuts down on me...

If I select the onboard sound in my jack setup then hydrogen gives me the same error as before "Direct access to the Sound Device Not Possible": No sound card available or sound support is not configured yet... I can continue but hydrogen bombs out.

If I select the MAudio card I don't get the above message when I start hydrogen but it still bombs out.

Any ideas?

BTW I downloaded that dynebolic iso and tried it - very nice.. at least hydrogen works there without a hitch!

JustInterested 04-18-2006 08:41 AM

:scratch: Still haven't found a solution to this...

If I start hydrogen from x-term as such: hydrogen -V -d alsa (or jack) then when I go past the first info screen and then the app bombs with the following message:
terminate called after throwing an instance of 'std::logic_error'
what(): basic_string::_S_construct NULL not valid

Any ideas anyone? Am I missing some dependancy?

Linux.tar.gz 04-18-2006 01:38 PM

Try to compile from sources.

JustInterested 04-19-2006 12:35 AM


Linux.tar.gz... Are you reading my mind? Amazing waht can be done with Linux! ;)

Yep was going to do that. Will try tonight or as soon as possible and post reply.


JustInterested 04-19-2006 05:40 PM

:scratch: Well I installed from source and also needed to install libsndfile and flac from source as well (???)... Still have the same issue - Hydrogen bombs.

Strangely enough I had it working once a few days ago. I turned off arts in kcontrol (is now permanently off). I didn't start jack and then fired up hydrogen... it opened ok. Then I selected jack audio driver from within hydrogen. I shut down hydrogen to do something else and when I tried it again it once again bombed and has done so since.

Any ideas anyone?

Linux.tar.gz 04-20-2006 10:17 PM

Usually, you have to start jack, then hydrogen. Don't forget to connect hydrogen output to alsa input in qjackctl.

JustInterested 04-21-2006 12:16 AM

Thans for the tips... But I hydrogen still crashes.

Maybe a library conflict? :scratch:

Linux.tar.gz 04-21-2006 09:46 AM

I don't know. I recompiled the latest hydrogen this morning and it worked.
Launched "qjackctl", then "hydrogen".

JustInterested 04-25-2006 06:13 AM

Hmmm. I do the same but hydrogen still crashes.

Seeing that my SUSE install is very fresh and under-utilised I'm very tempted to re-install it again...

Linux.tar.gz 04-26-2006 08:06 PM

Well if you want to go deeper into Linux, try some Slackware. I swear you won't regret it.

All times are GMT -5. The time now is 07:01 AM.