LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-12-2005, 10:07 PM   #16
djohnston
LQ Newbie
 
Registered: Oct 2005
Location: Edmond, OK
Distribution: SuSE 10
Posts: 9

Rep: Reputation: 0
poking around


Man, this is getting strange. Did you see darkroom7's earlier post where he said "i had to edit /etc/modprobe.d/nvidia and comment out the option line that mentioned NVreg_DeviceFileUID (the only line in my file)."?
So you found a pre-installed "nvidia" driver in SUSE10, huh? Hmmm. I'm going to do some digging around on my system. I may have a second driver "lurking". I never ran xorgcfg or xconf (on Slax it's xconf for Xorg). My driver is still 3D functional, BUT my monitor is flickering with visible scan lines no matter what resolution I select. This has never happened on any other distro. I know my SCSI controller shares IRQ5 with the GeForce2 card, but like I said, the flickering's never been an issue before.

CL-1, can you do me a favor? Can you send a copy of your xorg.conf file to djohnston999 @ yahoo DOT com? Maybe I can find an error in my file that's causing this. Also, the card I'm using is a GeForce2 GTS. (I've noticed a lot of variations of GeForce2).

Thanks, and congrats!
 
Old 11-13-2005, 07:49 AM   #17
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, Further weirdness:

I've now rebooted my machine for the first time. And lo and behold it couldn't start X. Running xorgconf listed that there were 2 drivers named "nvidia" listed. I now really don't understand what is going on. So I tried darkroom7's suggestion of commenting out the line in /etc/modprobe.d/nvidia. Still nothing.

So I unloaded the driver the correct way

#nvidia-installer --uninstall

and re-ran the install script

#NVIDIA-Linux-x86-1.0-7174-pkg1.run

This compiled and ran and upon switching to init 5 X started as normal with 3D suport. I notice in sax2 the checkbox for enable 3D support is checked but greyed out (so that it can't be turned off).

So I have one thing to say and that is - eh?

I don't really fancy having to unload, recompile and reinstall this everytime I boot my machine.

I'm going to try adding that script you to my boot.local although I don't see that it'll have any effect as the devices that it creates are already there. I've checked the Suse forums too and I'm also going to do the 2 things that were suggested

1) move /etc/modprobe.d/nvidia to /root
2) add the following two lines to /etc/udev/static_devices.txt
nvidia0 c 195 0 644
nvidiactl c 195 255 644

After I reboot my machine I'll tell you all how it went tomorrow.
 
Old 11-14-2005, 12:44 PM   #18
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Well I've rebooted and now if I have the nvidia driver enabled in my xorg.conf it hangs at the login screen. The user and password boxes appear but without the user name preentered. The cursor doesn't blink. The keyboard is totally unresponsive. The mouse pointer is there but won't repsond to clicks. If I reboot (to safe mode) and select the nv driver everything is fine.
 
Old 11-14-2005, 02:29 PM   #19
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Well I've changed everything back (removed the 2 lines from static_devics.txt and removed the script from boot.local). And the hanging problem still occured. I then noticed that there were many extra options for the nvidia driver set in my xorg.conf that I hadn't put there, I think at some point when I ran sax2 it added these options so I removed them and switched between run levels. Still no joy. I uninstalled the nvidia drivers, recompiled and installed them and it works again but now I'm afraid to shutdown my machine

Given that there were those extra options in my xorg.conf then I effectively haven't tested either the static_devices or the boot.local edits on there own. So at some point I'll try them individually and see if they help.
 
Old 11-15-2005, 05:10 AM   #20
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, rebooted the machine. X didn't start. Checked if the various devices made by the makedevices.sh script were present. They were not. Ran the makedevices.sh script. Switch to runlevel 5 and everything ran fine. So it would seem that a lack of those devices is the problem. The script tries to make devices in /dev/ and /etc/udev/devices/. I notice that in a clean Suse 10 install there is no /etc/udev/devices/. Anyway running the script and creating the devices in only /dev/ worked for me. So I've added the script to my /etc/rc.d/boot.local.

Instead of adding the contents of the makedevices.sh script to your boot.local file a cleaner way to add the script would be to do the following. Ensure the NVIDIA-Linux-x86-1.0-7174-pkg1.run installer is in the root directory

#cd /root
#NVIDIA-Linux-x86-1.0-7174-pkg1.run --extract-only
#echo "#Creating nvidia devices\necho 'Creating nvidia devices'\ncd /root/NVIDIA-Linux-x86-1.0-7174-pkg1/usr/src/nv\n./makedevices.sh\n"

Of course if that echo doesn't work you could add the lines to your boot.local like this:

#Creating nvidia devices
echo 'Creating nvidia devices'
cd /root/NVIDIA-Linux-x86-1.0-7174-pkg1/usr/src/nv
./makedevices.sh
 
Old 11-15-2005, 03:21 PM   #21
powerlifter450
Member
 
Registered: Feb 2005
Posts: 57

Rep: Reputation: 15
This has happened a few times in the past. What happens is that the nvidia drivers have no pre compiled kernel modules to use with the new kernel. there seems to be an easy fix to this. log in as root in console mode /usr/src/linux

run make oldconfig or make menuconfig or make xconfig

don't change anything. save and close. now cd to the nvidia driver package. type sh NVIDIA-Linux-whatever whatever.run

now it accept the agreement no it will complain about no kenel module. then it uninstalls the old driver then it installs the new nvidia driver. in your WM start sax2 enable 3d then test then finalize and your all set.
 
Old 11-16-2005, 04:06 AM   #22
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks powerlifter450 but the problem isn't that I can't install and run the 3D acceleration for the card. Given and fresh install of suse on the first boot I can compile, install and correctly configure the card as per the instructions from Nvidia. The problem is that when I reboot the machine afterwards runlevel 5 is unable to start X (even though it was previously working). Also, when it worked, using sax2 to configure the card never worked for me, manually editing my xorg.conf did. And, if you read through the nvidia installer script, I'm pretty sure that the installer does not uninstall the old driver, if there is an nvidia driver present it merely writes over it.

Anyway you'll be pleased to know that I now have this working with the card coming up correctly at boot time. The way I got it to work (installing legacy drivers) was to do the following, assuming this is the first install of the driver, ensure the NVIDIA installer script is in the root directory then, as root:

# init 3
# cd root
# NVIDIA-Linux-x86-1.0-7174-pkg1.run --extract-only
# NVIDIA-Linux-x86-1.0-7174-pkg1.run

Then accept everything and let it compile the module and kernel interface. Next, don't use sax2, follow the instructions for editing your xorg.conf file as provided in the nvidia read me. That is, open /etc/X11/xorg.conf and make the following edits:

1) In the "module" section ensure Load "glx" is present and REMOVE Load "dri"
2) In the "Device" section change Driver "nv" to Driver "nvidia"

Next edit your /etc/rc.d/boot.local Add the following lines, as written, to the end of the file (the leading # in this section adds a comment line to the boot.local, it isn't supposed to indicate a command line input):

#Creating nvidia devices
echo 'Creating nvidia devices'
cd /root/NVIDIA-Linux-x86-1.0-7174-pkg1/usr/src/nv
./makedevices.sh

Finally switch back to the graphical interface:

# init 5

Last edited by CL-1; 11-16-2005 at 04:07 AM.
 
Old 11-17-2005, 03:23 AM   #23
TigerLinux
Senior Member
 
Registered: Sep 2005
Location: Kuala Lumpur, Malaysia
Distribution: Ubuntu 11.04
Posts: 1,731

Rep: Reputation: 30
My question, shall i buy nvidia or ATI-radeon graphic card if i wanna use Suse ?
Suse supports which one better ?
 
Old 11-17-2005, 02:41 PM   #24
powerlifter450
Member
 
Registered: Feb 2005
Posts: 57

Rep: Reputation: 15
personally I like nvidia because I can run project looking glass with thier cards.
 
Old 11-17-2005, 03:39 PM   #25
jdblick
Member
 
Registered: Sep 2004
Distribution: SUSE 10.0 OSS
Posts: 261

Rep: Reputation: 30
I wonder how much support and whatever M$ promises NVidia and ATI for all these problems we have.
 
Old 11-19-2005, 09:35 AM   #26
TigerLinux
Senior Member
 
Registered: Sep 2005
Location: Kuala Lumpur, Malaysia
Distribution: Ubuntu 11.04
Posts: 1,731

Rep: Reputation: 30
Why?
The driver should be opensource.
Anyway, does suse supports nvidia's chipsets well?
 
Old 11-19-2005, 11:52 AM   #27
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
ATI made the interface for their 3D cards opensource. Nvidia have not. Nvidia have provided enough information about there cards to allow for a basic driver to be built (the nv driver) but the controls for their 3D graphics routines remain closed source. When you compile the Nvidia driver you're actually compiling a small piece of code that acts as an interface between the kernel and their binary (closed source) library/driver/thingy. So at a push, I suppose you might find that the ATI cards have better support than Nvidia in linux.

In practical terms if you have a recent graphics card and the latest drivers and you follow the instructions you'll rarely have any problems with either ATI or Nvidia cards. The only reason I was having a problem was because I was trying to get an old card and old (unsupported) driver to run in the latest Suse and clearly there are some subtle differences in Suse 10 to the verson of Suse the old nvidia installer was designed to run with.

Last edited by CL-1; 11-19-2005 at 11:57 AM.
 
Old 11-19-2005, 11:55 AM   #28
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Oh yes one thing I forgot to mention. If you have installed an old unsupported nvidia driver in Suse 10 you should run YOU and switch the latest nvidia drivers to "never download".
 
Old 11-19-2005, 03:06 PM   #29
adams5400
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
Sorry if this disrupts the thread. But I've reached a state of ecstasy at having finally solved my NVidia driver problem in OpenSuSE. I'm relatively a newbie so this might not be anything, but I thought I'd post it if it has the slightest chance of saving someone grief.

I just did a couple simple things and now my NVidia driver is running. I have glx, anyway, which I didn't have with the "nv" driver. Here's what I did:

1) Logged out of my xserver and went to "init 3" as root

2) Ran "nvidia-installer --uninstall" to clear out any manual installs. I assume the YOU installed version is not affected by this but I don't really know.

3) Ran "you" from the terminal as root, selected "Reload Patches from Server", and filtered the resulting list to see all installed patches (Filter "Installed Patches" I think).

4) Found the NVidia installer in the list, either install it ("i") or update it (">").

5) Back at the command line:
cd /lib/modules/2.6.13-15-default/kernel/drivers/video/
ln -s /lib/modules/2.6.13-15-default/kernel/drivers/video/nvidia/nvidiafb.ko
mv nvidiafb.ko nvidia.ko

I had to do this, I assume, because modprobe couldn't find "nvidia.ko" in the .../drivers/video directory

6) Edit XF86Config as follows:
cd /etc/X11
cp /etc/X11/XF86Config /etc/X11/XFConfig.backup (or whatevery you want to call it, just in case)
vi /etc/X11/XF86Config

Search down until you find Section "Devices". Mine looks like this:

Section "Device"
BoardName "RIVA TNT2 Model 64/Model 64 Pro"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection

And my Section "Module" looks like this:

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Save that and exit.

7) Run "init 5"


And it worked. As you can see, I have an old card, but if it workd for a RIVA, hopefully it'll work for newer cards. I suspect step 5 was most important, and that XF86Config was properly configured. The weird thing is, when I lsmod, I don't see anything that looks like my nvidia driver. Maybe once I reboot? I'm afraid to reboot. Pray for me.

Adam
 
Old 11-25-2005, 06:48 PM   #30
dasbooter
Member
 
Registered: Mar 2005
Posts: 122

Rep: Reputation: 15
I had the same problem as darkroom on running sax2 -m 0=nvidia (everybody say it with me now "0 is a digit not a letter ...and all your base" I have fatal error: yada yada no screen you suck go back to windows xp
pls to check var/log yada yada

checked log ,still says you suck and do dmesg
this is a rather long log how does grep work again uhm oh well same symbol problem as dark room comment out line in modprobe.d
I had a few other lines in modprobe.d as well
ran sax2(worked for me not for darkroom I guess) again which said something about not liking those other lines in modprobe.d but gloriously the nvidia splash screen came up configured then init 5 and away I go to correct the other weirdness brought on by the suse 10.0 upgrade from 9.3 ....man a (semi?)working beagle is cool but this was not worth it.

Clean installs are the way to go but linux installs are built over time and you fall in love with what you have
oh by the way I ran the bash script in this thread previous to commenting out the lines in modprobe.d as I wanted to see if that helped, just thought I would mention that ....losing interest...fading attention span.... Im out
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia nforce driver installation problem Wozl SUSE / openSUSE 1 07-25-2005 08:58 AM
yet another nvidia driver installation problem sbboy Linux - General 4 10-30-2004 01:28 AM
Yet another nvidia driver installation problem sbboy Mandriva 1 10-24-2004 09:12 AM
NVIDIA Installation problem! plz help! samuelgomes Linux - Hardware 2 04-22-2004 11:00 AM
Nvidia Installation problem Gruzzen Debian 3 11-18-2003 12:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 09:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration