LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-04-2005, 10:23 PM   #1
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Rep: Reputation: 0
Suse 10.0 nvidia installation problem


Hi,

I hope someone can help. I've just installed a completely fresh install of suse 10.0 and I can not get my nvidia GeForce graphics card to work properly (no 3D support). My previous linux install was Fedora 3 and 3D graphics it worked fine.

As per the instructions on the Suse site I used 'you' to install the drivers and then used
#sax2 -m 0=nvidia
to configure X. Checking xorg.conf everything is configured properly (driver="nvidia") but still no 3D support.

So I decide to try the more recent instance of the drivers at nvidia's website. This is the way I used to do it when I was running fedora. So;

I downloaded NVIDIA-Linux-x86-1.0-7676-pkg1.run
Then I switched to run level 3 (init 3)
And ran NVIDIA-Linux-x86-1.0-7676-pkg1.run
I accepted the agreement

At this point it stopped telling me that it didn't have a suitable interface precompiled (does it ever?) It then throws the message:
"unable to load nvidia.ko. Most likely because the kernel was built using the wrong kernel source."
And that it couldn't find my kernel source to build a new one or that my kernel source does not match the running kernel and if I know where the kernel source is installed I can give it the path with the --kernel-source-path option.

I was pretty sure I had installed the kernel-source package and that it matches my running kernel so I checked

# ls /lib/modules/`uname -r`/build/include/linux/version.h
This is successful and I have a /usr/src/linux that is linked correctly to /usr/src/linux-2.6.13-15 so I tried
#uname -r
This returns "2.6.13-15-default" so I have the correct kernel sources.

All well and good so I tried running NVIDIA-Linux-x86-1.0-7676-pkg1.run again with the correct options
# NVIDIA-Linux-x86-1.0-7676-pkg1.run --kernel-source-path=/usr/src/linux/

But to no avail it still tells me that it can't find my kernel source or that my kernel source does not match the running kernel.

I have even tried unpacking the nvidia script and compiling the driver on the command line but even that fails.

Can anyone see what I'm doing wrong or what I might be missing?

This is especially annoying as with fedora my graphics were fine but my sound card was flaky but now my soundcard is fine and the graphics are failing.

If I manage to work it out I'll post my solution.

Thanks.

Last edited by CL-1; 11-04-2005 at 10:35 PM.
 
Old 11-04-2005, 10:37 PM   #2
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
I have just tried running the older NVIDIA-Linux-x86-1.0-7667-pkg1.run package. It seems to do a little more. Again it complains that it can't find a suitable precompilied kernel interface and then goes on to build/compile one, a progress bar even fills up from 0 to 100 suggesting some manner of compiling is going on. However it once again goes on to throw the same error:

"unable to load nvidia.ko. Most likely because the kernel was built using the wrong kernel source."
 
Old 11-04-2005, 11:51 PM   #3
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, I've now discovered that my graphics card is sufficiently old that it is no longer supported by nvidia and that they advise installing an older release of their drivers. So I downloaded
NVIDIA-Linux-x86-1.0-7174-pkg1.run, switched to runlevel 3 and ran it

This appears to run fine. It builds a module and installs it. However now if I try to run sax2 as

sax2 -m 0=nvidia

It dies and advises me to check the logs the output of /var/log/SaX.log is:

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

My /var/log/Xorg.0.log reads:

(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

I have tried manually editing my xorg.conf to the following

Section "Device"
BoardName "GeForce2 GTS/GeForce2 Pro"
BusID "1:5:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection

But trying to start run level 5 just fails.
 
Old 11-05-2005, 04:51 AM   #4
djohnston
LQ Newbie
 
Registered: Oct 2005
Location: Edmond, OK
Distribution: SuSE 10
Posts: 9

Rep: Reputation: 0
I've had the same problem with a fresh openSUSE 10.0RC1 install (see thread "How do I install nVidia 3D driver on openSUSE10.0?"
http://www.linuxquestions.org/questi...hreadid=378848)

To go into a little more detail, I tried the 7676-pkg1.run and got a "legacy" card error message. (I'm running a "lowly" GeForce2). I then ran the 7174-pkg1.run file. After answering the nVidia EULA, I got an error message "No precompiled kernel interface was found to match your kernel. Would you like to download a precompiled kernel from ftp://download.invidia.com?" I wasn't connected to the internet, so I answered NO. The .run file then "compiled" and new interface, or appeared to, the progress bar went to 100%, and the script said it has finished its job successfully. It said for SuSE, to run sax2. So I ran modprobe nvidia and then sax2 -m 0=nvidia. Sax2 gave the error "xc:could not start configuration server".
WONDERFUL!
So I checked the /etc/X11/xorg.conf file for "nvidia" driver, and edited /etc/inittab back to runlevel 5. Then I rebooted. On reboot, I got errors as soon as xserver tried to start. Two of the screen errors were: "FATAL:Error inserting nvidia (/lib/modules/2.6.13-8-default/kernel/drivers/video/nvidia.ko):
Unknown symbol in module, or unknown parameter (see dmesg).",
& "(EE)NVIDIA(0):Failed to load the NVIDIA kernel module!".
Again, WONDERFUL!
So, still in runlevel 3, (non-GUI), I logged in as root. Then I edited /etc/X11/xorg.conf back to "nv". Then I did an init 5. That started the xserver again, and I logged in as user. I then did a "Find Files" from K-Menu for "nvidia.ko" starting from //. Nothing. Just to double-check, I opened a terminal, su'ed to root, and rebuilt the locate database. Then, still as user "root", I did a locate nvidia.ko.
Again, nothing. No wonder the nvidia.ko module can't be inserted. I'd like to insert it somewhere!!

I'm gonna watch your thread and mine. I've already encountered some clues from user "usaf_sp". Check out his thread of:
http://www.linuxquestions.org/questi...hreadid=379305
for more clues. He seems to be knowledgeable about openSUSE 10.0. From trial and error?


 
Old 11-05-2005, 08:09 AM   #5
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, I finally solved this problem.

Having installed packages 7676 and 7174 I was still unable to start an x server with driver="nvidia". So I went to wiki.X.Org as suggested in /var/log/SaX.log and looked up the "no screens found" error. There wasn't much there but it did suggest switching to runlevel 3 (init 3) and running either "x -configure" or xorgcfg. I ran xorgcfg and it failed complaining that there were conflicting nvidia divers of the same name. So I used "nvidia-installer -uninstall" to remove the last driver I'd built leaving only 1 behind. Switching to runlevel 5 yielded no joy.

Having looked around the internet a bit more I discovered someone's rant about what the install process does. (Apologies for henious paraphrasing): the install process for the nvidia drives overwrites your opengl libraries (and some other bits) with nvidia's versions. And moves your original ones to a dummy location. So should you uninstall them it puts back the originals. But what I appear to have done was install the 7676 libs (moving the originals to the dummy location) and then had over written those with the 7174 libs. But the installer doesn't keep track of which are the real libs so the 7174 module copied the 7676 libs over the originals. So in actual fact I had no easy way to go back to the original opengl config. In fact I have no way of telling which other libs were also affected.

My solution was to reinstall Suse 10 from scratch. Which wasn't very painful as it was a fresh (relatively) unconfigured installation anway and then ONLY install the 7174 nvidia drivers. I kind of sucked but it was still quicker than spending another 3 hours looking for a soluton on the internet.

Everything now works, except for an old harddrive that appears to have died during the reinstallation process but it was on it's way out anyway.

By the way I too am running an old GeForce 2 card.
 
Old 11-05-2005, 08:29 AM   #6
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
Re: Suse 10.0 nvidia installation problem

Quote:
Originally posted by CL-1
At this point it stopped telling me that it didn't have a suitable interface precompiled (does it ever?)
well it depends on what distro you are using, yes most of them do not include the kernel-source packages but the one i use, Archlinux, does, by default with the base install. and arch has a wonderful nvidia driver package so you do not have to go to nvidia to get it. they have the newest one and the legacy one (7174) all packaged up and ready to install. you still have to edit the xorg.conf file, but it sure makes it a whole heck of a lot easier to install. no more errors about not having the kernel-source or wrong compiler anymore.

anyway, glad you got it working, dont know why suse makes this so hard
 
Old 11-06-2005, 07:44 AM   #7
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Re: Re: Suse 10.0 nvidia installation problem

Quote:
Originally posted by jsmarshall85
anyway, glad you got it working, dont know why suse makes this so hard [/B]
Well I spoke too soon. Everything was running fine but now after the first reboot the graphics driver won't load.
 
Old 11-06-2005, 10:50 AM   #8
Elfod
LQ Newbie
 
Registered: Oct 2005
Location: London, UK
Distribution: SUSE 32 & 64 Bit
Posts: 11

Rep: Reputation: 0
Try using the nvidia installer script fetchnvidia.sh.

You can install and run it automagically from Software Update in Yast. This worked flawlessly for my bleeding edge 7800GTX card.
 
Old 11-06-2005, 10:18 PM   #9
djohnston
LQ Newbie
 
Registered: Oct 2005
Location: Edmond, OK
Distribution: SuSE 10
Posts: 9

Rep: Reputation: 0
unsuccessful

I reinstalled openSUSE 10.0 RC1 today, and re-ran the 7174 binary installer. I wish I could tell you I was successful like you were, but I wasn't. I got no errors whatsoever during the install, sax2 ran, but when I rebooted, I was in run level 3.
So I could get back to the GUI, I edited /etc/X11/xorg.conf and changed driver from "nvidia" back to "nv". I'm going over to the SUSE forums site to submit the error logs. Installing 3D driver for GeForce2 "legacy" graphics card shouldn't be THIS difficult.
 
Old 11-07-2005, 12:06 AM   #10
djohnston
LQ Newbie
 
Registered: Oct 2005
Location: Edmond, OK
Distribution: SuSE 10
Posts: 9

Rep: Reputation: 0
SUSE forums

Just returned from SUSE forums. Seems everyone with nVidia "legacy" cards are having problems. Reportedly, SUSE is "working on it". Check these two ditties I found over there:

"I had the same exact symptoms with my nVidia card (GEForce2) that is now relegated to legacy. If I run the NVidia installer, I can start up X without problems using the "nvidia" driver. I extracted the installer script and found a script that will fix the problem instead of having to run the installer. From the driver directory, the file is ./usr/src/nv/makedevices.sh which has the contents of:

#!/bin/sh

error() {
echo "$(basename $0): fatal error, $1 failed"
exit 1
}

if [ ! -c /dev/.devfsd ]; then
for i in 0 1 2 3 4 5 6 7; do
node="/dev/nvidia$i"
rm -f $node
mknod $node c 195 $i || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
done
node="/dev/nvidiactl"
rm -f $node
mknod $node c 195 255 || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
fi

if [ -d /etc/udev/devices ]; then
for i in 0 1 2 3 4 5 6 7; do
node="/etc/udev/devices/nvidia$i"
rm -f $node
mknod $node c 195 $i || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
done
node="/etc/udev/devices/nvidiactl"
rm -f $node
mknod $node c 195 255 || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
fi

exit 0
# end script

This script sets up several devices, but I'm not sure how to read BASH scripts. However, if this script is run before starting X, X will start--assuming nVidia legacy card w/nVidia driver 7174 installed.

Evidently, the directions on the SUSE website for installing legacy nVidia cards needs more information than just editing the /etc/udev/static_devices.txt file."

AND this one:

"A quick an maybe dirty workaround is:
Log in as root and copy the script above into

/etc/init.d/boot.local

and save the file.

For Legacy-cards, load down the lastest usefull driver from Nvidia.com (NVIDIA-Linux-x86-1.0-7174-pkg1.run). Switch as root into Runlevel 3 (init 3) and run the Driver-script.

After installation type:

switch2nvidia

type

sax2

and do the your configurations (by default, agp-support seems to be disable, change it to 3)

Test your settings and save it. After the next start of xserver, you got 3D-power.

I've tested the desciption with an old ELZA III and it works. "

Food for thought. I'm gonna keep trying. B4 I forget, is your card PCI or AGP? Notice where the second post says "and do the your configurations (by default, agp-support seems to be disable, change it to 3)". I'm not sure what that means. Do you?

 
Old 11-08-2005, 06:14 PM   #11
darkroom7
LQ Newbie
 
Registered: Nov 2005
Posts: 2

Rep: Reputation: 0
i just made it past the same basic problem a lot of people are having with SUSE 10 and nVidia. i have 2 nvidia cards, a geforce2 mx and a riva tnt2 (now legacy). i needed to switch to the 7174 driver so i downloaded it and built it fine but had problems loading it into the kernel. modprobe nvidia complained about missing symbols or invalid parameters. checking dmesg revealed the problem was with NVreg_DeviceFileUID. this must be some parameter/function available in newer versions of the nvidia driver but not 7174. i had to edit /etc/modprobe.d/nvidia and comment out the option line that mentioned NVreg_DeviceFileUID (the only line in my file). after that i could insert the nvidia module into the running kernel with modprobe. i tried to run sax2 -m 0=nvidia after that but it didn't work. i just made sure that the /etc/X11/xorg.conf file listed the "nvidia" driver and not the "nv" driver and did init 5 and X started up just fine, both cards using nvidia-7174. hope this helps.
 
Old 11-08-2005, 09:48 PM   #12
djohnston
LQ Newbie
 
Registered: Oct 2005
Location: Edmond, OK
Distribution: SuSE 10
Posts: 9

Rep: Reputation: 0
GeForce2 working now!

Thanks, darkroom7. I finally got 3D working, but I did it differently than you What I did SHOULD work for CL-1, as well. I copied the bash script shown in this thread to /etc/init.d/boot.local. Then I jumped to runlevel 3 and ran the 7174.pkg1.run installer. Then I issued the command "switch2nvidia". Then I ran SaX2. I then rebooted and logged in as the user. I'll tell you what, I've learned a lot about the nVidia installer, SaX2, and xorg.conf and inittab files.

CL-1, I hope you didn't give up. I finally got my card working. I don't know if I'll have to re-configure after a kernel update, or not, but except for re-creating the bash script, I can now install Nvidia driver in my sleep!
 
Old 11-09-2005, 03:16 PM   #13
darkroom7
LQ Newbie
 
Registered: Nov 2005
Posts: 2

Rep: Reputation: 0
this is so strange. i guess i'm missing something. i had to reboot today and when it came back up Xorg failed to start. i got the no screens error. lsmod showed the nvidia module was installed. i don't get it. i just re-ran NVIDIA-Linux-x86-1.0-7174-pkg1.run, let it recompile the nvidia module, then i did modprobe nvidia to install it in the kernel. init 5 started up Xorg just fine. i don't know what the deal is, but rebuilding the module got it back up.
 
Old 11-09-2005, 10:02 PM   #14
djohnston
LQ Newbie
 
Registered: Oct 2005
Location: Edmond, OK
Distribution: SuSE 10
Posts: 9

Rep: Reputation: 0
bash script

Darkroom7,
Try inserting the bash script shown earlier in this thread into the file /etc/init.d/boot.local. Unless you've already added something to it, the file most likely contains only comments. After doing so, reboot and see if that works. It did for me.
I found those instructions posted on the SUSE forums.
 
Old 11-12-2005, 12:44 PM   #15
CL-1
LQ Newbie
 
Registered: Nov 2002
Location: London
Distribution: Suse 8.0
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, I believe that I've finally solved this problem.

When I installed Suse the first time I ruined everything by installing the latest and legact nvidia drivers. If I ran xorgcfg (in runlevel 3) there were two drivers labelled nvidia listed as available to X and it couldn't resolve which to use.

I then tried reinstalling Suse so that I was starting from scratch and installed only the legacy driver. No joy this time either. Xorgcfg still listed there being 2 nvidia drivers. I couldn't work that out but maybe I didn't tell it to totally reformat the file system when I reinstalled Suse.

Resigning to defeat I installed Fedora Core 4 but it had it's usual problems with sound and video setup and it wouldn't let me connect to my wireless router for more than 30 seconds at a time. After an evenings playing around with it I decided to return to Suse (which I prefer).

I reinstalled Suse 10 last night and made sure I set it to completely repartition and reformat the hard drive. When I booted up I, switched to run level 3 and ran xorgcfg. There was already a driver listed called nvidia (as well as the normal nv driver). This seemed odd to me, clearly Suse 10 must already have a compiled nvidia driver (and my earlier assumption about not having correctly formatted the HD the second time round was wrong). My solution was just to move this driver out the way

#mv /usr/X11R6/lib/modules/drivers/nvidia_drv.o /root

Then I ran the legacy nvidia installer script (which ran and compiled correctly) and I then manually edited my xorg.conf (rather than using sax2). Switching to runlevel 5 and everything appears to be fine although I have yet to reboot my machine but I don't forsee any problems.

Oh and one thing I did notice on my rather aged machine Suse 10 boots significantly faster than Fedora (core 1, 2 and 4)

Last edited by CL-1; 11-12-2005 at 01:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia nforce driver installation problem Wozl SUSE / openSUSE 1 07-25-2005 08:58 AM
yet another nvidia driver installation problem sbboy Linux - General 4 10-30-2004 01:28 AM
Yet another nvidia driver installation problem sbboy Mandriva 1 10-24-2004 09:12 AM
NVIDIA Installation problem! plz help! samuelgomes Linux - Hardware 2 04-22-2004 11:00 AM
Nvidia Installation problem Gruzzen Debian 3 11-18-2003 12:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 11:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration