LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Speedtouch 330 silver and 9.2 one more time (https://www.linuxquestions.org/questions/suse-opensuse-60/speedtouch-330-silver-and-9-2-one-more-time-304386/)

Syringe 03-21-2005 01:51 PM

Speedtouch 330 silver and 9.2 one more time
 
I've already read all the topics on speedtouch in these forums, and numerous howto's and etc...

All of this is driving me crazy. I've spent a whole week trying to make it work. I just wanna give up on everything.

Ok so I'm on Suse 9.2 and I have speedtouch 330 silver. I did so many combinations and configuring that I think I'll simply reinstall the whole system.

Now for those who managed to make it work, please explain it to me, step by step. Wheter you used speedtouchconf or drivers. I need your personal experience with this one. Since some are saying use this, use that. I know rev4 is the one to use but I'm not sure in anything anymore.

Please you're my last hope.

ahh 03-21-2005 02:11 PM

I dont know if you've tried this one, but it worked for me. (PPPoATM)

http://linux-usb.sourceforge.net/SpeedTouch/suse/

Good luck!

Syringe 03-21-2005 04:41 PM

I've tried it, it didnt work out for me :(

Proud 03-21-2005 04:57 PM

Well I'll let you know that the rev4 modem/silver Speedtouch330 works, with Mandrake 10.0 and 10.1 and I've had it working for my pc and the family one for months now. I forget exactly how I set it up but as I'll be messing with a new pc in the next few weeks of this holiday I'm sure I'll go over it all again. I know I've not used the speedtouchscript but instead a Mandrake .rpm package. My last relevent post on the subject seems to be here.
Your best bet is to get at least the modem_run to execute with the -v 2 very verbose mode so you can see where things are going wrong. :)

Syringe 03-21-2005 06:02 PM

@proud - well the problem is that I have to jump on win in order to post :(

The problem with speedtouchconf is error 250 from modem_run:

Quote:

If you've run the script twice in a row, this is normal. The firmware can only be loaded once (without powering down the modem, either by rebooting, or disconnecting the modem and re-connecting it). The script only needs to be run once (assuming it is succesful).
:rolleyes: ...right

Quote:

If you do run the script twice, check /etc/ppp/chap-secrets (and pap-secrets) for duplicate entries - these should not matter, unless you entered an incorrect login/password at any point. The bundled undo.sh script will clean things up to the same state as before you ran the speedtouchconf.sh script.
I never ran it twice, unless it runs itself or something...I've checked for duplicate entries, my login/pass info is correct. Ran undo.sh dozens of time to clean up, I guess it didnt work out or something.

With the "ordinary" speedtouch drivers I get some error regarding microcode or something. I think I could get it working with speedtouchconf, but I just have to find the "missing link" in all this, I feel like I'm really close but still so far...

Proud 03-22-2005 12:15 PM

Ok, firstly boot your machine into linux without the modem connected.
Open a terminal, log in as root, and run
tail -f -n 30 /var/log/messages
Plug in the usb modem and copy what gets displayed.
You can use Ctrl+C to stop the log tailing.

Then lemmie know the result of running
modem_run -m -v 2 -f /path/to/microcode/mgmt.o


All times are GMT -5. The time now is 04:39 PM.