LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Sound Problems: CD works, no system/mp3/video sound (https://www.linuxquestions.org/questions/suse-opensuse-60/sound-problems-cd-works-no-system-mp3-video-sound-367824/)

tabnaka 09-28-2005 11:49 AM

Sound Problems: CD works, no system/mp3/video sound
 
Hi, I'm running the latest SuSE (use KDE). I have two sound cards, a SB card which is connected to my PC speakers, and another on-board card which I don't use.

The problem is:
1) I get no sound from the system, mp3's, or video
but,
2) I get perfect sound from CD's
3) I get perfect sound when I click the TEST button in YAST audio configuration window for the SB card.

One time yesterday I was clicking around and the sound started working (don't know exactly what I did), but when I restarted the computer the problems persisted. Also, I tried re-installing/re-configuring both sounds cards one at a time, but it did not fix the problem. Also, when I connect the PC speakers to the motherboard sound card, I still get no sound.

Anyone have any suggestions or prompt commands to run? Thanks
:scratch:

eka 09-28-2005 12:09 PM

Check mixer settings.Is PCM is On and volume it Up.CD maybe is connected with cable and doesn't use "software sound.
Be more specific what application has no sound?

tabnaka 09-28-2005 01:56 PM

How do I check if PCM is on? I'm not at home right now, but I'll check the mixer settings and get back to you. Also, none of the "standard" KDE media apps give any sound (amarok, jukebox, and Kaffine). Neither can I hear system sounds (opening/closing windows, sounds during start-up of KDE...)

eka 09-28-2005 03:06 PM

KDE uses ARTS.Check is ARTS installed and running.Check for ALSA,OSS,etc.
And if you have 2 sound cards listen to both of them because maybe sound playing on the other one.

tabnaka 09-29-2005 10:10 AM

Well I got my sound to work. It seems like whenever I have my Logitech Quickcam (USB web camera) plugged into my comp when booting up my sounds doesn't work thru the SB Live! card. But if I unplug the Quickcam during bootup and just either leave it unplugged or plug it in after SuSE and KDE load, my sound will work fine.

So how can I make sure that even if my USB web cam is plugged in the whole time (before booting) that my sound will still work?

Also I suggest that any other people having sound trouble try to disconnect any unnecessary peripherals, they may be interferring.

jasma12 01-13-2006 01:33 PM

KDE - No Sound / Video - any MP3/MPG/AVI
 

hey all. i'll save you all the trouble and tell you now that i am linux idiot. i just downloaded and installed suse linux 10.0 professional and have installed the KDE version. i've found myself around pretty easily and have manipulated my system to the way i want it to run for the most part. my problem is i have absolutely no sound when playing MP3's or avi's/mpeg's. i've downloaded MPlayer, but of course have no idea what to do with it. I've also downloaded the "essential" codec pack from the MPlayer site, and of course have no clue what to do with that either. All reference material i've seen says to put it in /usr/local/lib/codecs. there was no directory on my box named 'codecs' so i created one and put all the files from the Essential pack in it. i've used Kaffeine, Amorak and MPLayer: all with no luck. the system sounds, bootup and down, errors, etc all DO play system sounds; very clear, and very loud. can any of you brilliant linux users help out a n00b with a few basic linux problems? i just want to play my mp3's from my hard drive while i finish configuring Kerberos and Samba Client to add it to my WinTel A/D Domain! Have a heart and help out a linux dummie. :)
jasma12@gmail.com


All times are GMT -5. The time now is 04:08 PM.