LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-18-2009, 01:08 AM   #1
simjii
Member
 
Registered: Nov 2003
Distribution: SUSE 11.0 32bit and11.2 x86_64
Posts: 77

Rep: Reputation: 16
Unhappy Sooo slow Firefox on Suse 11.2


Just installed Suse 11.2 on a computer which was running on Suse 10.3.
After switching to 11.2 I realized that web page loading speed on Firefox is so slow. On the same network my 7 years old laptop can load the same page much faster and even my android smartphone. To load a web page first time it takes about 10 seconds on Suse 11.2 with firefox.
It is not just a specific web site problem.
Did anybody notice this problem or just me?
Is there any way to make Firefox faster. I even updated Firefox to 3.5.5 but no difference.

System info.
Suse 11.2 with KDE, wired network with dynamic IP.

Any help is appreciated.
 
Old 11-18-2009, 04:35 AM   #2
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 4,064

Rep: Reputation: 894Reputation: 894Reputation: 894Reputation: 894Reputation: 894Reputation: 894Reputation: 894
Do you have both ipv4 and ipv6 enabled?
 
Old 11-18-2009, 09:24 PM   #3
simjii
Member
 
Registered: Nov 2003
Distribution: SUSE 11.0 32bit and11.2 x86_64
Posts: 77

Original Poster
Rep: Reputation: 16
Yes both were enabled.
I just disabled ipv6 but it dose not seem helping.
Should I disable ipv4 instead ipv6?
 
Old 11-18-2009, 11:58 PM   #4
simjii
Member
 
Registered: Nov 2003
Distribution: SUSE 11.0 32bit and11.2 x86_64
Posts: 77

Original Poster
Rep: Reputation: 16
I think problem is solved.
It is caused by Firefox configuration. A simple solution is disabling ipv6 support in Firefox.
It has nothing to do with ipv6 in network setting.
The same problem was already reported on early version of Suse but i didn't have this problem with 10.3.
Here is how to disable ipv6 in Firefox. Taken from the thread linked below.

enter in FF address bar:
about:config
(no spaces above)
in the search bar inter ipv6
change the vaule of
network.dns.disableIPv6
from false to true

http://www.linuxquestions.org/questi...-wrong-408058/

Last edited by simjii; 11-19-2009 at 12:00 AM.
 
1 members found this post helpful.
Old 11-28-2009, 03:13 PM   #5
Cogar
Senior Member
 
Registered: Oct 2005
Location: It varies, but usually within 100 feet of a keyboard.
Distribution: Fedora 10, Kubuntu 8.04, Puppy 4.1.2, openSUSE 11.2
Posts: 1,126

Rep: Reputation: 51
Thank you for posting the solution, simjii. It made a huge difference for me.
 
Old 11-28-2009, 03:17 PM   #6
terryxela
Member
 
Registered: Dec 2006
Location: Denver, Colorado, USA
Distribution: SuSE 11.3
Posts: 125

Rep: Reputation: 17
Quote:
Originally Posted by simjii View Post
I think problem is solved.
It is caused by Firefox configuration. A simple solution is disabling ipv6 support in Firefox.
[/url]
The problem may be a little more complex than your approach and may show in other way like in the software manager, wget, etc.
Look at

https://bugzilla.novell.com/show_bug.cgi?id=547658

A quick test would be to enable ipv6 under firefox and add the DNS servers either from you isp or public dns
208.67.222.222
208.67.220.220
and then run firefox and see if it fix it.

If that is the case they are working on to fix it.

-=terry=-
 
1 members found this post helpful.
Old 11-28-2009, 05:29 PM   #7
simjii
Member
 
Registered: Nov 2003
Distribution: SUSE 11.0 32bit and11.2 x86_64
Posts: 77

Original Poster
Rep: Reputation: 16
terryxela

You are right. I just did quick test to reproduce the bug.
As reported in the bug linked in your post I can speed up firefox by adding
"options single-request" in /etc/resolv.conf.
I also realized that SUSE 11.0 doesn't seem to have this problem.
There is no difference in network setting and Firefox ipv6 setting between 11.0 and 11.2 on my computers but Firefox is so slow to look up pages only on 11.2.
Disabling ipv6 on Firefox is only a temporary work around.
 
Old 11-29-2009, 09:49 AM   #8
terryxela
Member
 
Registered: Dec 2006
Location: Denver, Colorado, USA
Distribution: SuSE 11.3
Posts: 125

Rep: Reputation: 17
The best work around would be

1. enable ipv6 in firefox

2. remove the extra line in resolv.conf.

so you are back to the beginning ;-)

3. find out the dns servers from your isp. In my case I just enter the ip address of the router http://192.168.0.1 on firefox. This open the router and I can get the 2 dns from there.

4. open yast/network devices/network setting
/global options and enable traditional method with ifup then
/hostname/DNS an enter the ip of the 2 DNS from your isp under Name Server 1 and Name Server 2.
Of course you can enter instead the public DNS but I do not think is right, I just keep the public DNS in case the isp DNS has a problem. Of course you can added as a Name Server 3 and it will not be utilize except if the other 2 fail

Now you should be OK. This procedure make your system as if would not have the bug. Everything should work well. The only downside is that the knetmanager is not enable but if it is a workstation you do not need it any way. It is is a laptop you have to do another step before connecting.

-=terry=-

Note: the cause of the bug is in Petr message #12 of

https://bugzilla.novell.com/show_bug.cgi?id=549447

Last edited by terryxela; 11-29-2009 at 09:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 01:17 PM
Laptop Touchpad Sooo Slow? Corallis Linux - Laptop and Netbook 3 01-19-2006 07:57 PM
Suse Opera/Firefox slow? caulfiek SUSE / openSUSE 11 12-25-2005 03:43 AM
Internet sooo SLOW! j.vilon Linux - General 34 10-18-2004 04:25 AM
Why is CL9.0 sooo slow???? bruno buys Conectiva 1 12-11-2003 11:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration