LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Software updater in SUSE 10.1 error (https://www.linuxquestions.org/questions/suse-opensuse-60/software-updater-in-suse-10-1-error-447234/)

riba43 05-21-2006 11:42 PM

Software updater in SUSE 10.1 error
 
I have the red icon with exclamation mark on my toolbar, which means that the software updater is running and when I click on it , it started to run the software update which ends with the following :Transaction failed: Package transaction failed: You do not have the required access level (superuser) for this method.

How do I turn on SU level???:confused:

david.dales 05-22-2006 01:52 AM

The first time you run it, it will ask you to add a privileged user. You probably overlooked that part.

In any case, you can look at "man rug" to add and adjust users. I think that updater is buggy though because, at least for me, sometimes it works and sometimes it doesn't.

riba43 05-22-2006 02:08 AM

Hi david,

No I did add a privileged user name when I started it the first time. Next update, it asked for a su name and password and since then it is as I have described. That is why I posted this thread. I also have a look at the thread which was posted at the same time as mine and read the following:
https://bugzilla.novell.com/show_bug.cgi?id=171171.
So I will wait till they repair the bug.

fragos 05-22-2006 09:38 PM

At the command line, "su" and login as root. Then enter "rug user-list" and you will see who is authorized for what privileges.

riba43 05-23-2006 12:21 AM

hi fragos,

i get this message:

bgorjup@bogomir:~> su
Password:
bogomir:/home/bgorjup # rug user-list

Username | Privileges
---------+---------------------------------------------------
bgorjup | subscribe, upgrade, install, refresh, view, remove

bogomir:/home/bgorjup #

I think i should be able to upgrade with rug.

fragos 05-23-2006 01:16 AM

I agree. I got virtually identical results. You could try "man rug" to all rug can do. I prefer to use GUI commands and only revert to CLI for investigation purposes or as a last resort. Having been a system software developer since 1964 I've learned that GUI tends to be more trouble free and successful.

david.dales 05-23-2006 01:23 AM

True, you can always still use the 10.0 method as well. I've found over the past 2 weeks that it seems to work better than the buggy tray icon. Yast > Software > Online Update.

riba43 05-23-2006 09:17 AM

This is what i get when try to use system installer:

Novell.Zenworks.Zmd.Public.ZenException: A transaction is already in progress

Server stack trace:
in <0x000a8> Novell.Zenworks.Zmd.Packaging.Transaction:Block (Boolean throwex)
in <0x0000d> Novell.Zenworks.Zmd.Packaging.Transaction:Block ()
in <0x0001d> Novell.Zenworks.Zmd.Packaging.PackageManager:Resolve (Novell.Zenworks.Zmd.Packaging.IResolvable[] installs, Novell.Zenworks.Zmd.Packaging.IResolvable[] upgrades, Novell.Zenworks.Zmd.Packaging.IResolvable[] removals)
in <0x0005b> Novell.Zenworks.Zmd.Packaging.RemotePackageManager:ResolveDependencies (Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] installs, Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] upgrades, Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] removals)
in <0x00000> <unknown method>
in (wrapper managed-to-native) System.Runtime.Remoting.RemotingServices:InternalExecute (System.Reflection.MethodBase,object,object[],object[]&)
in <0x00265> System.Runtime.Remoting.RemotingServices:InternalExecuteMessage (System.MarshalByRefObject target, IMethodCallMessage reqMsg)

Exception rethrown at [0]:

in <0x00a63> System.Runtime.Remoting.Proxies.RealProxy:PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception exc, System.Object[] out_args)

Brian Knoblauch 05-23-2006 09:49 AM

Quote:

Originally Posted by david.dales
True, you can always still use the 10.0 method as well. I've found over the past 2 weeks that it seems to work better than the buggy tray icon. Yast > Software > Online Update.

Ummm, that option no longer exists after I upgraded to 10.1!!!

There's an automatic online update option that doesn't appear to do anything. I did the register/configure thing and the automatic online update just comes up with a pretty empty box that I can click "finish" on. It has some text about adding a cron job, but it doesn't seem to actually do that.

I'd prefer to do manual updates anyways since it's a server. Unfortunately the old online update option is no longer in the menu :-( (I tried to run it manually too and the program doesn't seem to exist anymore).

fragos 05-23-2006 12:14 PM

The console command is "rug". "man rug" shows the numerous parameters. Rug dose install and update.

Micro420 05-23-2006 04:56 PM

I got the same error as you. The work around is to use the SuSE 10 online update. Unfortunately I forgot the command to do it. I found it randomly doing a google search.

anyone else remember the Yast command???


All times are GMT -5. The time now is 11:25 AM.