LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 08-22-2006, 04:17 AM   #1
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Rep: Reputation: 30
Smart update error


I did a smart update and got this error -
Code:
Fetching information for 'Latest KDE packages'...
-> http://software.opensuse.org/download/KDE:/KDE3/.../repomd.xml
repomd.xml                     ####################################### [ 48%]
error: Invalid XML file:
error:   /var/lib/smart/channels/suse-kde%%http:__software.opensuse.org_download_KDE:_KDE3_SUSE_Linux_10.1_repodata_repomd.xml
error:   http://software.opensuse.org/download/KDE:/KDE3/SUSE_Linux_10.1/repodata/repomd.xml
error:   mismatched tag: line 17, column 2
Is anyone else having this problem? Is it likely to be a temporary problem with the repo? I have had a similar error sometime in the past which resolved itself.
The thing is, last time I used suse my baby son got to the reset button and when I came to boot up next it did a filesystem check because the filesystem was not clean so maybe something is corrupted.
If this is the case does anyone know how to fix it?
 
Old 08-22-2006, 05:48 AM   #2
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 358

Rep: Reputation: 31
hey there, it does look to be a problem with the repo (assuming it has worked for you before).

I found some good info got getting YaST to work at this site: http://www.thejemreport.com/mambo/content/view/254/42/
Hope this helps,,,
 
Old 08-22-2006, 05:26 PM   #3
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Original Poster
Rep: Reputation: 30
Well, day two and I'm still getting the error.
Yast has worked fine on the odd occasion I've used it. I tend to forget I have yast at all cos I'm so used to smart now. I've always found yast to be too slow for my liking.
 
Old 08-22-2006, 09:18 PM   #4
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Original Poster
Rep: Reputation: 30
After removing and reinstalling smart, the problem has now gone away.

<EDIT> Nope, I was mistaken, the error is still there.

Last edited by shame; 08-23-2006 at 05:54 AM.
 
Old 08-24-2006, 01:10 AM   #5
quip
Member
 
Registered: Jun 2003
Distribution: Slackware
Posts: 100

Rep: Reputation: 15
I'm seeing the issue as well.
 
Old 08-24-2006, 09:42 AM   #6
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Original Poster
Rep: Reputation: 30
This has been reported on suseforums also and it is apparently the kde repo causing it. It's back to normal again for me now.
 
Old 08-29-2006, 10:41 PM   #7
BDHamp
Member
 
Registered: Mar 2005
Distribution: Ubuntu 9.10, Mint 8, Slackware 12
Posts: 105

Rep: Reputation: 16
I'm getting the error now too as well. I basically can't update anything involving KDE. Smart told me it wanted to delete it when I started it earlier this evening, and I stupidly allowed it to do so. Now I can't add it back. Using smart channel --add http://software.opensuse.org/downloa...SE_Linux_10.0/ pretends to add the channel, but it doesn't. Using the GUI results in the same problem. Nothing is actually added. Adding it manually via the GUI results in the error described in the OP.

OnEdit: Prior to this taking place, I had updated smart itself to .42-10. I reverted back to .42-9, and the problem went away.

Last edited by BDHamp; 08-29-2006 at 10:54 PM.
 
Old 08-31-2006, 01:49 AM   #8
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Original Poster
Rep: Reputation: 30
I've had the problem on and off since I first posted. What I have noticed is some mirrors seem to get back up and running before others so I added a few different mirros to the suse-kde source so if it does keep going, at least it will keep trying the other mirrors to make sure I can use the repo again as soon as.
 
Old 08-31-2006, 09:55 AM   #9
broch
Member
 
Registered: Feb 2005
Distribution: Slackware-current 64bit
Posts: 454

Rep: Reputation: 30
this is not smart but repository problem. Re-installing will not help unless at the same time when you re-nstall smart, they fix repository and you will think that you have fixed something.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Acer Aspire 5004WLMi, can bios update solve smart battery problem? Shioni Linux - Laptop and Netbook 1 08-12-2006 11:12 PM
Cron scripting to automatically update smart mwade Linux - Newbie 7 08-12-2006 10:53 PM
error messages when i try to update with smart dasy2k1 SUSE / openSUSE 4 08-12-2006 04:57 PM
smart wont update local rpm directory matticus SUSE / openSUSE 1 07-28-2006 12:22 AM
SuSE 10.0 security Update with 'smart' ? grumpf SUSE / openSUSE 2 07-08-2006 12:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration