LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   SMART error on channel updates - SuSE 10.1 (https://www.linuxquestions.org/questions/suse-opensuse-60/smart-error-on-channel-updates-suse-10-1-a-485558/)

zeb1801 09-21-2006 04:07 AM

SMART error on channel updates - SuSE 10.1
 
Im using Suse 10.1, everything has been working fine untill this morning. When I start SMART it loads OK, but when updating the channels I get an error message - see below:

Traceback (most recent call last):
File "/usr/bin/smart", line 194, in ?
main(sys.argv[1:])
File "/usr/bin/smart", line 167, in main
exitcode = iface.run(opts.command, opts.argv)
File "/usr/lib/python2.4/site-packages/smart/interface.py", line 53, in run
result = _command.main(self._ctrl, opts)
File "/usr/lib/python2.4/site-packages/smart/commands/update.py", line 78, in main
failed = not ctrl.reloadChannels(channels, caching=NEVER)
File "/usr/lib/python2.4/site-packages/smart/control.py", line 375, in reloadChannels
self._cache.load()
File "/usr/lib/python2.4/site-packages/smart/backends/rpm/metadata.py", line 321, in loadFileProvides
self.parseFilesList(fndict)
File "/usr/lib/python2.4/site-packages/smart/backends/rpm/metadata.py", line 346, in parseFilesList
for event, elem in cElementTree.iterparse(file, ("start", "end")):
File "<string>", line 60, in __iter__
SyntaxError: not well-formed (invalid token): line 479344, column 58

I've also deleted channel info and removed SMART's cache and then ran smart update, but the problem still occurs when the channels have updated.

Can anyone give me some info on this, or even how to fix it!!

Zeb

sporks 09-21-2006 10:08 AM

I wish I could help. I'm getting the same thing and came here looking for an answer.

sporks 09-21-2006 10:10 AM

Delete post

sporks 09-21-2006 10:20 AM

Delete post

google01103 09-21-2006 11:38 AM

Well seems there's lots getting this, me included

I cleaned out all the smart data I could find and reinstalled Smart and things are now fine exept I can't get a few repositories to update (think its the Suse build service).

I think what the problem is in the /var/lib/smart/channels directory but not sure. Hopefully someone has a simpler solution as I find adding channels painful unless they're included in konvenientsuse kommander script.

sporks 09-21-2006 11:40 AM

I deleted /var/lib/smart (maybe not a good move, I dunno). I tried deleting just the cache and the channels to no avail.

After I nuked it all and uninstalled/reinstalled it, everything works now.

zepphead5 09-21-2006 04:16 PM

Quote:

Originally Posted by sporks

After I nuked it all and uninstalled/reinstalled it, everything works now.


Same here, I was having the same problem as everyone else and it seemed to work for me.

google01103 09-21-2006 07:08 PM

Known bug https://bugzilla.novell.com/show_bug.cgi?id=207291

"When data is corrupted in the cache (e.g. because of wrong metadata on some server), the metadata is not downloaded in the next run (becuase it may be fixed) but read from the cache where it's ALWAYS corrupted. So the only way is to manually delete the cache to solve the problem."

osbie 09-21-2006 08:15 PM

Same problem here.

tried to delete cache, still fails on rebuild of cache.

WZX 09-24-2006 06:04 AM

Quote:

Originally Posted by osbie
Same problem here.

tried to delete cache, still fails on rebuild of cache.

Delete the files in /var/lib/smart/channels directory and run "smart update" again.

zeb1801 09-26-2006 04:31 AM

I tried deleting the cache and channel data but it still would'nt work, so I eventually uninstalled, rebooted and installed a earlier version, without updating all of the repositories. After the latest KDE update (maybe not even related, but waited anyway!) I again uninstalled and re-installed the latest SMART (0.42.13), refershed everything including all repositories and its now working fine again.

gabigrigore 09-29-2006 07:50 AM

worked for me by deleting the /var/lib/smart/channels directory contents. thank's a lot guys!


All times are GMT -5. The time now is 10:33 AM.