LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   sda or sdb? (https://www.linuxquestions.org/questions/suse-opensuse-60/sda-or-sdb-607004/)

stevest 12-15-2007 02:40 PM

sda or sdb?
 
A long time ago I configured fstab file to mount my external usb drive when I booted up.
fstab read
/dev/sda1 /media/USBdrive vfat users,gid=users,umask=0002,utf8=true 0 0

All went fine for a long time. Then I installed a card reader and thing seemed to change. My external HDD would only occasionally mount.
I looked into it tonight and found that it had now bee listed as sdb not sda! so again I edited fstab and all went ok until I rebooted. External HDD is now sda again. Talk about moving the goal posts!
Anyone any Idea as to what's going on?

manwichmakesameal 12-15-2007 06:14 PM

I'm pretty sure that SuSE 10.2 uses hal to manage things. When you installed the card reader, it automatically put that at sda. Now when you try to mount your external drive at sda, its not there. You can completely remove the entry for your external drive in /etc/fstab, and hal will automatically set it up for you.

stevest 12-16-2007 01:59 PM

Thanks for the reply.
I tried what you said and removed the entry and the EX HDD didn't mount. As I remember I had to add the above entry myself in the first place.
When I try
mount /dev/sda the console reports

steve@linux-3gvo:~> mount /dev/sda
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Syslog says

Dec 16 19:56:14 linux-hvgx kernel: FAT: invalid media value (0x06)
Dec 16 19:56:14 linux-hvgx kernel: VFS: Can't find a valid FAT filesystem on dev sda.

I'm at a loss as everything seemed to bo fine until recently

manwichmakesameal 12-16-2007 05:22 PM

You shouldn't have to manually mount it from the cli. If you have the system:/ kioslave in konqeror, you can just go to storage media and click on the external to mount and enter it. Also, do you have the drive on when you boot? Hal will place the first device it sees in sda, then sdb, etc... If you don't have the drive on, it will automatically put the card reader at sda then when you turn it on the usb drive goes to sdb.

stevest 12-16-2007 06:26 PM

The drive always remains on.

manwichmakesameal 12-16-2007 07:54 PM

I just noticed the command above, you used /dev/sda. Try using /dev/sda1. There should be at least one partition on there.

stevest 12-17-2007 12:55 PM

I tried /dev/sda1, a message came back saying that sda1 could not be found on fstab. I then edited fstab to read /dev/sda1 (was just sda) the tried to mount and another message came back reporting that there was no media to be found. This maybe because the EX HDD is now listed as sdb! Never had time to check, I'm now at work.
Why do you think that the EX HDD is sda on one boot then sdb another.

stevest 12-18-2007 11:57 AM

Thanks for your advice. However... my externel HDD has now been converted to an internal. It's designation is now hdb. I know it seems like I'm giving up but this at least sorts out my hard drive space shortage problem. I had been storing data on the external drive, and this in itself caused me a few problems as the file system used was FAT, and a number of file were over 4GB. So I had to split them. Now with the drive bing internal I have formated it and it now uses EXT3. Result = No space shortage issue, no file size problem and one external enclosure for sale!
Cheers.


All times are GMT -5. The time now is 12:14 PM.