Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 12-28-2005, 10:49 PM   #1
Registered: Dec 2004
Posts: 245

Rep: Reputation: 30
Samba shares - authenticate?

Hey guys - I have a big ol' hard drive on my downloading computer running suse 10 that I need to share over a network. Here's the setup:

The computer is 'netslave' running suse 10
The only user account is 'tux' belonging to group 'users'
A 250gb harddrive is mounted on /storage
/storage = user:tux, group:users
permissions = 750

The workgroup is 'WORKGROUP'
SMB share is 'FileVault' -> /storage

Try as I might to understand the convoluted wizards and configuration screens in suse, I just can't click on the right things to get it to share the way I like. Here's how I want it to preform.

Due to the nature of the files, I want to authenticate into the share. If I wanted to delete/modify the files, I want to log in with tux (the owner). Otherwise, I want to be able to log in with null values and be authed as a guest, which will be forced into the 'users' group, so I can access the files but not delete/modify them.

This has been wildly frustrating - it seems as though I can set it in the kde control panel to "share" mode and then the files are wide open. When I set it to "user" I can't ever authenticate, no matter what I tweak.

I know it's a pain, but if anyone knows of a step-by-step way of configuring it this way it would be much appreciated. I know this is entirely possible, just very hard to figure out. Thanx in advance!

Old 12-30-2005, 01:43 PM   #2
Registered: Jul 2003
Location: Gauteng, South Africa
Distribution: Windows XP, yup :D Will be back onto Ubuntu probably someday
Posts: 107

Rep: Reputation: 15
I think setting up Samba is best done by manually editing the smb.conf file, however frustrating it is having to read an entire manual to just set up a couple of shares.

So that is what I suggest, read the Samba manual and edit smb.conf. Also try reading the manual pages for smb.conf and smbpasswd (man smb.conf; man smbpasswd)
Old 12-30-2005, 07:11 PM   #3
Registered: Oct 2005
Location: Burley, WA
Distribution: Sabayon, Debian
Posts: 278

Rep: Reputation: Disabled
Make sure the directory/file permissions match those in smb.conf (or shares.conf if you go that way).


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Authenticate t.augusto Ubuntu 2 11-04-2005 04:13 PM
Not able to authenticate samba from win xp f00l Linux - Networking 2 10-30-2004 09:53 PM
Samba: Authenticate Linux-Clients in Samba Domain & Mount mule Linux - Software 0 12-10-2003 02:21 AM
Can't authenticate to samba with smbclient palmercabel Linux - Networking 8 12-04-2003 03:57 PM
Linux can mount samba shares but not windows shares bindsocket Linux - Software 1 12-01-2003 06:28 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 11:53 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration