LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 04-20-2005, 11:22 AM   #1
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Rep: Reputation: 30
Samba connection delay


I'm having a strange problem with Samba on my Suse 9.2 box. I can see the suse box from my windows machine but when I click on the server it says that it can't be found. If I try it 3 or 4 times it will eventually connect. If I map the drive and restart the windows machine I get the error saying that the server can't be found. I've tried to get to this suse box from 2 different windows machines and even a linux box and it has the same symptoms. Yet, I can connect to my debian box via samba with no problem. Any ideas?

Here is my smb.conf file (everything is defaulted except workgroup name and the share at the bottom):

Code:
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2005-01-28
[global]
workgroup = kesintl
printcap name = cups
printcap cache time = 750
cups options = raw
printer admin = @ntadmin, root, administrator
username map = /etc/samba/smbusers
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
security = share
restrict anonymous = no
domain master = no
preferred master = no
max protocol = NT
ldap ssl = No
server signing = Auto

[homes]
comment = Home Directories
valid users = %S
browseable = No
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[FOSS]
case sensitive = no
msdfs proxy = no
path = /usr/local/novell
force create mode = 0775
create mask = 0775
read only = no
force group = staff
comment = run dos progs from win98
force directory mode = 0775
directory mask = 0775
delete readonly = yes
 
Old 04-20-2005, 11:50 AM   #2
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 35
If this is the only samnba or windows server in your network, put this in the [global] section

local master = yes
preferred master = yes
os level = 60

and maybe try,

socket options = TCP_NODELAY

 
Old 04-20-2005, 12:10 PM   #3
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
I tried all of that (and rebooted) but unfortunately I'm still getting the same error when I reboot the windows 98 machines. It says the share can't be found and prompts to reconnect next time I boot. Any other ideas?
 
Old 04-20-2005, 01:04 PM   #4
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 35
Is there a reason why security is set to 'share', i don't know what else you have set up, but try that as 'user'. It might solve things.

Also, if this is your only server the settings above help with the general running of the network.

 
Old 04-20-2005, 08:06 PM   #5
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
I'm basically transitioning from a debian server to a suse 9.2 server. The debian server is setup almost exactly (except host name and IP address of course). Since the Debian server was setup as security=share and it worked well I thought I would duplicate that. Also, in the control center, under samba config it says to use share for security if you are in a small office environment which I am.

I can try to swtich it over to user but I'd rather know what the implications are first. Can you shed some light on that?

Thanks for your help so far!
 
Old 04-21-2005, 12:39 PM   #6
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 35
Basically it is how Samba authenticates users,
This is from http://us2.samba.org/samba/docs/using_samba/ch09.html which is in this book http://us2.samba.org/samba/docs/using_samba/toc.html

Authentication of Clients
At this point, we should discuss how Samba authenticates users. Each user who attempts to connect to a share not allowing guest access must provide a password to make a successful connection. What Samba does with that password—and consequently the strategy Samba will use to handle user authentication—is the arena of the security configuration option. Samba currently supports four security levels on its network: share, user, server, and domain.

1, Share-level security
Each share in the workgroup has one or more passwords associated with it. Anyone who knows a valid password for the share can access it.

2, User-level security
Each share in the workgroup is configured to allow access from certain users. With each initial tree connection, the Samba server verifies users and their passwords to allow them access to the share.

3, Server-level security
This is the same as user-level security, except that the Samba server uses another server to validate users and their passwords before granting access to the share.

4, Domain-level security
Samba becomes a member of a Windows NT domain and uses one of the domain's domain controllers�either the PDC or a BDC�to perform authentication. Once authenticated, the user is given a special token that allows her access to any share with appropriate access rights. With this token, the domain controller will not have to revalidate the user's password each time she attempts to access another share within the domain. The domain controller can be a Windows NT/2000 PDC or BDC, or Samba acting as a Windows NT PDC.

Having thought about this and from how your smb.conf is setup you seem to be trying to have samba authenticate your users when they log on to a machine and you have roaming profiles setup, but this doesn't really fit with security at 'share'. However if this setup works and you have both samba servers on at the same time they will conflict with each other. I do suggest that you read this http://us2.samba.org/samba/docs/man/Samba-Guide/ and then to get a better understanding of it all read the rest of the book that the above text came out of. And then use one of the setups in there and tailor it to your needs.

 
Old 04-21-2005, 03:35 PM   #7
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
I spent most of the day messing around with various options.. using user,share, and server settings.. changing the domain name of the server, changing the domain name of the clients, being a domain master, etc... all to no avail. The closest I can get it is where I access the share, map the drive and have it fail on reboot of the client but nevertheless be connected. I guess I'm going to have to settle for that.

It's my first suse experience and I'm not sure if I missed something easy (like a firewall setting?) but I have to say that I'm more likely to wipe the server in favor of something else when a stable x64 version is out.

Anyway, I really appreciate you taking the time to look into this with me. If you have any other ideas I'll definitely be interested in trying them!
 
Old 04-21-2005, 04:24 PM   #8
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Actually, if I can post a follow-up question here. I notice that my version of samba that's installed is 3.0.9 whereas the current version for AMD64 is 3.0.14. I wouldn't mind upgrading.. is there an easy way to do that (unfortunately the mirrors I have are also at 3.0.9) or do I have to download the whole thing from the samba website?
 
Old 04-22-2005, 08:04 AM   #9
Marius2
Member
 
Registered: Jan 2004
Location: Munich
Distribution: SuSE 9.2, 10.2, 10.3, knoppix
Posts: 276

Rep: Reputation: 31
I think you should compile from source (which I did only the day before yesterday, because of problems when connection with the samba client of a 9.2 box to a 9.2 server - after a short while, the share was gone). Upgraded to 3.0.14a, problem gone. Anyway, I download the source, then it's the usual
./configure
make
make install.

*BUT*

SuSE installs its stuff to /usr/bin and /usr/lib, while samba (like most software for linux) goes to /usr/local/bin and /lib, so after the make install you'll have two versions installed simultaneously. So remove smbd, nmbd and the samba client from /usr/bin, and add /usr/local/bin and /lib to PATH (by adding
PATH=$PATH:/usr/local/bin:/usr/local/lib
to your ~/.bashrc, for example). Just to be safe, check dependencies of smbd and the other bins with ldd afterwards.


HTH

Last edited by Marius2; 04-22-2005 at 08:06 AM.
 
Old 04-22-2005, 09:00 AM   #10
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Instead of installing it from source couldn't I just install the binary and avoid that? It looks like the binary is also pretty recent: http://us4.samba.org/samba/ftp/Binar....0/x86_64/9.2/

I'm really unfamiliar with RPMs though so I have no idea which files I would need to download (this is just the server but I would probably want to update the client too, right?) and then how to install them. Any help would be appreciated.

Thanks!
 
Old 04-22-2005, 02:34 PM   #11
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Ok, I installed the newest version of samba (3.0.14a) using the binaries on the samba website. Unfortunately my problem still exists. Would it be possible that it's related to the fact that I have two ethernet cards in the server? I'm just about out of ideas..
 
Old 04-22-2005, 02:48 PM   #12
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 35
Just a thought, lets say you have turned the client on, it has gone thru its boot up, do you now have a logon box or does it go straight to the desktop?
Now, when you map the network drive do you have to supply a user name and password or just a password? Also i take it that when you map the drive you tick the little box that says reconnect at log on.

Let us know this and maybe we might be able to understand the problem a bit more and figure out where it is going wrong.

Also what sort of enviroment (big/small office, home network) are we dealing with here? What clients do you have? Any other servers on the network?
 
Old 04-22-2005, 03:53 PM   #13
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by snowtigger
Just a thought, lets say you have turned the client on, it has gone thru its boot up, do you now have a logon box or does it go straight to the desktop?
I get a logon box for microsoft networking first.
Quote:

Now, when you map the network drive do you have to supply a user name and password or just a password? Also i take it that when you map the drive you tick the little box that says reconnect at log on.
Neither. the username and password for the samba share is the same as the username password I used for logging on to the microsoft network. So my guess is that it passes that username/pw along and if it works great but if not it would reprompt me. I do tick to reconnect at logon.

Quote:

Let us know this and maybe we might be able to understand the problem a bit more and figure out where it is going wrong.

Also what sort of enviroment (big/small office, home network) are we dealing with here? What clients do you have? Any other servers on the network?
I'm in a small office environment. There are two other linux boxes (debian) that run the same workgroup but I changed the workgroup on the suse machine in case that was the problem but it didn't help. I thought it might be due to dual NICS but I just disabled one and rebooted without success.

One thing I did notice though is that during the startup session the console says stuff like:

starting samba daemon... done
starting tomcat .... done
starting blah blah ... done
Mounting smb/cifs filesystems ... unused

Unused? Could that be the problem? I would think that would cause it not to work at all instead of giving me a delay.. How would I correct that if it's not normal?

Thanks for your patience with me.. this whole suse thing is completely different than my comfortable debian world..
 
Old 04-22-2005, 04:44 PM   #14
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 35
Quote:
Mounting smb/cifs filesystems ... unused
This is used when a linux client connects to a smb/cifs server. eg, if you were to manually mount a smb share using mount or an entry in fstab you would put the type as 'smbfs'

I have one other idea at the moment.
If samba is still running on the other machines, disable it and try that.
You do not actually need it running to connect a linux client to a samba server

Sorry if this doesn't help.
I will have a think about it and see what comes about.
 
Old 04-29-2005, 04:53 PM   #15
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Sorry for the delay -- it's been a tough week. I finally got around to disabling all the other servers (I just turned them off). It didn't help the situation.. I'm still getting that delay.

One thing that's strange is that I temporarily had the suse server use a workgroup all on its own (call it foo) and even though I've since changed that setting back to the original workgroup when I'm in my windows network it shows foo as a valid workgroup. I've restarted all the computers I can think of and somehow it's still showing foo out there. Is it alive somewhere in the ether? How does one purge their network neighborhood of workgroups that no longer exist?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection with Long Delay (Telnet, Ftp) sarmadys Linux - General 8 02-09-2011 12:55 AM
Network delay/Samba Briotti Linux - Networking 1 12-21-2003 05:00 PM
Still cant get connection w/ Samba and Win Xp jillyt Linux - Newbie 2 12-19-2003 10:58 AM
Man9.1 - networking delay/Samba Briotti Mandriva 1 10-19-2003 08:17 AM
Samba connection refused jmarsh Linux - Networking 2 03-03-2003 01:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 10:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration