Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 10-24-2004, 01:04 PM   #1
LQ Newbie
Registered: Oct 2004
Location: London
Distribution: SUSE 9.1
Posts: 13

Rep: Reputation: 0
sagem adsl modem on SuSE 9.1


After a long battle, I have sucessfully installed my Sagem adsl modem with a eagleusb driver and my modem works now fine.

The only thing is that I have to restart the modem, each time I want to connect, manually with a terminal window (SU ... usr/sbin/startadsl). This part of the installer does not work.

I found a hint on a french forum to work around this (see also below).

I did everything down to number 4. I can not work out what I have to do in number 4. I can not find where I have to activate adsl.boot.

Any ideas? Or any other way to autoconnect the modem?




J'ai automatisé la connexion au boot + reconnect automatique car le script de connect auto installé par eagleconfig ne fonctionne pas chez moi non plus.

Comme je ne suis pas une brute j'ai repris et modifié le script "adsl.watchdog" que j'utilisais avec SuSE 8 (je ne me souviens plus de l'auteur )

Pour info je suis dégroupé avec free... (donc pas de DHCP)

1-créer le fichier /usr/local/sbin/adsl.connect

/usr/local/sbin/eaglectrl -w
/sbin/SuSEfirewall2 stop
/sbin/SuSEfirewall2 start
# lancement de Wondershaper pour la qualité de service et ntop pour les stats
# C'est vous qui voyez...
/etc/init.d/ntop start
/etc/init.d/wondershaper start

2- créer le fichier /etc/init.d/adsl.boot

/usr/local/sbin/adsl.connect >/var/log/adsl.boot.log&

3- créer le fichier adsl.watchdog

# !/bin/bash
sleep 50
while [ "" == "" ] ; do
sleep 6
# on pingue sa passerelle pas plus loin...
INTERNET_TEST=$(ping -W 1 -c 1 XX.XX.XX.254 |grep '1 received')
if [ "$INTERNET_TEST" == "" ] ; then
INTERNET_TEST2=$(ping -W 1 -c 1 XX.XX.XX.254 |grep '1 received')
if [ "$INTERNET_TEST2" == "" ] ; then
INTERNET_TEST3=$(ping -W 1 -c 1 XX.XX.XX.254 |grep '1 received')
if [ "$INTERNET_TEST3" == "" ] ; then
# Là plus de doute possible, gros reset dans sa face...
/etc/init.d/ntop stop
/etc/init.d/wondershaper stop
rmmod uhci_hcd
insmod /lib/modules/2.6.5-7.108-default/kernel/drivers/usb/host/uhci-hcd.ko
# adapter avec sa version de kernel
sleep 1

done ;

4- Dans Yast -> Système-> éditeur de niveaux d'execution

activer adsl.boot en mode expert pour sélectionner les niveaux 3, 4 et 5
Au boot la connect. sera donc lancée

5- Reste a modifier /etc/inittab pour que l"adsl.watchdog monte la garde.
ajouter la ligne:


6- On reboote pour voir si au boot tout se lance normalement

7- Pour tester le watchdog on fait un ifdown eth0 (ou ethX)
la connect. doit retomber sur ces pattes. (~ 40 secondes)

Voilà, c'est du bourrin, et ca marche...
Old 10-26-2004, 07:16 PM   #2
LQ Newbie
Registered: Oct 2004
Location: europe
Posts: 1

Rep: Reputation: 0
Hi JeTa,

Congratulations with your working adsl modem!
I haven't succeded, trying for more than a week now.

My sagem 800 usb modem did't work with the eagle-usb drivers.
Maybe you can give me a "short' rapport of your 'struggle'
That would be nice eh?

Well anyway, is your problem fixed already?
If not read this, as i understand this maybe your problem, and try it out.
Specific the bottom lines.

To connect a Suse 9.1 (Kernel 2.6) machine via a Sagem Fast800? E2T to a UK-ADSL network with Tiscali as provider.

See the detailed instructions below.

Especially note steps 4 and 8 which were unexpected.

0. Install development packages (via Yast)
- kernel-sources
- gcc (C-Compiler)
- cpp
- libgcc (C-Bibliotheken)
- eazy (SUSE Compatibilty Links)
- lsb (Standard Base Tools)
- bison (C Parser Generator)
- libusb (USB-Bibliotheken)
- usbutils
- make
- ncurses
- ncurses - devel (kernel-menuconfig)

1. Start a root console

2. Preparing the kernel-sources: The sources must belong to the installed kernel.

cd /usr/src/linux
Save an old config if exists:

mv .config .config.old
Type "uname -r" to find out the version of the installed kernel and copy the respective file from "/boot/config*" to "/usr/src/linux/.config".

cp /boot/config-`uname -r` /usr/src/linux/.config

make menuconfig
and exit with saving.

3. Prepare the eagle-usb-driver
Download: eagle-usb-1.9.8.tar.bz2 from SourceForge download area (you may take latest version and adapt)
Unpack it somewhere: e.g. into /opt

cd /opt
tar xvfj eagle-usb-1.9.8.tar.bz2
cd /opt/eagle-usb-1.9.8
If no configure-file exists run

Then a configure-file should exist. Run

./configure --prefix=/usr

4. Normally you would proceed with "make" etc. but I had the problem that after completing the installation my modem seemed to be too new:
The modem wouldn't become operational, after waiting and when typing "eaglectrl -p" something like this would appear:

Post-firmware device on USB bus 4 (type=POTS)

The solution for this was to use the original *.bnm-files from the Tiscali-Windows-Installation-CD instead of the *.bnm-files in the eagle-usb-1.9.8-package:
The directory /media/cdrecorder/ASSETS/Sagem/L1/IDMA contains the files:

Copy them to /opt/eagle-usb-1.9.8/driver/firmware/sagem/pots and /opt/eagle-usb-1.9.8/driver/firmware/usr/pots and also rename them from uppercase to lowercase letters e.g.:

cp /media/cdrecorder/ASSETS/Sagem/L1/IDMA/RTBLDEP0.BNM /opt/eagle-usb-1.9.8/driver/firmware/sagem/pots/rtbldep0.bnm
etc. (for files 0...4)

Note you may use this alternate method :
dowload latest windows drivers from sagem

cd /opt/eagle-usb-1.9.8/
unzip $(DIR_DL)/ # where DIR_DL is the directory where you downloaded
cp W.2.0.31_fr/L1/IDMA/rtbldep*.bnm driver/firmware/sagem/pots
cp W.2.0.31_fr/L1/IDMA/rtbldei*.bnm driver/firmware/sagem/isdn

Those .bnm work with E2L modem and work with Fast 800 WA (wanadoo origin) and Fast 908
I don't know the difference from E2T to E2L but I suspect T mind Tiscaly, for L, I don't know.

Do you know if those bnm work with E2T modems?

5. Now it's finally time for make:

make install

6. Configuring the ADSL-connection:

Some questions about country, username, password and when to launch the ADSL-connection will be asked now.

When everything works then text similar to this will appear:

Loading DSP & options... [ OK ]
Waiting for modem to be operational... [ OK ]
Configuration successful.
You can now type "startadsl" to launch the connection.

7. Now run "startadsl" and try to access the internet via konqueror or similar.
8. After restarting the computer neither eagleconfig nor startdsl worked anymore. The problem seemed to be that the DSP-code wasn't reinitialised.
My solution was to change line 59 in /usr/sbin/eagleconfig to

which forces the DSP-reinitialisation with every launch of eagleconfig.
Then "startadsl" works again.

9. The connection can finally be terminated with "stopadsl".
Good luck, Major2
Old 10-27-2004, 03:28 PM   #3
LQ Newbie
Registered: Oct 2004
Location: London
Distribution: SUSE 9.1
Posts: 13

Original Poster
Rep: Reputation: 0
Hi Major2

Congratulations to you too. It is quite a struggle, I think. Thanks for your detailed answer.

My procedure was pretty similar.
The only thing I did different was that I have used Kernel 2.6.4(-52) which is supported by the eagle-usb ( driver without having to copy the bnm-files from the CD.
But it is good to know that my modem is future proof anyway!!

I do not know about the E2T modem. I have got an E2L.

I installed some more development packages as you recommended and reinstalled it again to see if I still have to type "startadsl" to make the connection. Unfortunately yes. I was hoping it would connect automatically when I boot.

Never mind.....


Old 10-27-2004, 06:17 PM   #4
LQ Veteran
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 86
JeTa -- per the LQ Rules, all posts should be in English. There may be some folks here who can translate French, but this site is English-based, and you likely would get additional replies if you edited your original post and translated it into English. Thanks -- J.W.
Old 12-20-2004, 07:48 PM   #5
Registered: Dec 2004
Distribution: OpenSuSE 10.0
Posts: 140

Rep: Reputation: 15
I got the solution.

i installed mandrake 10.1 and that installed the drivers automatically and all i had to do was set up the connection. I hope this helps you

Last edited by Ace2005; 12-20-2004 at 08:04 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sagem F@st 800 ADSL modem BangorScott Mandriva 10 10-15-2004 04:14 PM
Sagem F@st 800 PE usb adsl modem Geosharp Linux - Hardware 0 02-01-2004 05:25 PM
using sagem 800 adsl usb modem on Mandrake 9.2 Or suse 9.0? Ejg Linux - Newbie 0 01-28-2004 11:39 AM
SAGEM F@st 800-840 adsl modem andy010 Linux - Networking 0 11-20-2003 07:28 PM
Problem installing Sagem ADSL modem Terenus Linux - Newbie 0 09-16-2003 02:20 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 11:17 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration