LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 01-13-2007, 08:26 PM   #1
abominable
LQ Newbie
 
Registered: Mar 2006
Posts: 16

Rep: Reputation: 0
run command shortcut+suse 10.2


Well I'm used to keyboard functionality..

I recently installed suse 10.2 everything worked fine. After enabling xgl the shortcuts alt+f1 (--> popup launch menu) and alt+f2 (--> run command) don't work.

Well I've checked every possible settings controller (kcontrol , beryl-settings). Everywhere they are set correctly but the shortcuts don't function.

Does anyone have any idea how can I restore them or solve my prob?
 
Old 01-14-2007, 01:10 PM   #2
google01103
Member
 
Registered: May 2006
Distribution: Suse 10.2 x64
Posts: 247

Rep: Reputation: 31
Had this right after I installed 10.2 but problem went away after a reboot
 
Old 01-17-2007, 07:34 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
To change to console SuSE uses <CTRL> <ALT> <Fn> with n = 1-6 included. 7-12 are the corresponding GUI-screens.
 
Old 01-25-2007, 09:14 PM   #4
abominable
LQ Newbie
 
Registered: Mar 2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by google01103
Had this right after I installed 10.2 but problem went away after a reboot
Mine steel remains.. Do you run xgl?
 
Old 06-26-2007, 08:22 PM   #5
aribowo
LQ Newbie
 
Registered: Jan 2007
Location: Balikpapan, Indonesia
Distribution: OpenSUSE 11.1
Posts: 12

Rep: Reputation: 0
Yes, I have the same problem too. Could anyone give me any clue on how to? Thanks in advance.
 
Old 06-27-2007, 01:08 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Maybe all of you [c|sh]ould have a look at the keyboard section in the xorg.conf file...
 
Old 06-27-2007, 08:36 PM   #7
aribowo
LQ Newbie
 
Registered: Jan 2007
Location: Balikpapan, Indonesia
Distribution: OpenSUSE 11.1
Posts: 12

Rep: Reputation: 0
Well, it seems like you all don't understand what I mean. After enabling xgl (which give us 3d effect on desktop), we couldn't activate the KDE shortcut keyboard, such as Alt+F1 and Alt+F2. We don't mean to switch from GUI to console, but some features on KDE couldn't work after we start xgl. Is that clear enough? Thank you.
 
Old 06-28-2007, 08:18 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Quote:
Originally Posted by aribowo
Well, it seems like you all don't understand what I mean...
Ah yes. That was whose fault?
http://www.catb.org/~esr/faqs/smart-questions.html

Quote:
Originally Posted by aribowo
... After enabling xgl (which give us 3d effect on desktop), we couldn't activate the KDE shortcut keyboard, such as Alt+F1 and Alt+F2. We don't mean to switch from GUI to console, but some features on KDE couldn't work after we start xgl...
Indeed. And there is a chance that the reason lies within the xorg.conf. Did you have a look?

Quote:
Originally Posted by aribowo
...Is that clear enough? Thank you.
You are aware that nobody here is obliged to try to help you, are you?
 
Old 06-29-2007, 12:29 AM   #9
aribowo
LQ Newbie
 
Registered: Jan 2007
Location: Balikpapan, Indonesia
Distribution: OpenSUSE 11.1
Posts: 12

Rep: Reputation: 0
Smile

Quote:
You are aware that nobody here is obliged to try to help you, are you?
Sorry, I don't mean to offense. I just want to make clear about the problem.

Hi JZL240I-U, this is my xorg.conf line for keyboard.

Code:
Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "pc104"
  Option       "XkbRules" "xfree86"
EndSection
I didn't find anything wrong in it (I probably made mistake). Do you think it is the problem? Could you help me please? Thank you very much.
 
Old 06-29-2007, 01:45 AM   #10
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Okay, no offense taken . Your keyboard section looks allright to me. Argh, the description in the documentation of the x server is for people who already understand the details and that is not me .

Well, no help for it. You'll have to look into the man and info pages of xorg.conf and x. Somewhere there will be a description how to assign values to the function keys of your keyboard. You might try to play with that. The key has to have its intended value, so KDE can trigger the correct response.

Should the problem reside in KDE (might be the easier way to begin) here is the link to the KDE documentation, you might want to dig there first anyhow http://www.kde.org/documentation/ see also http://docs.kde.org/development/en/k...documents.html
 
Old 07-02-2007, 04:34 PM   #11
bonito
Member
 
Registered: Mar 2005
Posts: 117

Rep: Reputation: 15
i Do

Quote:
Originally Posted by aribowo
Well, it seems like you all don't understand what I mean. After enabling xgl (which give us 3d effect on desktop), we couldn't activate the KDE shortcut keyboard, such as Alt+F1 and Alt+F2. We don't mean to switch from GUI to console, but some features on KDE couldn't work after we start xgl. Is that clear enough? Thank you.
I Know Exactly what you mean. i went through this back in March...
and I STill have no idea how to resolve it.

In fact, i finally disabled XGL and went back to Xorg.
Sure the special effects were nice, but not act the expense of functionality.

Oh well, maybe this will be improved in 10.3...
 
Old 07-02-2007, 11:10 PM   #12
aribowo
LQ Newbie
 
Registered: Jan 2007
Location: Balikpapan, Indonesia
Distribution: OpenSUSE 11.1
Posts: 12

Rep: Reputation: 0
Smile

Thank you guys. I really appreciate it. Wish you all the best.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Run as Root Shortcut SLP SUSE / openSUSE 4 04-21-2006 10:35 AM
g++ command shortcut? m_lp_ql_m Linux - Software 5 02-17-2006 08:42 PM
Execute shortcut as Root Command? batorma Linux - Newbie 2 11-08-2005 02:22 PM
Thunderbird Installed, How to Run?? SuSe Shortcut?? Kevin Tough SUSE / openSUSE 2 08-24-2005 10:27 AM
How can I go to the windows screen from the command line on suse, on run level 3? abefroman SUSE / openSUSE 1 05-08-2005 07:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration