LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 04-20-2005, 10:16 AM   #1
mattl
Member
 
Registered: Mar 2004
Location: MA, USA
Distribution: OpenSuse 10, FC4/5, Mepis
Posts: 95

Rep: Reputation: 15
remote desktop (vnc) double keystrokes issue


Since installing suse 9.2, using the remote desktop and using vnc -or tightvnc (from a windows workstation) the keystrokes are double/trippled up.
such as i type 'ls' and it outputs 'lssssss'.
Ive noticed if i type slow it doesn't happen. very slow. any tips what to try to fix this? its over an internal network only and its constant and repeatable, always been that way..would like to fix.

I hope this hasnt been discussed already, i did a search of the whole site nothing came up.

Thanks!

Matt
 
Old 04-29-2005, 03:22 AM   #2
jess1975
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Suse 11.1
Posts: 87

Rep: Reputation: 15
VNC eats up massive resources. Instead of releasing your user, release your display.

Go to SAX2 and there you can release your display (with password), it's a lot faster.

I had the same problem and now everything works really fast.
 
Old 04-29-2005, 11:44 AM   #3
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
Since its internal, I'd suggest choosing a slower connection speed. I had similar issues over DSL connection and I just picked Low connection and surprisingly it was just as fast but less delay.
 
Old 04-30-2005, 05:54 PM   #4
mattl
Member
 
Registered: Mar 2004
Location: MA, USA
Distribution: OpenSuse 10, FC4/5, Mepis
Posts: 95

Original Poster
Rep: Reputation: 15
thanks both, I'm not even sure its vnc , im using the remote desktop sharing applet built in with suse 9.2. looking at processes i don't see Xvnc (or vncserver) like i did when i ran the server manually on suse 9.1.

i don't see anything about speed in the host settings..

what's sax2? i looked around didn't see anything relating to vnc. I do know there are a few projects going with vnc compatibility i will try one of those other packages, thanks!

matt
 
Old 04-30-2005, 06:23 PM   #5
jdblick
Member
 
Registered: Sep 2004
Distribution: SUSE 10.0 OSS
Posts: 261

Rep: Reputation: 30
sax2 is accessible from yast. You can adjust settings for display, keyboard, and mouse in it.
 
Old 04-30-2005, 08:19 PM   #6
mattl
Member
 
Registered: Mar 2004
Location: MA, USA
Distribution: OpenSuse 10, FC4/5, Mepis
Posts: 95

Original Poster
Rep: Reputation: 15
thanks i did just find it and try turning on vnc in there am still experimenting with it, thanks!
 
Old 05-02-2005, 01:51 PM   #7
mattl
Member
 
Registered: Mar 2004
Location: MA, USA
Distribution: OpenSuse 10, FC4/5, Mepis
Posts: 95

Original Poster
Rep: Reputation: 15
Well, I enabled vnc w/a pw in Sax2 but can't figure out how to connect to it? I'm not sure if I need to also have remote desktop turned on or to manually start vnc?
I tried connecting to various common ports (5900, etc). also can't find any docs on using vnc configged through sax2. help appreciated. (and already received thanks)
 
Old 05-02-2005, 05:21 PM   #8
jess1975
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Suse 11.1
Posts: 87

Rep: Reputation: 15
You should disable the firewall. I couldn't get it to work well with the firewall on. Then from the other computer VNC to ipadress:0

that should work. For windows you need realVNC enterprise or something. You need the VNC 3 Protocol.
 
Old 05-02-2005, 06:41 PM   #9
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
For the key repeating problem you can start it with the -norepeat flag.
 
Old 05-05-2005, 05:33 PM   #10
mattl
Member
 
Registered: Mar 2004
Location: MA, USA
Distribution: OpenSuse 10, FC4/5, Mepis
Posts: 95

Original Poster
Rep: Reputation: 15
i was JUST about to repost to you guys that i couldn;t get it still and noticed jess's comment about need the version 3 protocol and thats what did it. I did notice in my logs it showed "got connection, ignoring minor version mismatch". apparently it wasn;t ignoring it too successfully even though i got no more errors than that. so on the windows client config i troed checking off the butyton to only use protocol 3.3 and i can connect to :5900, problem solved!
i am now using the remote desktop as configged though sax2. thanks to all folks!
 
Old 05-06-2005, 05:04 AM   #11
jess1975
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Suse 11.1
Posts: 87

Rep: Reputation: 15
Kumbaya,
It never hurts to help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
remote desktop,vnc,ssh inside a lan durden2.0 Linux - Networking 3 09-22-2006 03:55 PM
Remote Desktop, ssh, vnc, rdesktop, RDP, cygwin? chbin Linux - Networking 7 12-17-2005 05:28 PM
VNC vs Remote Desktop: display confusion klandingham Linux - Newbie 0 11-03-2004 11:27 AM
'Remote Desktop' with SSH and VNC kaon Slackware 11 09-21-2004 01:15 PM
Does KDE remote desktop == VNC? Brain Drop Linux - Networking 1 07-05-2004 03:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 03:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration