-   SUSE / openSUSE (
-   -   Question: Configuring LILO for OpenSUSE 11.3 (

suhaib 08-21-2010 12:12 PM

Question: Configuring LILO for OpenSUSE 11.3
Hey guys,

It's been a while since I posted here.

I recently installed OpenSUSE 11.3 as a VM, using VirtualBox (Mac version). It might seem a little pointless to some, but it's for learning purposes. Sadly I don't have the array of machines I use to have to do a non-virtual installation, but that's besides the point.

I've been going over some of the LPI-101 examination material from the developerWorks/IBM site. I've come to a point where you need to configure LILO and quite frankly its been at least 4 years since I've touched LILO. Anyhow, I installed LILO using yast and it appears to be installed, yet every time I run the lilo command, I get the message,

Fatal: Cannot open: /etc/lilo.conf

The reason why I guess is because I don't have the .conf file, which I thought was suppose to generate when you install LILO? I've also tried liloconfig but that doesn't seem to exist. It's worth mentioning that currently I'm using GRUB and haven't touched its .conf file at all (if that would be necessary). Any suggestions on what the problem could be, and how to get that file generated?

I wouldn't think it'd be necessary to just copy a .conf file or write one myself. I would rather see the generated output first.

Many thanks.

suhaib 08-22-2010 07:02 PM

Ok, I've gotten somewhere. I needed to select LILO as the bootloader from yast and allow it to first generate the lilo.conf file. Hopefully this should suffice for learning purposes...

All times are GMT -5. The time now is 08:40 AM.