LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   qemu installs but no kqemu acceleration (https://www.linuxquestions.org/questions/suse-opensuse-60/qemu-installs-but-no-kqemu-acceleration-514743/)

google01103 12-29-2006 07:21 PM

qemu installs but no kqemu acceleration
 
I compiled and installed qemu and kqemu according to the OpenSuse faq and qemu instructions using the 3.4.6 compiler. The kqemu kernel module installs fine and qemu runs fine but when I test for acceleration I get "kqemu support: not compiled". I've give rw rights to /dev/kqemu and "lsmod | grep kqemu" gives the response "kqemu 182920 0".

I extracted kqemu into the extracted qemu directory and compiled qemu first per instructions.

what haven't I done correctly?

fyi - I do use VmwareServer but want to test qemu

thanks,

craigevil 12-30-2006 04:16 PM

I have to run the following commands (as root) after every reboot. I don't know why, but, hey, who cares? Simply add it to /etc/rc.local.

$ mknod /dev/kqemu c 250 0
$ chmod 666 /dev/kqemu

You can also try starting qemu with -kernel-kqemu although that froze my system the last time I tried it.

google01103 12-30-2006 06:08 PM

Thanks, I fixed it - it seems I had a bad/older kqemu module loaded from one of my many compiles and a reboot cleaned that out and I just installed the correct one

Also, the "-kernel-kqemu" option won't work on a 64bit system you must use "qemu-system-x86_64 "

fyi - I'm using modprobe instead of mknod

thanks,


All times are GMT -5. The time now is 09:32 PM.