LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 10-01-2005, 12:04 PM   #1
biledaemon
Member
 
Registered: Mar 2003
Location: Somewhere between Hell and Limbo
Distribution: Slack 10.2; Debian
Posts: 57

Rep: Reputation: 15
Proggy can't find X11 Development Pkgs in Suse.


I tried finding in YAST the X11 development packages but I am not sure if I have them already or not. If I do then the program that I am trying to compile is not finding them.

WHen doing ./configure in the path Mplayer I get this:

Checking for X11 headers presence ... not found (check if the dev(el) packages are installed)
Checking for X11 libs presence ... not found (check if the dev(el) packages are installed)
Checking for X11 ... no
Checking for DPMS ... no
Checking for Xv ... no
Checking for XvMC ... no
Checking for Xinerama ... no

How can I tell ./configure where to find the packages in Suse 9.2? I also want "configure" to search in my home dir. There also several proggys that Mplayer is looking for that I KNOW are installed for sure but Mplayer cannot find them.

BTW, The rpm based package of Mplayer is corrupt in the packman site..so I decided to build Mplayer from scratch.

Any help would be greatly appreciated.

Thanks.
 
Old 10-01-2005, 02:28 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Mineral, Virginia
Distribution: Debian 8
Posts: 7,890

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
"How can I tell ./configure where to find the packages in Suse 9.2?"

Use YaST2 to install the development packages. Then ./configure will find them without you telling it anything.

-----------------------
Steve Stites
 
Old 10-01-2005, 03:55 PM   #3
biledaemon
Member
 
Registered: Mar 2003
Location: Somewhere between Hell and Limbo
Distribution: Slack 10.2; Debian
Posts: 57

Original Poster
Rep: Reputation: 15
I don't have YAST2.. I looked up X11 in YAST and I don't see anything resembling X11 development packages in my Suse CD1 9.2; most of the X11 related packages like fonts and whatnot are already installed. Could it be that you are referring to YAST2 in Suse 9.3?

IF that's the case, I will wipe out everything and install 9.3 just to get mplayer working. Let me know your thoughts.
 
Old 10-01-2005, 05:47 PM   #4
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Mineral, Virginia
Distribution: Debian 8
Posts: 7,890

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
"I don't have YAST2.. I looked up X11 in YAST"

In SuSE 9.2, and 9.3 YaST and YaST2 are treated as synonyms.

"I don't see anything resembling X11 development packages in my Suse CD1 9.2"

They are there.

----------------------------
Steve Stites
 
Old 10-01-2005, 06:02 PM   #5
biledaemon
Member
 
Registered: Mar 2003
Location: Somewhere between Hell and Limbo
Distribution: Slack 10.2; Debian
Posts: 57

Original Poster
Rep: Reputation: 15
"They are there"

Could u specify where and what are these packages called in Suse 9.2? If I am not looking at them right of the bat, what should i put in the search field?

I tried:

1) X11
2) Development

Thanks for your input. Greatly appreciated for your patience at a newbie. Maybe they are already installed and I just happen to miss them..
 
Old 10-01-2005, 11:14 PM   #6
axobeauvi
Member
 
Registered: Apr 2003
Posts: 128

Rep: Reputation: 16
X11 is a generic term
I think 9.2 has XFree86 unless you installed Xorg
look for devel packs for xfree86
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X11 doesn't find needed libs Tantalos Linux - Software 5 12-30-2004 03:10 PM
Help! Running IglooFTP-PRO : error: does not find libgtk-x11-2.0.so.0 asaba Linux - Software 0 11-02-2004 11:36 AM
ld: cannot find -lgdk-x11-2.0 abirami Linux - Software 1 08-20-2004 07:20 AM
X11 development packages corbis_demon Linux - Newbie 2 07-01-2004 06:49 AM
xv can't find X11 header files tunedLow Linux - Software 9 07-02-2002 02:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration