LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 02-24-2008, 04:59 AM   #16
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198

Quote:
Install nvidia proprietory driver package - the supply output of lspci.
By default, ubuntu uses free (GPL license) drivers for hardware. Some manufacturers provide non-free drivers (i.e. nvidia). Your laptop has a lot of nvidia devices listed as "unknown". This suggests that you will be better off with the non-free drivers. Install them.

"lspci" is a terminal command which means "list pci devices". After you have installed nvidia drivers, open a terminal and enter "lspci". Copy the output here.

However - last post includes a link to an excellent overview on this nassty laptop. Read it through.
 
Old 04-11-2009, 07:22 AM   #17
Callumitus
LQ Newbie
 
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
Atheros wireless drivers

Hi guys,

Had a few problems with the same type of laptop on Hardy 8.04.
They were:-
* Wifi card was not recognised
* When the wifi card was finally installed and set up, the graphics card was not recognised, resulting in poor resolution.

Here is how I got around it from the start :-

1. Install the linux-backports-modules-hardy-generic package (I used Synaptic Package Manager).

2. Reboot your laptop.

3. After login, go to the Hardware Drivers tool in System > Administration and disabincludingle ALL ( 802.11 and HAL) atheros drivers except for "Support for 5.xxx atheros cards". If your screen resolution has defaulted back to the generic driver and shows here as the USB Display Driver, disable it too.

4. Reboot your laptop.

5. Go back Hardware Drivers and make sure that only "Support for 5.xxx atheros cards" is enabled (don't enable the other atheros drivers, I have found they tend to conflict).

6. If your display driver has defaulted to the USB Display driver as described in #3 (as it did in mine), then install the linux-restricted-modules package and reboot. When you login to Ubuntu again and go back into Hardware Drivers the USB Driver should be replaced by the NVIDIA drivers.

7. Enable the NVIDIA drivers and Ubuntu should determine which driver to use for your hardware. Leave the Atheros 802.11 and HAL drivers disabled, reboot your laptop once again and it should all be fixed. Wireless, wired and graphics.

8. When completed, you should have enabled only Support for 5.xxx atheros cards and NVIDIA accelerated graphics driver. If any other atheros drivers are enabled, disable them.

In the end I got the atheros card working along with the correct screen resolution.

Last edited by Callumitus; 04-13-2009 at 11:20 PM. Reason: to make it clearer
 
Old 04-13-2009, 12:39 AM   #18
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by Callumitus View Post
Hi guys,
Hello...
Quote:

Have just done this myself using Hardy 8.04
You followed these instructions for Ubuntu 8.04 (which used to be called "Hardy Heron"). But you have not said how this helped you, if at all, or if this would help anyone with similar problems to the OP. That sort of detail helps make your post useful.
Quote:

1. Install the linux-backports-modules-hardy-generic package (or replace hardy with the codename of your distro, ie, gutsy, intrepid etc)
It can make your message clearer if you edit the instructions you followed to show what you actually did. Here, I presume that you used the boldface version.

Quote:
6. If your display driver has defaulted to the USB Display driver as described in #3,
"IF"??? Well did it?
Quote:
then install the linux-restricted-modules package and reboot. When you login to Ubuntu again and go back into Hardware Drivers the USB Driver should be replaced by the NVIDIA drivers.
Was it???
Quote:
8. When completed, you should have enabled only Support for 5.xxx atheros cards and NVIDIA accelerated graphics driver.
And what was the result???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Ubuntu 7.10 on Acer aspire 4520 amitabhishek Linux - Laptop and Netbook 28 02-20-2008 06:19 PM
acer aspire 4520 riple Linux - Laptop and Netbook 1 10-15-2007 02:40 AM
which distro suitable for acer aspire 4520 zero717k Linux - Laptop and Netbook 2 09-10-2007 02:50 PM
Laptop Problems (Acer aspire 3682wxci) Boom_Fist Linux - Laptop and Netbook 1 08-14-2007 04:23 PM
laptop Acer Aspire 1522 Problems JJX Debian 2 01-01-2005 05:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration