LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 03-07-2008, 04:19 PM   #1
mrukjames
LQ Newbie
 
Registered: Jan 2008
Posts: 26

Rep: Reputation: 15
Problems selecting and running Windows Vista from Grub menu in Suse Linux 10.2


Hi, recently I wanted to go into Windows to check something, and have found that windows vista has disappeared from the Grub boot loader menu. In its place is XEN. When you click on it Windows doesn't install.

I have never seen this before or to my knowledge never have installed XEN. Do you know why this has happened? Also, do you know how I can boot windows or setup boot loader in Yast to configure this? I am fairly new to Linux,

Thanks,
James
 
Old 03-07-2008, 07:29 PM   #2
rabbit2345
Member
 
Registered: Apr 2007
Location: 中国上海
Distribution: Lubuntu 16.04 LTS
Posts: 372

Rep: Reputation: 40
Maybe whe you updated the kernel, the xen kernel was installed. But anyway, all you have to is:

1-open a terminal

2-switch to root using su - or sudo -i

3-type:

Code:
kwrite /boot/grub/menu
Code:
# Modified by YaST2. Last modification on Tue Feb 26 22:17:19 EST 2008
default 0
timeout 8
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/sda3 vga=0x31a resume=/dev/sda2 splash=verbose showopts
    initrd /boot/initrd-2.6.22.17-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title openSUSE 10.3 (Failsafe)
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/sda3 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.17-0.1-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title XEN
something...
???
stuff
so you need to remove the xen section and replace it with a chainloader
:
Code:
###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd?,x)
    chainloader (hd?,x)+1
replace the ? with your disk number, so if you only have 1 hd, then this will be 0

replace 'x' with partition number, starting from 0, so under linux, your windows partition is /dev/hdax (just a guess)

so in the end, your /boot/grub/menu.lst should look like this:
Code:
# Modified by YaST2. Last modification on Tue Feb 26 22:17:19 EST 2008
default 0
timeout 8
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/sda3 vga=0x31a resume=/dev/sda2 splash=verbose showopts
    initrd /boot/initrd-2.6.22.17-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title openSUSE 10.3 (Failsafe)
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/sda3 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.17-0.1-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows XP Professional
    rootnoverify (hd0,2)
    chainloader (hd0,0)+1
 
Old 03-08-2008, 08:04 AM   #3
mrukjames
LQ Newbie
 
Registered: Jan 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Hi thanks for showing me that, but I am still having trouble. I keep on getting an error that says it can't find BOOTMGR. I don't know what partition windows is on, it says sda2. I've tried it as 1 and 2, and I've only got one hard drive. I doesn't seem to work. I've restarted my computer about 30 times trying different things but I am not having any luck.
 
Old 03-08-2008, 06:34 PM   #4
rabbit2345
Member
 
Registered: Apr 2007
Location: 中国上海
Distribution: Lubuntu 16.04 LTS
Posts: 372

Rep: Reputation: 40
k,

if your windows is on sda2,

then the drive setting should be (hd0,1)

could you please give more detail on the BOOTMGR error?
 
Old 03-09-2008, 08:09 AM   #5
mrukjames
LQ Newbie
 
Registered: Jan 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Smile Thanks

Hi thanks,

I have just added the following code to the menu1st file and it worked
Code:
###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,1)
    chainloader (hd0,1)+1
I think it was because the title was different from the yast2 title, or maybe it was because I was stressed. I really appreciate your help.

Thankyou
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub Error 22 using Vista and Open SUSE 10.3 cheesecore Linux - Newbie 1 01-18-2008 07:33 AM
Vista Suse 10.3 & grub PB0711 SUSE / openSUSE 6 11-09-2007 06:43 PM
grub and Windows Vista 'Documents and settings' Riichard Linux - Software 1 08-09-2007 02:43 PM
installing vista upgrade on my windows partion, will GRUB get in the way? chris598 Linux - General 2 05-19-2007 08:44 AM
Triple Boot Vista,XP,Suse 10.2 Grub Can't Load Windows Maccer2007 Linux - General 3 02-14-2007 06:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration