LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 04-30-2005, 03:19 AM   #1
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
Problems installing SmartLink 56.6k External USB Modem on SuSE 9.2


It can be seen as a Thompson SGc 56k Modem (or something similar). I have downloaded the latest linux driver from their site and when i run make install and modprobe slusb the following output is the result.

My concern is line 14 (or 15 counting the actual command) and the result then of the modprode command.
 
Old 04-30-2005, 02:16 PM   #2
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
SuSE has the necessary software in Yast for the smartlink modem. I have used it on two laptops in the past.

Just do a search in add remove software for smartlink. Install the software and you should be able to set up your modem.
 
Old 05-01-2005, 04:32 AM   #3
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
http://linmodems.technion.ac.il/packages/smartlink/

So I've used the USB driver to be found there.

I have followed the instructions in the README and I am able to use slmodemd and and dev/ttySL0 has been created.

Howeever I have no clue what to do in KInternet to get a connection running

Last edited by Jongi; 10-28-2005 at 04:42 AM.
 
Old 05-01-2005, 04:36 AM   #4
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
USB obviously
 
Old 05-20-2005, 04:22 AM   #5
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
How do I ensure that the modem is assigned to /dev/modem at startup? When I run:

#ln -s /dev/ttySL0 /dev/modem

I get the following error:
ln: `/dev/modem': File exists

After doing this I then ran:

#slmodemd /dev/slusb0

Which results in the following output:
SmartLink Soft Modem: version 2.9.10 May 1 2005 08:21:29
symbolic link `/dev/ttySL0' -> `/dev/pts/3' created.
modem `slusb0' created. TTY is `/dev/pts/3'
Use `/dev/ttySL0' as modem device, Ctrl+C for termination.


This leads me to believe the system picks up the modem and it is ready to work. KInternet doesn't give me the option to setup the modem as /dev/ttySL0 which is why I need to set the modem up as /dev/modem.

I have setup the file /etc/sysconfig/slmodemd to look like this:
SLMODEMD_DEVICE=/dev/slusb0
SLMODEMD_COUNTRY=SOUTHAFRICA
 
Old 05-21-2005, 12:43 PM   #6
equinox
Member
 
Registered: Dec 2003
Location: Johannesburg, South Africa
Posts: 846

Rep: Reputation: 30
For

Code:
How do I ensure that the modem is assigned to /dev/modem at startup? When I run:
do

# rm /dev/modem

# ln -s /dev/ttySLO /dev/modem

For

Code:
This leads me to believe the system picks up the modem and it is ready to work. KInternet doesn't give me the option to setup the modem as /dev/ttySL0 which is why I need to set the modem up as /dev/modem.
Go to YaST and just create a custom modem (one that isnt configured or detected). Just point it to /dev/ttySL0 and all will work.
 
Old 05-22-2005, 02:25 AM   #7
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
equinox: is the a file where I should put the lines:

Quote:
# rm /dev/modem

# ln -s /dev/ttySLO /dev/modem
 
Old 05-22-2005, 02:30 AM   #8
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
equinox: it looks like you have set your desktop to 1280x1024. I can't seem to have KDE change to that resolution
 
Old 05-22-2005, 03:35 AM   #9
equinox
Member
 
Registered: Dec 2003
Location: Johannesburg, South Africa
Posts: 846

Rep: Reputation: 30
Question

No there is no file, the "#" just represents a bash prompt. So as root I'm telling you what to do at the command line. Regarding my screen resolution, what's that got to do with your modem ?
 
Old 05-22-2005, 03:38 AM   #10
equinox
Member
 
Registered: Dec 2003
Location: Johannesburg, South Africa
Posts: 846

Rep: Reputation: 30
Have you ever thought of using wvdial? As root once you have started "slmodemd", switch to another terminal and run "wvdialconf /etc/wvdial.conf".
 
Old 05-22-2005, 05:10 AM   #11
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Equinox: I take it that once I do that in a terminal (the ln command), then that will be a permanent change.

I did that and all is good (this is being typed from SuSE). Is there a way to connect without running slmodemd first. That is, a way of just running KInternet to connect?

The screen resolution is another problem that is affecting me and I saw that you seemed to have yours at 1280x1024 so I figured you might help.
 
Old 06-06-2005, 11:10 AM   #12
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
So is it not possible to have slmodemd run automatically on startup?
 
Old 06-06-2005, 11:14 AM   #13
equinox
Member
 
Registered: Dec 2003
Location: Johannesburg, South Africa
Posts: 846

Rep: Reputation: 30
Yes, copy the slmodemd.SUSE file from the scripts directory to /etc/init.d/slmodemd . Don't forget to chmod +x the script.
 
Old 06-07-2005, 03:38 AM   #14
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
I'll give it a try this evening . Thanks.
 
Old 06-08-2005, 02:57 PM   #15
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
So I have created the file /etc/init.d/slmodemd. That has been done by copying the file slmodemd.SUSE from slmodem-2.9.10_USB.tar.gz. This is the error that comes up when KDE starts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another smartlink modem problem, but on Suse 9.3 dabump SUSE / openSUSE 14 12-29-2005 04:29 AM
SUSE 9.3 smartlink modem problems thelonewolf SUSE / openSUSE 9 10-28-2005 12:00 PM
Smartlink USB modem installation on SuSE 9.2 dborzasi SUSE / openSUSE 3 06-03-2005 04:10 PM
SMARTLink 56k External Modem Problem!! movanns Linux - Networking 37 04-27-2005 04:11 PM
Smartlink USB modem LordPBA Linux - Newbie 4 03-13-2003 03:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration