-   SUSE / openSUSE (
-   -   Problem with LVM partitions (

firewiz87 04-29-2009 11:14 PM

Problem with LVM partitions
I have been using LVM partitions on my Open SUSE 11.0 machine for a while now.... But on a fine day, when booting the system, all i get is the following error:


Reading all physical volumes, This may take a while....
Couldnt find device with uuid 'iUDlO-VLkW-4fYN-u3cX-C0zR-lw4f-c7b8Eh'
Couldnt find all physical volumes for volume group system
Couldnt find device with uuid 'iUDlO-VLkW-4fYN-u3cX-C0zR-lw4f-c7b8Eh'
Couldnt find all physical volumes for volume group system
Volume group "system" not found
Could not find /dev/system/SUSE11.0root.
want me to fall back to /dev/system/SUSE11.0root?(Y/n)

Giving a Y to the above question gives the same error and exits to shell

My knowledge is limited to setting up of LVM....
Any idea why the error occurs?? I am pretty sure its not an HDD error...
There is more than 200 GB of data....
Is there any way to recover without losing data???

Thanx in advance

bhaslinux 04-30-2009 05:07 AM

this only means that the physical volumes are not found which are needed to
enable the VG into active mode.
Did you remove any partition/harddisk from the system ?

firewiz87 05-01-2009 12:33 AM

I have no hardware changes... the problem occurred without any reason which puzzles me....

I have two hard disks, one in which windows is installed (a few partitions from the disk are part of LVM) and the other disk in which Linux is installed....

Both the hard disks can be booted which means that the HDDs are ok....

JZL240I-U 05-04-2009 01:30 AM

That's not hardware changes. LVM can't find two partitions with the cumbersome handles of 'iUDlO-VLkW-4fYN-u3cX-C0zR-lw4f-c7b8Eh' and 'iUDlO-VLkW-4fYN-u3cX-C0zR-lw4f-c7b8Eh' respectively. You could map that on your system to /dev/sdxy by looking into the /dev directory and the "by-uuid" subdirectory.

They are gone --whyever-- and the physical volume is incomplete, thus the error. So without more information what happened to your partition table there is no getting a grip on this. I seem to remember, that the superblock has copies strewn all over the disk. Maybe you can restore your old partition scheme, never mind why it got lost in the first place...

bhaslinux 05-05-2009 03:28 AM

does the partial activation of VG work ?

vgchange -P -y <vg name>

this sometimes can salvage some data atleast ...
nevertheless as JZL240I-U told, why did the physical volumes disappear ?

firewiz87 05-06-2009 10:07 AM

Problem solved with no data loss.... :D
It seems that the problem was created by a corrupted metafile (as tommylovell pointed out) and also because of a corrupted partition table....

on checking the partition tables i found that infact one of my physical volumes was now shown as free space.....that is /dev/sda7 (in my case) was missing

Since i dont like fdisk too much i just used the windows disk manager to create an ntfs partition with the plan to convert it to ext3 later in linux.....
having created the ntfs partition, i now had /dev/sda7 partition

On booting back to linux i was surprised to see that the ntfs partition i just created was taken as a LVM system
(i have no idea why that happened.... it was not even a linux partition....hopefully somebody could explain that)

Anyway all my data is fine n i am the happiest man in the world ;)

Can somebody tell me why the NTFS partition created was accepted by LVM??? Should i change it back to a linux partition at a later stage?? The data is intact as far as i can see......

JZL240I-U 05-07-2009 03:11 AM

Uarghhh. That is nasty. If it were my data I'd backup them faster than ... whatever. After that, recreation of the partition with the correct file system type and formatting. Only then playing back the data.

To be on the secure side in the future, have a look at

firewiz87 05-09-2009 03:05 AM

I have already converted the partition to LVM (0x8e). Now its working properly....

Originally Posted by JZL240I-U (Post 3533026)
To be on the secure side in the future, have a look at

Good suggestion.... i was wondering if there was a live cd with all the data recovery software.....
Wondering if there is a GUI tool for working on LVMs.... Gparted does nt support LVM right???

JZL240I-U 05-11-2009 01:42 AM

Of these I know (but not how far they support LVM):

Then there is:


firewiz87 05-12-2009 01:18 AM

Thanx for the awesome list..... i ll check em out....

I wish there was a gui partition manager that supports lvm.... LVM is has all these wonderful features.... makes me happy until it crashes.... ;)

JZL240I-U 05-12-2009 04:57 AM

I don't use LVM anymore. Some years ago I had a file system crash. Rescuing data from LVM volumes was impossible (or I was too stupid). Since all the instruments of rescue in ext2/3 and dd etc won't work as easy if at all on LVM (at least, that is what I think and I don't want proof the hard way) and there is gparted etc I can't see the necessity for LVM anymore.

firewiz87 05-13-2009 12:42 AM

Yea recovery of LVM is difficult (trust me....i just faced it) as on a physical partition possibly because the lvm is how do u say it..... visualized??

Well one of the features i like about LVM is the resizing of partitions and its ability to add new partition..... just wish data recovery in LVM is easier too....

I am optimistic dat de condition will change in a short time.... hopefully.

All times are GMT -5. The time now is 08:15 AM.