LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 03-15-2007, 10:12 AM   #1
douart
LQ Newbie
 
Registered: Oct 2006
Distribution: SuSE11.1 86_64
Posts: 16

Rep: Reputation: 0
Privoxy problem


I have to restart privoxy after connecting to internet for privoxy to work.

Suse 10.2, dialup, Firefox, privoxy starts at boot
I have "modify dns when connected" and "automatically retrieve dns" selected.
I tried entering name servers in "connection parameters" and that did not help.
 
Old 03-16-2007, 08:56 AM   #2
Mojojo
Member
 
Registered: May 2003
Location: Philadelphia/PA
Distribution: Arch
Posts: 452

Rep: Reputation: 34
If your on dialup and you just wanna use privoxy to remain anonymous 2 things your just gonna slow your internet connection to a crawl and If I remember correctly with dialup you IP changes everytime you connect. If you really wanna remain anonymous I would suggest using tor. Firefox has a pluggin called foxyproxy which does the same as tor/privoxy did in the begining only without having to use privoxy. Hope this helps
 
Old 03-16-2007, 01:29 PM   #3
douart
LQ Newbie
 
Registered: Oct 2006
Distribution: SuSE11.1 86_64
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks for the reply Mojojo.

Ad blocking is my main concern. I am not interested in Tor.

(Mojojo) "your just gonna slow your internet connection to a crawl"

I do not notice a slowdown with privoxy.
I know "connection crawl". I live out of town where the phone lines are bad. If I could receive 2kB avg. downloads I would be thrilled. I have a friend in town with broadband where I download torrents, distros and other large downloads. I bring them home on an external HD or flash drive. I attached a handle to the top of my linux box to make it easier to carry it in for direct updates.

(Mojojo) "If I remember correctly with dialup your IP changes every time you connect."

Yes, my IP address is randomly assigned every time I log in to my IP provider, but I think the DNS that is assigned is the same. I was thinking DNS is the problem. I thought that configuring privoxy to look for a particular DNS would be the answer. I bogged down after several days trying to find out how to solve this problem. As I said, restarting privoxy after connecting works.

I considered a script to automate restarting privoxy with one click but learning how is taking too much time. I have learned some basics (very!) of python and bash scripting. I could not find a tutorial easy enough for me that would start a program as root or su and then put input into the program.
I fudged and used AutoIt with Windows to automate such things as connecting to Internet, defraging then shutting down, inputting "ping and lan addresses" at command prompt when troubleshooting, and other such tasks.

But, configuring privoxy to use a particular DNS (if that is the answer) when connecting to the Internet is, as is said, more "Elegant".
Sorry to run on with the drivel. I do not blog, I have sent few emails, and have made few posts over the years and may be it is all coming out at once!

I found privoxy and it seems to be a pleasant substitute for Proxomitron.

douart
 
Old 03-31-2007, 01:20 PM   #4
douart
LQ Newbie
 
Registered: Oct 2006
Distribution: SuSE11.1 86_64
Posts: 16

Original Poster
Rep: Reputation: 0
I reinstalled 10.2 with the 64 bit version.

Privoxy starts at boot.
Gnome desktop
I use Kinternet to start my dialup connection.
Firefox is configured to use Privoxy.

After connecting I have to restart Privoxy as su to browse.

I guess the problem is with "resolver.conf / dns". I tried many things but have not found the solution.

Anyone using Privoxy with dialup and not having to restart Privoxy?
 
Old 04-13-2007, 02:29 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
I don't understand the problem. You install privoxy via YAST. Then call the runlevel editor (expert modus preferably) and switch on privoxy in runlevel 5. Bingo. What is your problem, exactly? (No flame / slight intended...)
 
Old 04-14-2007, 07:52 AM   #6
douart
LQ Newbie
 
Registered: Oct 2006
Distribution: SuSE11.1 86_64
Posts: 16

Original Poster
Rep: Reputation: 0
Thank you for your interest JZL24O1-U.
Privoxy starts at boot.
After connecting to Internet by dialup Firefox gives this message, "The proxy server is refusing connections".
I have to restart privoxy by running, "/etc/init.d/privoxy restart", before I can browse.
 
Old 04-16-2007, 01:24 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Hmmm. Please in console try a
Code:
ps ax | grep privoxy
before trying to browse. What does it say? Privoxy really and truly living?

Do you use other proxies simultaneously?
 
Old 04-17-2007, 09:05 AM   #8
douart
LQ Newbie
 
Registered: Oct 2006
Distribution: SuSE11.1 86_64
Posts: 16

Original Poster
Rep: Reputation: 0
JZL24O1-U
I run (ps ax | grep privoxy) first thing after reboot.

I get: 3325 ? Ss 0:00 /usr/sbin/privoxy --user privoxy privoxy --pidfile /var/run/privoxy.pid --chroot /etc/config
4017 pts/0 R+ 0:00 grep privoxy

I then connect to dialup ip using kinternet.
Next I run (ps ax | grep privoxy) again.

I get: 3325 ? Ss 0:00 /usr/sbin/privoxy --user privoxy privoxy --pidfile /var/run/privoxy.pid --chroot /etc/config
4241 pts/0 R+ 0:00 grep privoxy

I then click on link to this LinuxQuestions.org thread.

I get 404 error page in Firefox that states:
"This is Privoxy 3.0.5 on unknown (127.0.0.1), port 8118, enabled
No such domain
Your request for http://www.linuxquestions.org/questi...d.php?t=537724 could not be fulfilled, because the domain name www.linuxquestions.org could not be resolved."

I then restart privoxy by running (/etc/init.d/privoxy restart)
After restarting privoxy after makeing the dialup connection I can browse.

I am using no other proxy.
Is'nt the problem dns related?
 
Old 04-18-2007, 05:40 AM   #9
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Ouuuh. Could that be privoxy 3.0.3? That has a known issue in DNS resolution (perhaps exclusively under SuSE). Download and build privoxy 3.0.6 that should cure the malady (did it myself but haven't activated it yet).

<edit> I see it is privoxy 3.0.5. Dunno the health status of that one...

<edit2> It might be easier to write a little script like
Code:
#!bin sh
/etc/init.d/privoxy restart
Kinternet
make the script file executable and point your Kinternet-button at that, instead of Kinternet itself.

Last edited by JZL240I-U; 04-18-2007 at 05:44 AM.
 
Old 06-19-2007, 01:19 PM   #10
douart
LQ Newbie
 
Registered: Oct 2006
Distribution: SuSE11.1 86_64
Posts: 16

Original Poster
Rep: Reputation: 0
Problem solved.
Added " /etc/init.d/privoxy restart " to end of
script at " /etc/ppp/ip-up.local ".
That restarts privoxy after a dialup
connection is made.
 
Old 06-20-2007, 01:01 AM   #11
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Okay, if that works for you. I tried privoxy 3.0.6 and that cured my dns problem.

I still don't understand that behaviour and find it inacceptable in a piece of software ... .
 
Old 06-29-2007, 09:51 PM   #12
wolfbite
LQ Newbie
 
Registered: Jun 2007
Posts: 4

Rep: Reputation: 0
Hello everyone.
I am fairly new to linux and I have Suse 10.2

When I try to install privoxy 3.0.3-1 rpm package, this error occurs:



Subprocess failed. Error: RPM failed: groupadd: GID 73 is not unique.
error: %pre(privoxy-suse-3.0.3-1.i386) scriptlet failed, exit status 6
error: install: %pre scriptlet failed (2), skipping privoxy-suse-3.0.3-1


---
groupadd: GID 73 is not unique.
error: %pre(privoxy-suse-3.0.3-1.i386) scriptlet failed, exit status 6
error: install: %pre scriptlet failed (2), skipping privoxy-suse-3.0.3-1

2007-06-29 22:45:10 privoxy-suse.rpm install failed
rpm output:
groupadd: GID 73 is not unique.
error: %pre(privoxy-suse-3.0.3-1.i386) scriptlet failed, exit status 6
error: install: %pre scriptlet failed (2), skipping privoxy-suse-3.0.3-1


---------------

Any ideas on how to fix this and successfully install privoxy? Thank you all in advance.
 
Old 07-02-2007, 01:12 AM   #13
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Wellcome to LQ, wolfbite.

I'd suggest you create your own thread with an appropriate title, so you'll get more and more to the point answers .

As to your problem, start YAST2 and open the module that lets you add groups (don't recall the exact name right now). It will list the groups already in existence. If there is a group "privoxy" you have it already installed.

Also check the documentation of privoxy...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Privoxy - "Privoxy is not being used" from http://www.privoxy.org/config/ slimjim Linux - Networking 1 03-12-2007 11:07 AM
Privoxy and tor dns resolution problem JAKK Linux - Networking 4 02-12-2007 12:31 AM
Privoxy???????? jason.rohde Linux - Networking 0 08-26-2005 09:11 AM
Privoxy Mortified Pengu Linux - Software 3 11-28-2004 12:11 PM
Permission Problem with Privoxy HaloinaHaystack Linux - Software 1 11-28-2004 12:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 11:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration