LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Plugins for Mozilla and Firefox (https://www.linuxquestions.org/questions/suse-opensuse-60/plugins-for-mozilla-and-firefox-313481/)

floppywhopper 04-15-2005 05:27 AM

Plugins for Mozilla and Firefox
 
Installed Suse 9.2 from DVD.
By default Konqueror was loaded with flash support but not Mozilla of Firefox.
So after playing around and generally feeling warm & fuzzy about Suse I decided to install Mozilla and Firefox. But they dont have the plugins for Java, Flash etc that Konqueror has.
Is there any simple way of doing this.

Konqueror has a nice little utility for scanning the system for plugins, does Mozilla and Firefox ?

floppy

salparadise 04-15-2005 07:27 AM

Find the place where the plugins that Konqueror is using is. This may be /usr/lib/mozilla/plugins/
Then copy them to /usr/lib/mozilla-1.x/plugins and /usr/lib/mozilla-firefox/plugins.
If Mozilla is not installed a "pretend" mozilla dir is created and the plugins placed there. In the "configure Konqueror" menu there should be a plugins section which will give the actual location of all currently found plugins. (This helps in locating the correct dir for copying. Also, some distros put firefox in /usr/lib/firefox and some in /usr/lib/mozilla-firefox).
Either copy them by invoking Konqueror as root or from the command line.

Hope this helps some.

dwrose 05-10-2005 12:45 PM

I am assuming you installed Mozilla and/or Firefox from the SuSE sources.

In SuSE Pro 9.2, the locations for mozilla is /opt/mozilla, so plugins are in /opt/mozilla/lib/plugins. Similarly, for Firefox, the location is /opt/MozillaFirefox.

Also, there is a package for the Java plug in that does install for Mozilla and Firefox, but if you tried another plugin install (say from the java.com website), then you may have a bad softlink in either plugins folder. So, go look and rm if necessary.

floppywhopper 05-10-2005 06:02 PM

Tried all those things, sadly no-go
for other reasons I have to re-install Suse
so I'll have a go and make sure that Mozilla and Firefox are installed
in the first instance

Thanks for the help guys
floppy

dwrose 05-10-2005 06:33 PM

When you reinstall, or after you reinstall, also select java-sun-1_4_2-plugin package for install.

So far, I have found that its best policy to install from SuSE sources first, only if you are sure that SuSE doesn't have it look elsewhere.

Not always easy, as I found out trying to get my HP printer to work, I ended up having to uninstall something else once I found the name of the package that I needed.

Good luck, I'd like to know how it turns out.

pilotgi 05-11-2005 03:33 PM

It would be easier to diagnose this problem if you would post what version of Firefox is installed and where you got it from. After it's installed, type about: plugins(no spaces) in the address box and post the results. I just upgraded to SUSE 9.3 and flash, realplayer, acroread, and java plugins links were already installed in /opt/MozillaFirefox/lib/plugins.

I upgraded the java plugin to 1.5 because the default version was 1.4.2.

dwrose 05-13-2005 08:23 AM

This issue is reported on SuSE's knowledgebase:

http://portal.suse.com/sdb/en/2004/1...avaplug92.html

Basically, it says you have to install java-1_4_2-sun-plugin package using YaST, although there is an additional caveat for 64-bit machines.

J.W. 05-13-2005 03:20 PM

As far as getting Flash to install for Firefox (v1.0.3), all I did was go to a page that used Flash, and Firefox told me there was a missing plug-in, with a "Click here to get it" message. Installation required about 2 more clicks, and it's done. -- J.W.

If you need a page that uses Flash, you can use this one


All times are GMT -5. The time now is 05:19 AM.