-   SUSE / openSUSE (
-   -   Playing Midi in SuSE 9.2 (

Mic Q 01-07-2005 06:08 PM

Playing Midi in SuSE 9.2
Can SuSE 9.2 play midi files? Kmid can be activated but with no sounds.

The same for NoteEdit and virtual keyboard, tried but no sound?

Caeda 01-08-2005 09:00 PM

Click on the midi-file and it plays in the embedded player?

Mic Q 01-09-2005 03:33 AM

Clicked on a midi file (e.g. song.mid) and KMid will start.

It seems like playing but no sound is heard.

Caeda 01-09-2005 01:14 PM

You've checked all the mixers settings to be sure you don't have any channels muted that might be cancelling your midi sounds? Do you have an actual midi sound card or are you depending on suse's midi emulation...

Caeda 01-12-2005 04:41 PM

Muwahahahaha... I bet you gave up on me :-D

Well, i been busy.
I've found roughly 12 dozen ways to play a midi file in suse, and here's the 2 easiest, and I'll make a new thread for this so others can see. :)

Option one. Make sure you have the "netscape" plugger and other browser plugins installed from yast. Right click on any midi file and select "Preview" and "Preview In Netscape Plugger" This uses the browser plugin to play it.

Option two, the nicer way. There's an rpm of xmms-midi??.003???.rpm on Or you can use google to locate an rpm if need be. Install the rpm from a command line with rpm -Uvh --nodeps xmms*.rpm You'll need the nodeps part because it won't recognize suse's odd placement of timidity++, which is installed by default.

XMMS can now load and play midi files :) Enjoy.

Mic Q 01-12-2005 06:47 PM

will be away from my SUSE box for a while but still visiting the forum daily ;)

gave up on you ? NO WAY , linux and its people are by far the best :D

will try when back with SUSE (may be quite some time), :(


All times are GMT -5. The time now is 12:57 AM.