-   SUSE / openSUSE (
-   -   Play DVDs (

suavecu 04-05-2006 09:33 PM

Play DVDs
OK, this sucks, I was going to switch to Unbutu, but Ktorrent keeps crashing on me, so I can't seem to finish the download at the moment. So I figure, since I have to fix something anyways, I might as fix what's giving me the reason to switch to another distro.

DVD's, the bane of my existense. It seems that 18 million people have had this same problem, yet it looks like I've done what they asked and I still can't get it to work. The problem is, it actually plays the DVD only until the end of the FBI warning about copywrite violation (which is funny in it's own right) and then stops, regardless of the player (MPlayer, Kaffiene, Gxine, Codene).

I have the Packman and guru repositories installed (it's where I downloaded MPlayer, and the unproteced win32 codecs from). I've read that I have to install libdvdcss and have tried unsuccessfully (I think). It finishes with the ./configure but doesn't say anything when it's done. When I run make, it doesn't error out, but nothing really happens. Then I run make install and this is how it ends


make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/usr/libdvdcss-1.2.8/src'
make[2]: Leaving directory `/usr/libdvdcss-1.2.8/src'
make[1]: Leaving directory `/usr/libdvdcss-1.2.8/src'
Making install in test
make[1]: Entering directory `/usr/libdvdcss-1.2.8/test'
make[2]: Entering directory `/usr/libdvdcss-1.2.8/test'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/usr/libdvdcss-1.2.8/test'
make[1]: Leaving directory `/usr/libdvdcss-1.2.8/test'
make[1]: Entering directory `/usr/libdvdcss-1.2.8'
make[2]: Entering directory `/usr/libdvdcss-1.2.8'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/usr/libdvdcss-1.2.8'
make[1]: Leaving directory `/usr/libdvdcss-1.2.8'
Which is what makes me think nothing is really happening. I tried to find it with Yast and there is absolutely nothing there, which is annoying in it's own right.

So as for the check list I've installed MPlayer, Xine, Kaffiene, Codene and the win32 codecs. I tried to compile the libdvdcss and got to the above point. When I try to play dvd's it plays only the FBI warning on every dvd and then stops.

Maybe I can figure out why Ktorrent keeps crashing and switch distros as my friend has Unbutu and plays DVDs right out of the box, but I've got to the point where I know my openSuse system and would like to be able to keep it rather than installing another freaking OS. If you don't know how to troubleshoot this, any suggestions as to how to get more information so that I can create more helpful post that would be appreciated as well.

Thanks ahead of time for all of your help (and I thought getting my iPod to synch up, and playing mp3s was frustrating),

abisko00 04-06-2006 06:30 AM


Could there be some DVD region problem (maybe your drive is locked in the wrong region setting)?

All I can suggest is to try the installation of libdvdcss again. There are quite simple instructions for SUSE on
MPlayer, however, should be already compiled with libdvdcss. Strange that this doesn't work either. You could also try VLC:

suavecu 04-06-2006 07:46 AM

Well the DVD player has played DVDs in Windows and in Mandriva 2006 (although I didn't like Mandriva) so I don't believe it's the DVD players.

When I get home from work I will try to install lidvdcss again from the linnk you posted, and I will also try the VLC and let you know how it goes.

If anyone has any other Ideas until then, let me know and I'll try them too.

fragos 04-06-2006 07:16 PM this page has a link to a newer dvdcss and some instructions part way down the page.

suavecu 04-06-2006 08:48 PM

I tried using the auto script for Suse 9.0 >= from the first link

and it ended with:


libdvdcss2 have not been installed
so I'm assuming that didn't work.

I tried installig as an rpm from the second link (followed it through to where I download the rpm from) I get the message:


file /usr/lib/ from install of libdvdcss2-1.2.9-1 conflicts with file from package
It still will not play with MPlayer, however, now it plays with Kaffiene and Xine, but it's is choppy and has no sound. So even though it was never "installed" it's getting me past where I was. Going to try and restart it, although I'm pretty sure that won't do anything either :(

I'll try and keep people updated as to what is going on.

suavecu 04-06-2006 08:58 PM

So the audio problems was really funny. I had my headphone plugged into my speakers and they were on the floor. I almost busted them because I turned the volume all the way up and finally heard them behind my desk. I'm should add the ID: DOT to my swipe card.

So while that caused me to laugh out loud the choppiness of it hasn't changed :( Does anyone have any idea why it would be choppy like that? Is it because the libdvdcss didn't really finish installing.

Also, the sound is perfect, but the video is choppy as all crap. I'm using Kaffiene now, or anything with the xine engine (MPlayer still says no sir).

Thanks again for your help.

suavecu 04-06-2006 09:08 PM

Ok playing it in straight Xine may have given me some of the answers. It said I was dropping too many frames and to go to here for help. When I went there it said to run xine-check and that it would answer most problems, which I think it did. Although solving these problems may be difficult (I never know what's going to be easy or hard anymore).

The first one says


Your X server doesn't support YV12 overlays.
That means xine will have to do color space transformation and scaling
in software, which is quite CPU intensive. Maybe upgrading your
X server will help here.
If you have an ATI card, you'll find accelerated X servers on
I have no idea what to do there, but I do have an ATI card so I'm going to go to the site and see if it tells me. The second "hint" was exactly the same, not sure why it came up twice.

The third and finaly hint said:


Your X server doesn't have any XVideo support...
XVideo is an X server extension introduced by XFree86 4.x. This
extension provides access to hardware accelerated color space
conversion and scaling, which gives a great performance boost.
If you have a fast (>1GHz) machine, you may be able to watch all
kinds of video, anyway. You will waste lots of CPU cycles, though...
I don't have a guess on what to do with the third one, but I'm guessing that the first two might infact fix the last one. Possibly by replacing my Xserver (still don't know how to do that) it will give me XVideo support.

I'll keep you posted, and anyone else who may be in this crappy sinking boat of mine :)

suavecu 04-06-2006 09:15 PM

This is getting comical, there is no information about any XServer at that website, and although they have a bunch of links. They all take you to the same page, about Open Media System, and how they won some case battle. However you can't actually download the software from them. Going to try google to see if I can find an XServer for an ATI card.

suavecu 04-06-2006 10:38 PM

Well that was close, I backed up my X11R6 folder, installed the new one, and when I started back up there was no startx file. Thank god I backed it up. Still stuck :(

Anyone have any ideas as to where to get an X server that can support an ATI card, still trying to figure out Gatos.

suavecu 04-06-2006 11:06 PM

When I run Xine from the console, after the encription is done getting set. It just says bad_frame over and over again. Regardless of the DVD I use.

I figure the problem is now what Xine says it is and that I have to get a new X server, although, this is where I am stuck now.

Any help will be greatly appreciated.

suavecu 04-07-2006 05:56 PM

Shameless bump. Still nothing.

suavecu 04-07-2006 07:38 PM

Is it possible that I can run KDE without an X server? Then is it possible that the ATI-Driver propirety (SP?) doesn't come with one and that's why I'm getting this error?

Should I unintall the ATI-Driver and try to install XFree86 from the Gatos people and see how that works?

suavecu 04-08-2006 01:24 AM

Well I have Unbutu so this is probably the end. I'll let you know if Unbutu fixes all my problems tomorrow.

piscikeeper 04-08-2006 02:00 AM

it probably won' need the accelerated ati drivers installed.

suavecu 04-08-2006 07:11 PM

Well it kind of worked. I had a problem with my installation media so I had to resinstall Suse again. Well this time I ran the update right off the bat, I installed the two repositories (packman and guru) and installed MPlayer. This time, I never isntalled the ATI-driver and it worked. :)

I'll probably end up screwing it up again. If I do, I'll let you know :)

All times are GMT -5. The time now is 11:06 PM.