LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   passwordless login SuSE 10.1 (https://www.linuxquestions.org/questions/suse-opensuse-60/passwordless-login-suse-10-1-a-455916/)

tsmalley 06-18-2006 07:53 AM

passwordless login SuSE 10.1
 
Hi, I cannot use the passwordless login feature in SuSE 10.1. I have tried setting it in YaST,
Control Center, Security and Users,User Management, Expert Options, then Login settings. I then chose, Write changes now. Upon next login, I still have to enter my password.

I also tried setting this in KDE Control Center, System Administration, Login manager. Then on the Convenience tab, I enabled passwordless logins for myself, saved the changes, but then once again, the next time I log in I always have to enter my password.

Is there a text file or config file I need to edit in order to enable this?

Thanks to whoever can help with this!

homey 06-18-2006 08:31 AM

I think the correct term is AutoLogin.
I just tried that on my Suse 10.1 KDE and it gets me in without typing a password ( I still do have a password, just don't need to type it. )

As root user, I went to
YaST / Control Center / Security and Users / User Management / Expert Options... / then Login settings
[X] AutoLogin
User to Log In ( fred )
OK

That info is in /etc/opt/kde3/share/config/kdm/kdmrc
AutoLoginEnable=true
AutologinUser=fred

tsmalley 06-18-2006 09:06 AM

Homey,
Well, I did the same thing you did, and it still requires a password every time. Could it have something to do with me running Xgl? I also checked the above mentioned config file, and it is also enabled there. BTW, there are two settings, one for AutoLogin, and the other for Passwordless login.

homey 06-18-2006 09:12 AM

I don't know why it isn't working on your system but, I sure wouldn't recommend using Passwordless login on anything other than the virus mill ( Windows ) .


All times are GMT -5. The time now is 08:39 PM.