LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   package with asm/io.h? (https://www.linuxquestions.org/questions/suse-opensuse-60/package-with-asm-io-h-595596/)

basd 10-29-2007 05:07 PM

package with asm/io.h?
 
I am trying to compile "gins", which is telling me it cannot find "include/asm/io.h".

My websearching indicates this may be part of the kernel headers. Whatever package it belongs to, I can't find it -- I've installed all of the libraries that sound to me as though they might be necessary for compiling this gcc++ program.

(GINS is a program that is supposed to be able to take a Glade GUI and use it to manage ordinary command line scripts. I've got GLADE/GTK2/GCC/GCC+ libraries loaded, as well as some kernel libraries, but still no io.h)

I would ask in the "programming" forum, but I suspect that solving this particular problem will require finding out which SUSE package contains the io.h file.

Thanks.

auxsvr 10-30-2007 11:05 AM

You need the kernel-source package.

basd 11-01-2007 01:13 PM

kernel source and asm/io.h
 
Yes, thank you -- I do have the kernel source package installed. In fact, I have numerous "io.h" packages, but none in the path searched by "make". I tried using include/linux/io.h -- this didn't work because it generated lots more missing references.

It seems that my path for compiling programs is missing an appropriate directory, but I'm not certain how to correct that or what directory should be included that is presently not included.

Thanks again.

Barrington

auxsvr 11-02-2007 10:03 AM

The file /lib/modules/$(uname -r)/source/include/asm/io.h should exist if you are running the kernel that corresponds to the kernel-source package. Are you running the opensuse stock kernel?


All times are GMT -5. The time now is 07:39 AM.