LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-23-2005, 05:49 PM   #46
Animortis
LQ Newbie
 
Registered: Nov 2005
Distribution: PCLinuxOS
Posts: 4

Rep: Reputation: 0

Ah, permit me to clarify myself. It's not immediately clear what the URL is of the repositories the OpenSuSE website is referring to when it says, "A complete SuSE experience." I found the other URLs okay, after some hair-pulling and missed links, but I'm still not sure what it refers to in that instance.

What I find works very well is some linked to in the article, "Hacking OpenSuSE" on The Jem Report. Maybe they're what they refer to? Clicking "International Mirrors for the Released Versions" happens to be a bad link on the site. (OpenSuSE's website needs to be as clean as its distro!)

Listed in the article are:

mirrors.kernel.org/opensuse/distribution/SL-10.0-OSS/inst-source-java
mirrors.kernel.org/opensuse/distribution/SL-10.0-OSS/inst-source
mirrors.kernel.org/suse/i386/10.0/SUSE-Linux10.0-GM-Extra

Plus adding Pacman leads to a very easy install of most any software you want...

Sorry about the confusion. SuSE
 
Old 11-30-2005, 06:26 PM   #47
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Rep: Reputation: 15
I'm afraid I must be doing something wrong here. I just installed opensuse 10.0. I go to YaST, Software, Installation Source, then click "Add."

No matter what I try to add (packman, mirrors, etc.), I get the following message:

Unable to create installation source from URL
Details:
ERROR(InstSrc:E_no_instsrc_on_media)

What does this mean, and how do I fix it? I've been reading all the various threads on 10.0 sources, but I can't get anything to work.

thanks!
 
Old 12-01-2005, 02:40 AM   #48
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
General rules for YaST sources:

- enter the plain server address. No slashes, no protocols! (e.g. ftp.suse.com)
- enter the path to the directory that contains the file 'directory.yast'. No other directory will work!
- do not start the path with a slash!

Otherwise, use the command 'installation_sources -a <url>' from a root-console. Here you can type the URL just like you would do in your browser. This is a good way of testing the URL, btw: type it in your browsers address line and see if you find the file 'directory.yast'.
 
Old 12-01-2005, 05:04 PM   #49
ungua
Member
 
Registered: Oct 2004
Location: bergen, norway
Distribution: OpenSuSe (SuSe 10.1), Win XP Pro
Posts: 539

Rep: Reputation: 30
Quote:
Originally posted by craigevil
Success!!

Added
http://ftp.opensuse.org/pub/opensuse...1/inst-source/
http://ftp.opensuse.org/pub/opensuse...t-source-java/

Yippie. Also found out how to look through the package instead of just searching. SUSE is cool. The only thing I can't find is Rox-filer.

But hey I did find Wesnoth and Fillet two of the coolest games.
unfortunately, none of the sources mentioned above works for me...!? i wanted to install all the necessary media-things (can't even watch .mpg-files now), but the message i get is always the following: http://home.arcor.de/noroli/Bildschirmphoto2.jpg
(the picture shows a weird failure like ftp://http:// - this was my fault, reproducing a screenshot in a hurry. else i follow the yast-rules mentioned above)

is there any possibility for a failure in yast? am i doing something wrong? using the terminal is not really an option for me.

i appreciate any help!

regards
ungua

edit: similar error to cartwright, i presume...?
edit 041205: ... in other words, there is no solution? any other options to update the system? i cannot even watch videos now.

Last edited by ungua; 12-04-2005 at 11:36 AM.
 
Old 12-09-2005, 10:11 AM   #50
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
http servers:

packman.rsync.zmi.at
suse/10.0

packman.iu-bremen.de
suse/10.0


ftp servers:

ftp.gwdg.de
pub/linux/misc/suser-guru/rpm/10.0

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source-java

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source

mirrors.kernel.org
suse/i386/10.0/SUSE-Linux10.0-GM-Extra

mirrors.mathematik.uni-bielefeld.de
pub/linux/suse/suse/i386/current/SUSE-Linux10.0-GM-Extra


Don't forget to turn it on and make it available.

If you still have errors then type it manually. Sometime cut and paste doesn't work simply because you add a space before or after that unintentionally then it won't give you correct address!
 
Old 12-21-2005, 04:05 PM   #51
serpico
LQ Newbie
 
Registered: Dec 2005
Location: Vancouver, Canada
Distribution: Suse
Posts: 1

Rep: Reputation: 0
Thanks guys for this sticky. I just installed Suse 10 from a DVD iso I downloaded on a PC that couldn't install Windows. Glad the install worked great and now to add these suggestions. I also found this article that helped me and may assist others:

http://linux.wordpress.com/2005/10/07/hacking-opensuse/

Last edited by serpico; 12-21-2005 at 10:45 PM.
 
Old 01-03-2006, 11:16 PM   #52
schneemann
Member
 
Registered: Nov 2005
Location: Nord Vancouver
Distribution: suse 10.0
Posts: 106

Rep: Reputation: 15
Question

Quote:
Originally Posted by cartwright
I'm afraid I must be doing something wrong here. I just installed opensuse 10.0. I go to YaST, Software, Installation Source, then click "Add."

No matter what I try to add (packman, mirrors, etc.), I get the following message:

Unable to create installation source from URL
Details:
ERROR(InstSrc:E_no_instsrc_on_media)

What does this mean, and how do I fix it? I've been reading all the various threads on 10.0 sources, but I can't get anything to work.

thanks!
I have the same problem but I solve it and what aherm sayed

http servers:



packman.iu-bremen.de
suse/10.0


ftp servers:

ftp.gwdg.de
pub/linux/misc/suser-guru/rpm/10.0

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source-java

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source

mirrors.kernel.org
suse/i386/10.0/SUSE-Linux10.0-GM-Extra

mirrors.mathematik.uni-bielefeld.de
pub/linux/suse/suse/i386/current/SUSE-Linux10.0-GM-Extra


Don't forget to turn it on and make it available.

If you still have errors then type it manually. Sometime cut and paste doesn't work simply because you add a space before or after that unintentionally then it won't give you correct address!

After I click ADD after it is doing samething after when it was finished on my screen I can see only packman.iu-bremen.de/suse/10.0 no error,I counted packman.iu-bremen.de/suse/10.0
exatly 85 times packman.iu-bremen.de/suse/10.0.
What is going on?
 
Old 01-05-2006, 12:42 AM   #53
schneemann
Member
 
Registered: Nov 2005
Location: Nord Vancouver
Distribution: suse 10.0
Posts: 106

Rep: Reputation: 15
Quote:
Originally Posted by schneemann
I have the same problem but I solve it and what aherm sayed

http servers:



packman.iu-bremen.de
suse/10.0


ftp servers:

ftp.gwdg.de
pub/linux/misc/suser-guru/rpm/10.0

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source-java

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source

mirrors.kernel.org
suse/i386/10.0/SUSE-Linux10.0-GM-Extra

mirrors.mathematik.uni-bielefeld.de
pub/linux/suse/suse/i386/current/SUSE-Linux10.0-GM-Extra


Don't forget to turn it on and make it available.

If you still have errors then type it manually. Sometime cut and paste doesn't work simply because you add a space before or after that unintentionally then it won't give you correct address!

After I click ADD after it is doing samething after when it was finished on my screen I can see only packman.iu-bremen.de/suse/10.0 no error,I counted packman.iu-bremen.de/suse/10.0
exatly 85 times packman.iu-bremen.de/suse/10.0.
What is going on?
I can not think,that no one of you have lot`s of patience like me hehehehehehe.But that is ok on other hand I fund my answer in few more days not in that forum and that gentleman got far more patience then your guys.
Wow I can`t wait for that that my dvd media will work with commercial DVD`s and I have no more problem with my suse 10.0.

adios amigos
 
Old 01-09-2006, 11:32 AM   #54
lefty.crupps
Member
 
Registered: Apr 2005
Location: Minneap USA
Distribution: Debian, Mepis, Sidux
Posts: 470

Rep: Reputation: 32
I read somewhere here that the prelink program may no longer be in by default. I agree that it takes a good chunk of time to prelink after running Kynaptic, but isn't that prelinking the point of the SUPER release?

Last edited by lefty.crupps; 01-11-2006 at 07:54 AM.
 
Old 01-16-2006, 02:21 PM   #55
ungua
Member
 
Registered: Oct 2004
Location: bergen, norway
Distribution: OpenSuSe (SuSe 10.1), Win XP Pro
Posts: 539

Rep: Reputation: 30
thank you, aherm, suddenly it works at my pc. but there's new trouble: when i search for "xine", then press "install all" and afterwards "update when newer version available" i get an error-message that arts, libxine, directfb, imagemagick etc do not exist and there are a couple of conflicts. so how do i do a complete media-update without worrying??

i was on holidays for 40 days and hoped the problem could be solved rather fast now. still cannot watch videos or listen to mp3...

regards
ungua

edit: "arts" is mentioned some places, but i cannot install it form your first http-link. am i supposed to keep looking? why is yast only telling me what i lack without the option "install everything necessary"? wouldn't that be easier??

Last edited by ungua; 01-16-2006 at 02:26 PM.
 
Old 01-17-2006, 03:29 AM   #56
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
Any repositories for KDE 3.5?
 
Old 01-17-2006, 04:44 AM   #57
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Quote:
Originally Posted by Jongi
Any repositories for KDE 3.5?
Try the usual KDE supplementary sources on the official SUSE mirrors.

E.g.:
ftp://ftp.gwdg.de/pub/linux/suse/ftp...0/yast-source/
 
Old 01-19-2006, 06:11 AM   #58
inertia666
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Rep: Reputation: 0
I can't get a single user defined source to work at all. I just get different retrieval errors all the time, depending on which ftp / http address I use.

The first time i used this in suse 9.3 it worked first time so I can't imagine that using Suse 10 i am being so stupid as I can't get something this simple working.

I can navigate all the address perfectly well in a browser, but YAST will not use them.

Code:
error
HTTP return code: 404 (URL: http://packman.iu-bremen.de/suse/10.0/i386/update/10.0-OSS/patches/directory.3)
when using packman.iu-bremen.de/suse/10.0

Last edited by inertia666; 01-19-2006 at 06:15 AM.
 
Old 01-19-2006, 06:21 AM   #59
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Could you post the URL's you are trying to use?
 
Old 01-19-2006, 06:23 AM   #60
inertia666
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Rep: Reputation: 0
http servers:



packman.iu-bremen.de
suse/10.0


ftp servers:

ftp.gwdg.de
pub/linux/misc/suser-guru/rpm/10.0

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source-java

mirrors.kernel.org
opensuse/distribution/SL-10.0-OSS/inst-source

mirrors.kernel.org
suse/i386/10.0/SUSE-Linux10.0-GM-Extra

mirrors.mathematik.uni-bielefeld.de
pub/linux/suse/suse/i386/current/SUSE-Linux10.0-GM-Extra


none of these work for me at all. i get different error messages.
The predefined sources in yast are working fine.

This is really doing my head in, and it's the very reason I am finding it hard to switch over to linux, despite many months of trying on and off. I always seem to stumble over stupid problems and once again I am maintaining the operating system rather than it maintaining me.

This has to be a yast bug, I can't be that stupid to not even get a simple thing like this working.,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
YAST Repositories Wavz Linux - Software 2 08-06-2006 08:30 AM
yast and repositories unionjak SUSE / openSUSE 9 11-14-2005 02:16 AM
Please help with setting up Yast repositories in SuSE 10.0. LaptopLinux SUSE / openSUSE 8 11-07-2005 07:27 PM
Yast unoffical repositories Henster Linux - Newbie 4 09-20-2004 03:30 PM
How do I use Suse's Yast to install packages from alt repositories? tlawlessrr Linux - Software 3 07-12-2004 04:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 06:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration