-   SUSE / openSUSE (
-   -   opensuse 11 - compiz x86_64, libcompizconfig 586... wait, what? where is x86_64 ver? (

almcneill 09-24-2008 06:41 PM

opensuse 11 - compiz x86_64, libcompizconfig 586... wait, what? where is x86_64 ver?
I hope this catches someones eye, had some problems with compiz, like crashing, serious screen glitches, and such. I was a little disappointed because i have been using compiz-fusion since the beginning with very minor problems that i could easily fix.

Anyway, i figured that i could fix this as well. I tried everything, NOTHING seemed to work! So after some time i noticed (through xterm) that i was getting a ccp error from compiz on starting. After some research i found this to be a simple fix, my compiz and libcompizconfig were not compatible version. Oh, ok i must have selected the wrong version during an upgrade, no problem! I will just run yast and select the correct version...

Lets see compiz version 0.7.8-25.1-x86_64 and
libcompizconfig version 0.7.8-2.1-i586 hmmm, i don't get it, they are the same versions, they should be working... oh wait i just noticed 64 and 586... DUH, i feel like a fool.

So, since i have an 64 bit machine i will just select the libcompizconfig version 0.7.8-2.1-x86_64... HEY, wait a minute, where the hell is it??? There isnt one! What the?!?!

OK, minor set back, just search the internet for it,,,,,,, there is only a 586 version???? Oh come on!!!

OK, i know that this may seem a little petty, BUT certain things cannot be done with the version that i am running (like the cylinder shape) you know the eye catching candy plug-ins that only work with newer versions...

So, a simple request for a simple man. Please Novell, post the correct library file to the repository so that i may resume pleasing my eyes with all the latest and greatest eye candy!!

Thank you very much in advance,

a very loyal suse user since ver 7.0

CRC123 09-25-2008 10:53 AM

What's wrong with compiz-fusion? It should have everything compiz has and I know for a fact it works on 64-bit since I run it on 64-bit.

almcneill 09-25-2008 11:51 PM

why didn't i think of that?
well why didn't i think of that... oh thats right since beryl and compiz joined, it has been called compiz-fusion, and opensuse only puts the compiz package in the repository, possibly due to the fact that it IS compiz-fusion, and its just easier to call it compiz (i don't know im just guessing), but yes i am sorry for not stating myself properly, i was providing technical names for the packages. And if you do have compiz"-fusion" working please can you tell me what version, iteration, so on, and so on...

I would appreciate it if you would not try to point out that i must be a fool for using the wrong package as to if you notice in my first post, i DID my research first before posting. I try to refrain from just pointing out over-sighted outbursts.

Thank you,

almcneill 09-26-2008 12:01 AM

ahhh, so i see i'm not the only one now....

here is another post.....

olva 09-26-2008 02:47 AM

i read your thread but still did not get it till now , are you using the new version of compiz or just stuck with the previous version like what i did ?? and if you are using the new one , would you please send me a link for this libcompizconfig to upgrade mine also .

almcneill 09-26-2008 07:34 AM

no, sorry unfortunately i am still using the old one due to the fact that there is not an x86_64 libcompizconfig only a 586 version, and it is NOT compatible with the 64 version of compiz. I would very much love to use the newer version due to the simple fact that many of my plugins for compiz that i like to use are not working with the older version that i am using.

So, if ANYONE can find the 64 version of the library file, PLEASE PLEASE PLEASE let me know.

By the by, this is the novell forum, do they not monitor it for problems like this???

CRC123 09-26-2008 10:00 AM

I just checked my compiz packages and apparently the x86_64 version of libcompizconfig 0.7.8 was available at some point and time, but no longer. But using this site, I found a repo that has it. I also have the XGL repo.

Macchiavelli 09-27-2008 05:28 AM

I've the same Problem

I have the same problem if I install compiz x86_64 Ver 0.7.8-25.1 on my OpenSuSE 11.0 system. After install no more window dekos are visible, and no effects, like wobbly, are there.

I need help to.

olva 09-28-2008 02:09 AM

just downgrade to the previous version

almcneill 09-28-2008 11:36 AM

I could downgrade or...
OK, so i got a wild hair up my... (well, you know) this morning. I tried the repositories that you had pointed to in an earlier post, but was having serious glitches with KDE. So, frustrated i did downgrade to the 0.7.4.blah.blah.blah version that comes on the DVD. Of course, it does not allow you to rotate a sphere or cylinder, only the cube. I know, I know, pretty petty of me (call me vain), but I enjoy my eye candy, and besides, whats the use of advancing utilities if they don't work?

Well, I solved it this morning right before posting this (well sort of).

The repository would have you upgrade from 0.7.4... to 0.7.8... which is missing the x86_64 libcompizconfig file. So for laughs, i turned that repository off, and instead turned on the same repository but for opensuse version 10.3 instead of version 11. This provides you an upgrade from version 0.7.4... to 0.7.6! Now i'm sure that this is missing some gadgets that the 0.7.8 ver has, BUT, being as that i have not been able to use that ver properly yet, im not missing anything! So, now i can rotate my sphere instead of just a cube (i know, vain)! But it works, of course dependencies will complain about compiz-kde4 and that it must be un-installed, but if you let it do that, it works beautifully!

I will keep trying, and see if i can't get compiz-kde4 back in somehow and report back.

Oh yeah, if needed for anyone else following along here, and would like the temporary upgrade link, it is listed below.

Report back soon (hopefully with success)!



All times are GMT -5. The time now is 04:19 AM.