-   SUSE / openSUSE (
-   -   OpenSuse 11.4 VNC Howto (

whschimmel 02-03-2013 05:04 AM

OpenSuse 11.4 VNC Howto
Hi There,

I am getting crazy of getting my RealVNC server to work. I have an license from work and installed x11vnc and VNC-E (which is realvnc enterprise).

First off all if I run the RealVNC Server (user-mode) from the application launcher it works, but first I need to kill x11vnc to get port 5900 free.
I want the RealVNC server to start automaticly on the start of my X session.

I created an Autostartscript in /home/<username>/.kde4/Autostart called x11vnc it contains the following data:

#! /bin/sh
x11vnc -rfbauth ~/.vnc/passwd -bg -rfbport 5900 -gui tray=minimal,iconfont=14x17 -forever -noxdamage &

this is why I need to kill x11vnc when running RealVNC server manually.

Problem is that I now have an x11vnc tray icon in stead of a realvnc tray icon.
Secondly It does not ask for any password, to get an password I did the following (in a terminal)


x11vnc -usepasswd

x11vnc -usepw -display :0
next I restarted my opensuse box, but still no password... :eek:

If anyone knows where I did wrong, it would be a great help.

whschimmel 02-03-2013 05:18 AM

I just saw that the x11vnc icon had properties where I could enter a password and a view only password. I did this and rebooted my opensuse box, now I get an tray Icon error and still no password:


tail: cannot watch `/tmp/x11vnc.tray.qJoDsk': No such file or directory
tail: cannot watch `/tmp/x11vnc.tray.qJoDsk': No such file or directory
    while executing
"close $channel"
    (procedure "read_client_info" line 25)
    invoked from within
"read_client_info $client_tail"
    (procedure "read_client_tail" line 5)
    invoked from within

Crazy :Pengy:

whschimmel 02-03-2013 05:25 AM

by the way I see that the command for the realvnc server is:


I think this should become x11vnc? or am I seeing this wrong?

whschimmel 02-04-2013 08:30 AM

I have found the solution

I made a new Autostart file with the content:

#! /bin/sh

Now my VNC server is starting.... :-)

John VV 02-04-2013 10:59 AM

OpenSuse 11.4
just be careful 11.4 is past it's end of life
it went EOL on "November 5th 2012"

there will never be( and have not been) any security fixes

All times are GMT -5. The time now is 10:27 AM.