-   SUSE / openSUSE (
-   -   openSuSE 11.1 32 or 64 bit, how to properly tell? (

plisken 07-28-2009 02:05 PM

openSuSE 11.1 32 or 64 bit, how to properly tell?
As per subject, I'm running openSuSE 11.1 and as far as I was aware installed the 64 bit verion, I'm running it on an HP Compaq Centrino due number.

I've been trying to recompile my kernel, change some features and run into some boot problems, which have been attributed to "trying to load a 32bit kernel onto a 64 bit OS". For the time being, I dont have the exact messages showen, but was told that they basically meant this, anyway...

I'm trying to find out if I do indeed have a 64 bit version running, so far:

unmae -a = Linux nemesis #1 SMP 2009-07-01 15:37:09 +0200 i686 i686 i386 GNU/Linux

Any and all help is as always appreciated...

Thanks in advance.

GrapefruiTgirl 07-28-2009 03:15 PM

In my semi-limited experience, yours looks like a 32bit kernel, therefore it would be running on a 32bit SuSE. I'm not sure EVERY kernel that is 64bit shows in `uname -a` the 'x86_64' piece, but I believe they do (I'm open for correction on this).

As an example:

sh-3.1# uname -a
Linux reactor 2.6.30-2630G #5 SMP PREEMPT Wed Jul 15 20:19:51 ADT 2009 x86_64
Genuine Intel(R) CPU            2160  @ 1.80GHz GenuineIntel GNU/Linux

(I broke the line for sane-ness) but note the bold text. My 32bit kernels output of the uname -a command looked much like yours.

Hope this helps -- though again, I'm open for correction on this.


EDIT - posting for us the EXACT errors will help :)

plisken 07-29-2009 03:18 AM

The errors are basically, it fails to find modules in /lib/modules

ronlau9 07-29-2009 04:26 AM


Originally Posted by plisken (Post 3623918)
The errors are basically, it fails to find modules in /lib/modules

The result of youŕe uname - a is that youŕe running 32 bits version of opensuse.
A other indication is that if you are running 64 bits version you mostly
have lib and lib64
In lib you will find a lot .
So we really needs to know what is missing ?

colucix 07-29-2009 04:39 AM

To find out if the OS is 32 (i586) or 64-bit (x86_64) try lsb_release -a. Mine is 32-bit:

$ lsb_release -a
LSB Version:    core-2.0-noarch:core-3.2-noarch:core-2.0-ia32:core-3.2-ia32:desktop-3.2-ia32:desktop-3.2-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.2-ia32:graphics-3.2-noarch
Distributor ID: SUSE LINUX
Description:    openSUSE 11.1 (i586)
Release:        11.1
Codename:      n/a

or simply:

$ cat /etc/SuSE-release
openSUSE 11.1 (i586)
VERSION = 11.1

plisken 07-29-2009 05:50 AM

This is starting to confuse me even more now, think I'll take a step back and explain things more or less as they happened.

I had a working SuSE install running, which I bgelieved to be a 64 bit version, the results of the uname -a are shown above, this unfortunately is no longer runnable, since on my last kernel install attempt, it got over written, I do hawever still have a working xen kernel which I can still boot into, however when I run the uname -a command from there, I am shown as being 64 bit. /etc/SuSE-release shows openSuSE 11.1 (x86_64), I also have /lib and a /lib64 folders.

So I guess we can assume that I have a 64 bit release installed, so my question should possibly now be, how can I compile a kernel and install it so that it boots properly?

I normally do the following (albeit on slackware)

download the kernel from and place it along side the others in /usr/src
I enter the folder in this case: /usr/src/linux-
I run make menuconfig, use the .config file located in /boot and modify to suit, then

make clean
make bzImage
make modules
make modules_install
make install

Now the make install, I have never really used before, I normally copied my kernel from /usr/src/linuxkernel/arch/i386orx86/boot/newkernel to /boot/newkernel and then modify grub or lilo but i now understand that make install does this for me.

This is basically where I got to and when trying to boot the new kernel, it would not read the modules and would hang, I was advised that this was down to loading a 32bit kernel on a 64bit OS

All help is appreciated, I don't really want to do a clean install with this but would rather successfully make a new kernel with the options i need from the current working xen one. I was only recompiling to add in RTC and something else which for now escapes me, but it was so I could run vmware.

All times are GMT -5. The time now is 10:51 AM.