LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 10-05-2007, 11:26 AM   #1
danreed007
LQ Newbie
 
Registered: Aug 2004
Posts: 21

Rep: Reputation: 15
openSUSE 10.3, NTFS write permission


Hi all

Ive just installed opensuse 10.3 all excited that it is supposed to give automatic read/write access to NTFS partitions via NTFS-3g which is now built into suse. However, it seems that only root has write access to ntfs partitions. As a simple user I can only read the partitions and write access is denied. I enclose my '/etc/fstab' entry (generated by the installation; I have not changed it) and 'ls-l' of the windows mount points to see if you guys/girls can help:

/etc/fstab:
/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVS-_WD-WXE107257702-part2 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale
=en_GB.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVS-_WD-WXE107257702-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale
=en_GB.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVS-_WD-WXE107257702-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale
=en_GB.UTF-8 0 0

ls -l /windows:
drwxr-xr-x 5 root root 120 2007-10-05 12:37 windows

ls -l /windows/E:
drwxr-xr-x 1 root users 4096 2007-09-20 17:14 Documents
drwxr-xr-x 1 root users 0 2007-09-23 12:47 Downloads
drwxr-xr-x 1 root users 4096 2007-10-05 16:58 Images
drwxr-xr-x 1 root users 0 2007-09-19 16:51 Misc
drwxr-xr-x 1 root users 4096 2007-09-19 15:13 Movies
drwxr-xr-x 1 root users 4096 2007-09-24 19:35 Music
drwxr-xr-x 1 root users 0 2007-09-14 21:13 $RECYCLE.BIN
drwxr-xr-x 1 root users 0 2007-09-14 23:01 System Volume Information

Thanks for any help
 
Old 10-05-2007, 02:02 PM   #2
igu
Member
 
Registered: Jan 2003
Distribution: Fedora, Gentoo, SUSE, Mandriva
Posts: 127

Rep: Reputation: 15
Remove the fmask=133,dmask=022 options then it should work for users too.
 
Old 10-06-2007, 09:29 AM   #3
danreed007
LQ Newbie
 
Registered: Aug 2004
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by igu View Post
Remove the fmask=133,dmask=022 options then it should work for users too.
Can you tell me exactly what those parameters mean? Thanks
 
Old 10-06-2007, 11:57 AM   #4
danreed007
LQ Newbie
 
Registered: Aug 2004
Posts: 21

Original Poster
Rep: Reputation: 15
I downloaded and installed ntfs-config and used it as root to change the write permissions...all is well now.
 
Old 01-12-2008, 03:39 PM   #5
Watever
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
I had the same problem on Suse 10.3, after installing ntfs-config in Yast and running it. I was still not working. After unchecking and rechecking my drives everything worked fine.

Hope this helps someone. Try uncheck and check again.
 
Old 01-18-2008, 09:12 PM   #6
bottled leaf
Member
 
Registered: Feb 2004
Distribution: opensuse 11.3 x64
Posts: 98

Rep: Reputation: 15
all you really had to do was change users,gid=users,fmask=133,dmask=022,locale
=en_GB.UTF-8 0 0 to defaults 0 0. i just did it and it worked. but you have to be in root to change the fstab
 
Old 01-20-2008, 05:30 PM   #7
lin_myworld
Member
 
Registered: Oct 2007
Location: India
Distribution: Ubuntu 8.04
Posts: 93

Rep: Reputation: 15
fmask=133,dmask=022


what does that parameter mean.
 
Old 01-20-2008, 06:02 PM   #8
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Quote:
Originally Posted by lin_myworld View Post
fmask=133,dmask=022


what does that parameter mean.
fmask is a umask just for files. The 'x' bit is cleared for owner. The 'wx' bits are cleared for group and others. The dmask given clears the write permission bit for group and others. The 'x' bit is different for directories. It allows you to enter a directory.

If you are the only user of this machine you could use 'uid=<yourusername>',fmask=177,dmask=077' to give you full exclusive access.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How To Enable NTFS Write Support (ntfs-3g) On Ubuntu Feisty Fawn LXer Syndicated Linux News 0 09-11-2007 08:20 PM
LXer: How To Enable NTFS Write Support (ntfs-3g) On Mandriva 2007 Spring LXer Syndicated Linux News 0 09-05-2007 05:30 PM
Ntfs Write Permission hariiyer Linux - Software 1 12-17-2005 12:44 AM
no write permission on NTFS mount zchoyt Linux - General 1 08-25-2005 09:10 PM
ntfs write and permission mathfeel Linux - Hardware 7 02-23-2005 09:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration