LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 05-31-2008, 09:40 AM   #1
v1pEr
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: winxp + suse 10.1 dual boot
Posts: 88

Rep: Reputation: 15
Opensuse 10.3 is too slow


I'm noticing my 10.3 install is really slow lately, and it is annoying me more and more, so I am trying to find out what is the cause. My notebook is fairly good (Core 2 Duo T7250@2GHz, 2GB Ram, Nvidia NVS 140M) so I don't think that is the problem.

What do I mean with slow?
- Flash videos get the CPUs to 50 - 90% each and the playback is not smooth.
- This is almost the same for normal videos in fullscreen.
- Refreshing a page in firefox gets one of the cores to 100%
- Scrolling in firefox is not smooth at all
- Switching desktops with compiz (you know, the rotating cubes) is also not smooth at all
- Can't play lBreakout with a decent fps
- maximising and resizing a window takes 4 seconds
- playing webcam takes about 80% for both CPUs

These are just some examples to show what I mean. Somehow I have the feeling that my nvidia drivers are not installed (correctly) but I do see the nvidia logo on login.

Now the thing is that I want to give more info but I don't know where to start, I really have no idea what the cause/bottleneck is so somebody has to point me to the right directions.

top while playing a flash video in firefox:

Tasks: 151 total, 5 running, 146 sleeping, 0 stopped, 0 zombie
Cpu(s): 55.3%us, 6.5%sy, 0.0%ni, 36.5%id, 0.8%wa, 0.2%hi, 0.7%si, 0.0%st
Mem: 2074504k total, 1962956k used, 111548k free, 677724k buffers
Swap: 2104472k total, 12k used, 2104460k free, 863268k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
26145 root 20 0 913m 62m 10m R 83 3.1 8:42.12 X
3318 v1per 20 0 212m 83m 25m R 21 4.1 4:24.08 firefox-bin
26299 v1per 20 0 28456 21m 8824 R 16 1.1 3:13.13 compiz
26304 v1per 20 0 98.9m 26m 12m S 2 1.3 0:40.59 python
8301 v1per 20 0 146m 53m 27m S 0 2.6 0:35.31 amarokapp
20510 v1per 20 0 2324 1036 764 R 0 0.0 0:00.06 top
26328 v1per 20 0 41360 17m 11m R 0 0.9 0:02.20 gnome-terminal
28213 v1per 20 0 31464 24m 4828 S 0 1.2 0:18.14 wish
28270 v1per 20 0 70112 29m 12m S 0 1.5 0:08.38 skype
1 root 20 0 740 292 240 S 0 0.0 0:01.33 init

loadavg looks normal I think:
17:32 elise:~ > cat /proc/loadavg
1.79 1.16 0.95 1/264 24633

A lot in cache:
17:34 elise:~ > cat /proc/meminfo
MemTotal: 2074504 kB
MemFree: 105084 kB
Buffers: 678320 kB
Cached: 869464 kB

my kernel
17:35 elise:~ > uname -r
2.6.23.16-ccj64-regular

One problem I am able to pinpoint though is that xgl is not enabled for compiz, if I enable it I only get a totally white cube/desktop.

Any help on this is really appreciated.

Last edited by v1pEr; 05-31-2008 at 09:47 AM.
 
Old 05-31-2008, 10:03 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
open suse 10.3 is to slow

It is strange that when log in you saw the NVidia screen it did not apply to me When scrolling in firefox is not smooth I think it means that the Nvidia driver is not correct Not smooth can be a indication that the driver
is not correct
Even tough you already check try to find out if you really have the correct driver

all the best
 
Old 05-31-2008, 10:04 AM   #3
ophirg
Member
 
Registered: Jan 2008
Location: Israel
Distribution: Kubuntu 13.10
Posts: 134

Rep: Reputation: 34
Have you tried to disable compiz? Turning off 3d acceleration and switching to nv driver?
That way you can find out if the slowdown has anything to do with the video driver.

Also, try disabling all indexing programs.
Beagle is probably on default. try running "beagle-shutdown" from konsole.
Quit the openSUSE updater.

Find out what makes the difference.

Look at /proc/vmstat to find out if there is a large number of page faults.

and btw, it doesn't matter if the cache almost fills the memory.
 
Old 05-31-2008, 10:13 AM   #4
v1pEr
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: winxp + suse 10.1 dual boot
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ophirg View Post
Have you tried to disable compiz? Turning off 3d acceleration and switching to nv driver?
That way you can find out if the slowdown has anything to do with the video driver.

Also, try disabling all indexing programs.
Beagle is probably on default. try running "beagle-shutdown" from konsole.
Quit the openSUSE updater.

Find out what makes the difference.

Look at /proc/vmstat to find out if there is a large number of page faults.

and btw, it doesn't matter if the cache almost fills the memory.
If I disable compiz (by uninstalling it) I don't have any window borders anymore, so that's not so great (I really have the feeling that something is wrong with my compiz installation )

beagle and opensuse updater are not running

Code:
18:09 elise:/home/v1per # cat /proc/vmstat
nr_free_pages 6719
nr_inactive 325176
nr_active 170314
nr_anon_pages 90131
nr_mapped 29523
nr_file_pages 405378
nr_dirty 125
nr_writeback 0
nr_slab_reclaimable 5094
nr_slab_unreclaimable 3964
nr_page_table_pages 816
nr_unstable 0
nr_bounce 0
nr_vmscan_write 26
pgpgin 4227438
pgpgout 2324080
pswpin 0
pswpout 3
pgalloc_dma 45465
pgalloc_normal 6150209
pgalloc_high 13107639
pgalloc_movable 0
pgfree 19310489
pgactivate 695734
pgdeactivate 328419
pgfault 59622960
pgmajfault 1612
pgrefill_dma 8650
pgrefill_normal 309025
pgrefill_high 165579
pgrefill_movable 0
pgsteal_dma 12222
pgsteal_normal 457092
pgsteal_high 141971
pgsteal_movable 0
pgscan_kswapd_dma 12231
pgscan_kswapd_normal 466857
pgscan_kswapd_high 152731
pgscan_kswapd_movable 0
pgscan_direct_dma 0
pgscan_direct_normal 384
pgscan_direct_high 384
pgscan_direct_movable 0
pginodesteal 0
slabs_scanned 180608
kswapd_steal 610517
kswapd_inodesteal 151823
pageoutrun 7821
allocstall 6
pgrotated 20
I post it here because this is too advanced for me ;-)

Quote:
Originally Posted by ophirg View Post
and btw, it doesn't matter if the cache almost fills the memory.
I know but I just wanted to point out what was happening as the memory usage was quite high in top

Quote:
Originally Posted by ronlau9 View Post
try to find out if you really have the correct driver
I installed the driver with the 1 click install of opensuse and it gave me no errors so I suppose everything should be ok?


thank you for the fast reply btw

Last edited by v1pEr; 05-31-2008 at 10:24 AM.
 
Old 05-31-2008, 10:55 AM   #5
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
opensuse 10.3 is to slow

In yast2> hardware> monitor and graphic card you can check the installed
NIVIdia driver .
Is the correct driver installed ?

all the best
 
Old 05-31-2008, 11:06 AM   #6
v1pEr
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: winxp + suse 10.1 dual boot
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ronlau9 View Post
In yast2> hardware> monitor and graphic card you can check the installed
NIVIdia driver .
Is the correct driver installed ?
The card is recognized correctly but I can see no sign of which driver is installed. Also the screen resolution is recognized wrong.

http://yet-another.net/pictures/Scre...figuration.png

Edit: Is it possible that my xorg configuration is incorrect?

Code:
19:10 elise:~ > cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Feb 14 18:20:37 PST 2008

# generic XFree86 4.x configuration file
# Screen Section for module X support
# -------------------------------------
# Screen Section for fbdev support
# vesafb defaults to 16bit
# others default to 8bit, force a higher colordepth
# on Apple onboard controllers, remove the default #207338
# changes for DefaultDepth have to be made in /usr/lib/YaST2/startup/YaST2.call as well
# ----------------------------------
# Screen Section for vesa support
# ----------------------------------
# Screen Section for vmware support
# ----------------------------------
# Device Sections...
# -------------------

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[fbdev]" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Synaptics Touchpad"
    Option         "Xinerama" "off"
EndSection

Section "Files"
    ModulePath      "/usr/lib/xorg/modules"
    InputDevices      "/dev/ttyS0"
    InputDevices      "/dev/ttyS1"
    InputDevices      "/dev/ttyS2"
    InputDevices      "/dev/ttyS3"
    InputDevices      "/dev/ttyS4"
    InputDevices      "/dev/ttyS5"
    InputDevices      "/dev/ttyS6"
    InputDevices      "/dev/ttyS7"
    InputDevices      "/dev/ttyS8"
    InputDevices      "/dev/psaux"
    InputDevices      "Synaptics Touchpad"
    FontPath        "/usr/share/fonts/truetype/"
    FontPath        "/usr/share/fonts/uni/"
    FontPath        "/usr/share/fonts/misc/"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail"
    Option         "BlankTime" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbRules" "xfree86"
    Option         "XkbKeycodes" "xfree86"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "Name" "Synaptics Touchpad"
    Option         "Device" "/dev/input/mouse1"
    Option         "Protocol" "auto-dev"
    Option         "SendCoreEvents" "true"
    Option         "SHMConfig" "on"
    Option         "LeftEdge" "130"
    Option         "RightEdge" "840"
    Option         "TopEdge" "130"
    Option         "BottomEdge" "640"
    Option         "FingerLow" "7"
    Option         "FingerHigh" "8"
    Option         "MaxTapTime" "180"
    Option         "MinTapTime" "110"
    Option         "ClickTime" "0"
    Option         "EmulateMidButtonTime" "75"
    Option         "VertScrollDelta" "140"
    Option         "HorizScrollDelta" "20"
    Option         "MinSpeed" "0.40"
    Option         "MaxSpeed" "0.95"
    Option         "AccelFactor" "0.030"
    Option         "EdgeMotionMinSpeed" "200"
    Option         "EdgeMotionMaxSpeed" "200"
    Option         "UpDownScrolling" "1"
    Option         "CircularScrolling" "1"
    Option         "CircScrollDelta" "1"
    Option         "CircScrollTrigger" "3"
    Option         "VertEdgeScroll" "on"
EndSection

Section "Modes"
    Identifier         "Modes[0]"
    ModeLine     "800x600" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    ModeLine     "640x480" 31.5 640 656 720 840 480 481 484 500 # 6. Try
    ModeLine     "640x480" 31.5 640 680 720 864 480 488 491 521 # 5. Try
    ModeLine     "640x480" 28.0 640 664 760 800 480 491 493 525 # 4. Try
    ModeLine     "640x480" 28.3 640 664 760 800 480 491 493 525 # 3. Try
    ModeLine     "640x480" 25.2 640 664 760 800 480 491 493 525 # 2. Try
    ModeLine     "640x480" 25.2 640 664 760 800 480 491 493 525 # 1. Try
EndSection

Section "Modes"
    Identifier         "Modes[vmware]"
    ModeLine     "800x600" 29.4 800 816 896 992 600 601 604 617
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "Initial"
    ModelName      "Initial"
    UseModes       "Modes[0]"
    HorizSync       25.0 - 40.0
    VertRefresh     47.0 - 75.0
EndSection

Section "Monitor"
    Identifier     "Monitor[vmware]"
    VendorName     "Initial"
    ModelName      "Initial"
    UseModes       "Modes[vmware]"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
EndSection

Section "Monitor"
    Identifier     "Monitor[vesa]"
    VendorName     "VESA"
    ModelName      "VESA"
    HorizSync       31.0 - 48.0
    VertRefresh     50.0 - 60.0
EndSection

Section "Device"

  #BusID        "1:0:0"
  # device_options
    Identifier     "Device[0]"
    Driver         "ChangeMe"
    Option         "sw_cursor" "on"
EndSection

Section "Device"

  # fbdev_options
    Identifier     "Device[fbdev]"
    Driver         "nvidia"
EndSection

Section "Device"

  #Option        "DefaultRefresh"
    Identifier     "Device[vesa]"
    Driver         "vesa"
    Option         "ModeSetClearScreen" "no"
EndSection

Section "Device"
    Identifier     "Device[vmware]"
    Driver         "vmware"
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    16
    SubSection     "Display"
        Depth       16
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "800x600"
    EndSubSection
EndSection

Section "Screen"

#@DefaultDepth@
    Identifier     "Screen[fbdev]"
    Device         "Device[fbdev]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "default"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen[vesa]"
    Device         "Device[vesa]"
    Monitor        "Monitor[vesa]"
    SubSection     "Display"
        Depth       16
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "default"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen[vmware]"
    Device         "Device[vmware]"
    Monitor        "Monitor[vmware]"
    SubSection     "Display"
        Depth       8
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "800x600"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
I see an awful lot of screens here :-)

Edit 2: xorg.conf file looks good to me after all (maybe too much screens, but the screen being used (fbdev) has the nvidia driver)

Last edited by v1pEr; 05-31-2008 at 11:19 AM.
 
Old 05-31-2008, 01:36 PM   #7
ophirg
Member
 
Registered: Jan 2008
Location: Israel
Distribution: Kubuntu 13.10
Posts: 134

Rep: Reputation: 34
Hi
Sorry for the late response, I was busy.

The /proc/vmstat is fine. you don't have many page faults

Try running "nvidia-xconfig" in konsole. It will try to configure your xorg.conf automatically. If you don't like the new settings, restore the old ones from xorg.conf.backup
You should have this tool installed. Have a look at "man nvidia-xconfig" to understand what it does.

I really don't understand why there are so many drivers and screens...
I have only one - nvidia. no vesa or vmware. but I don't know what software are you running so you might need them. keep the xorg.conf.backup file.

hope that helps
 
Old 05-31-2008, 02:02 PM   #8
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
opensuse 10.3 is too slow

I compare my x.org with you,rs the device section in particular
Mine stated correctly the Nvidia cart I use the bus ide that the driver is
a Nvidia driver and that the vendor is NVidia
also my monitor is there with full spec
I can not find the same in you,rs but maybe I overlook it

all the best
 
Old 05-31-2008, 03:29 PM   #9
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 4,070

Rep: Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897
If you have just started up when you took the top figures, there is something suspicious about that memory usage. I know everyone always gets concerned unnecessarily about this, but in this case 2G is getting (almost) used up, and only (!) 677k is going as buffers. So something is using about 1.25 G and I think one instance of Firefox should be closer to a tenth of that.

Having said that, if it isn't causing swapping there's no reason to believe that this is slowing you down. So, it may well be an issue, but I'm far from sure that its the issue.

Which GUI is this? (Do you have more than one GUI installed? Try the other one!) You might find it easier to understand what is going on if you look at ksysguard rather than top (although top has the advantage that its output is more 'postable').
 
Old 06-01-2008, 07:55 AM   #10
v1pEr
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: winxp + suse 10.1 dual boot
Posts: 88

Original Poster
Rep: Reputation: 15
@ophirg: I ran nvidia-xconfig but no difference
@salasi: ok ran ksysguard, although I don't see any difference with any other tools, but I only took a very quick look at it

just started playing the movie, a load of 1.5 for just playing a firefox movie, that shouldn't be like that, right?

X taking 64%???

@salasi: no I had done some work already (couple of virtual machines, some large files encrypted)

Edit: I really suspect my driver now, but how do I check this?

Edit 2: This is my xorg log but I don't see any errors?
Code:
16:52 elise:/home/v1per # grep -i nvidia /var/log/Xorg.0.log
(--) PCI:*(1:0:0) nVidia Corporation Quadro NVS 140M rev 161, Mem @ 0xfd000000/24, 0xe0000000/28, 0xfa000000/25, I/O @ 0xdf00/7
(II) Module glx: vendor="NVIDIA Corporation"
(II) NVIDIA GLX Module  169.12  Thu Feb 14 18:45:56 PST 2008
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules//drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
(II) NVIDIA dlloader X Driver  169.12  Thu Feb 14 17:55:38 PST 2008
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(--) Chipset NVIDIA GPU found
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RenderAccel" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU Quadro NVS 140M (G86GL) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 60.86.47.00.01
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on Quadro NVS 140M at PCI:1:0:0:
(--) NVIDIA(0):     Seiko (DFP-0)
(--) NVIDIA(0): Seiko (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): Seiko (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "default"; removing.
(WW) NVIDIA(0): 
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
(--) NVIDIA(0): DPI set to (129, 126); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled

Last edited by v1pEr; 06-01-2008 at 09:14 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSuse 10.2 RPM installation SLow R03L SUSE / openSUSE 3 04-11-2008 03:39 AM
Very slow disk access with OpenSuSE 10.3 dimitriw1972 Linux - Hardware 1 12-02-2007 07:24 AM
dg965ry dg965ryck opensuse very slow after installation pingus37 Linux - Newbie 3 07-10-2007 08:31 AM
OpenSuse 10.2 and extremely slow torrent speeds jagatic Linux - Software 1 05-07-2007 09:21 AM
WiFi slow on openSuSE 10.1, but normal speed on XP Inchcape Linux - Wireless Networking 1 02-11-2007 02:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 11:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration