-   SUSE / openSUSE (
-   -   openSUSE 10.1 Xorg 6.9 consuming CPU and crashing (

jturning 12-21-2006 01:23 AM

openSUSE 10.1 Xorg 6.9 consuming CPU and crashing
I'm running openSUSE 10.1 with 6.9 and latest ATI driver and latest KDE packages. The problem is when you lock the computer while logged into KDE and the screen saver and locking module load Xorg slowly starts consuming more and more CPU until it reaches maximum and locks Xwindows. Other than locking the computer, everything is fine. Any ideas?


billkendrick 02-15-2007 12:08 PM

Same issue on Kubuntu 6.10
I tried playing with Xgl and Beryl to get fun composited and wiggly windows, but then switched back to Xorg. Not sure if I didn't switch things back properly, but these days, when I unlock my X session, my mouse moves, but I cannot click anything or type into any windows (or use shortcut keys), and the XOrg progess is taking nearly 100% of my CPU.

Reading someones similar problem elsewhere, I disabled the "AllowGLXWithComposite" option for my "nvidia" driver device, and set the "Composite" extension to "Disable", but to no avail.

I've got a PCI-based NVidia GeForce FX5200 with, as I mentioned, the non-Open-Source "nvidia" driver, on an AMD Sempron 2200.

My CPU usage is fairly typical at all other times. It's just when the KDE session has been locked for a while (e.g., via the K menu's "Lock Session" option) that Xorg climbs really high and my KDE desktop becomes unusable.

(I need to Ctrl+Alt+F1 and do a "sudo /etc/init.d/kdm stop", which sometimes doesn't work, in which case I do an Alt+SysRQ+K magic sysrequest key combo or start "kill -9"ing things. Ouch!)


jturning 02-16-2007 12:36 AM

Are you running the 64bit version of Kubuntu?

I never could iron down a solution. I did see reference that there was a known bug in the 64 bit version of the ATI driver, and have been waiting for an update from ATI. Your Nvidia experience kind of points it back at Xorg. And I also saw some reference where the KDE folks say it's an Xorg bug as even if the KDE code is bad, Xorg shouldn't allow it to hose the system. Anyway, I did notice that with XGL/compiz the bug went away. But I've taken to running Gnome which doesn't suffer from the bug. Beryl was never very stable for me. There have been a lot of updates to Xorg and KDE, but I haven't gone back to test KDE. I'll need to try it this weekend.

As a note, I experienced the same problem with openSUSE 10.1 and Xorg 6.9 as well as openSUSE 10.2 and Xorg 7.2. It seemed to have started when KDE went to 3.5.5. And I'd guess something to do with the window manager of KDE and it's interaction with Xorg.

I have come to really appreciate running Gnome though. The only bug I had experienced with Gnome is that after a few days Nautilus would spike hogging one of my CPUs, which was a known bug. I'd just kill it and it would come back like explorer in Windows. But since the last updates I haven't seen the bug, so perhaps they fixed it. I think I should have installed the 32 bit version of the OS, :).

billkendrick 02-16-2007 03:10 PM


Originally Posted by jturning
Are you running the 64bit version of Kubuntu?

No, like I said, it's an AMD Sempron, and I'm just running the 32bit Kubuntu. (In fact, currently a '386' flavor of the Linux kernel... not even 686)


jturning 02-25-2007 03:30 PM

I tried a totally updated KDE and Xorg, and the bug was still there. For me, ATI just came out with a new driver, but it doesn't support Xorg 7.2. Still using Gnome, but I think I'll play with the new XFCE and IceWM.

All times are GMT -5. The time now is 06:16 AM.