LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 03-01-2008, 11:39 AM   #1
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Rep: Reputation: 205Reputation: 205Reputation: 205
OpenOffice.org fonts bad in SuSE, excellent in Slackware: Why?


Hi there,

I am currently setting up a new system with OpenSuSE 10.3 64-bit. Almost everything works the way I want it, but what is still totally unacceptable is the quality of font rendering in OpenOffice.org 2.3.1 (mainly: Writer).

EDIT: I have prepared some screenshots illustrating my problem.
http://www.iverbi.de/UNLINKED/images.html

http://www.iverbi.de/UNLINKED/DejaVu...enSvsSlack.png shows OpenOffice.org 2.3.1 Writer rendering some text with the font DejaVu Serif in OpenSuSE 10.3 (top) and Slackware 12.0 (bottom).
http://www.iverbi.de/UNLINKED/FontRe...S_KDEvsOOo.png shows that the rendering of fonts within KDE is quite nice, meanwhile, in my new OpenSuSE box. For some reason, however, the rendering is still poor in OpenOffice.org.
http://www.iverbi.de/UNLINKED/OpenS_KDESetting_AA_1.png and http://www.iverbi.de/UNLINKED/OpenS_KDESettingAA_2.png show my KDE settings for anti-aliasing and sub-pixel hinting.
http://www.iverbi.de/UNLINKED/OpenS_OOoSettingAA.png shows my OOo settings for anti-aliasing.

Despite spending the whole last night searching the web on this problem I was only able to solve it partially. As I am using OOo on MS Windows XP and Slackware 12.0, where I get excellent font rendering out of the box on CRT and LCD monitors, I would guess that my problem is OpenSuSE specific, which is why I post here.

I managed to improve the font rendering in KDE in general, so that text in applications and web sites is rendered with acceptable, (but honestly: not good) quality by recompiling freetype2 with support for subpixel hinting.

Here is what I have done so far.
After installing the Microsoft Truetype fonts, I followed this How-to: http://opensuse-community.org/SubpixelHinting.

Then I experimented a bit with the settings for subpixel hinting in
Code:
/etc/sysconfig/fonts-config
and in the KDE control center. The best settings for my 17" LCD monitor (Samsung Samtron 74V) I found so far, are:

Code:
Anti-aliasing "active"
Sub-pixel hinting "medium"
no font size excluded
Anti-aliasing in OOo is active for all font sizes. And my NVIDIA graphics driver is configured to use application specific settings for anti-aliasing.

The result is acceptable or good for most applications, but the way fonts appear in OOo really hurts my eye.

EDIT: What puzzles me is the fact, that Slackware 12.0 provides perfect font rendering without all of this, ie with subpixel hinting switched off, etc. OpenSuSE needs all of this, and still the quality is not up to what I am used to, after years with Slackware as my main system. But OpenSuSE is otherwise an excellent distribution, so I refuse to believe that there is no solution...

I'd be grateful for any hints, what else I could check or modify in order to get a font display that allows me to work with OOo many hours a day.

Thanks in advance!

gargamel

Last edited by gargamel; 03-01-2008 at 04:51 PM.
 
Old 03-01-2008, 01:57 PM   #2
Caballero del norte
Member
 
Registered: Apr 2007
Location: Sonoran Desert, USA
Distribution: Ubuntu 8.04
Posts: 30

Rep: Reputation: 16
OO.org fonts

Get into OO.o Writer and go to the menu: Tools > Options. Open the first option that comes up in the frame on the left (OpenOffice.org), and select View.

You should see, about halfway down in the big frame, the words Screen Font Antialiasing with a fill-in box for pixels and a checkbox.

Tick the checkbox and fill in a small number in the fill-in box. I have used 8, but I find 4 is even better. Then punch the OK button. That ought to do it.

This has worked for me in the past and is distro-independent.

It could be that your distro's version of OO.o defaults to a high antialiasing argument... I seem to recall this as a serious issue with 2.1 or 2.2.

Good luck!

Last edited by Caballero del norte; 03-01-2008 at 01:58 PM.
 
Old 03-01-2008, 04:26 PM   #3
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Original Poster
Rep: Reputation: 205Reputation: 205Reputation: 205
Thanks, but I've done all of this, unfortunately it didn't have the expected effect. I have prepared some screenshots illustrating the problem:

http://www.iverbi.de/UNLINKED/images.html

I'd be grateful for other ideas, what I might look for!

Thanks, best regards

gargamel
 
Old 03-03-2008, 04:17 PM   #4
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Original Poster
Rep: Reputation: 205Reputation: 205Reputation: 205
As it turns out, this is a problem of the Novell version of OpenOffice.org 2.3.1 under KDE on OpenSuSE 10.3. The fonts look better in a GTK+ environment, such as FVWM2, and I've been told, that they look really good under Gnome (which I haven't installed here).

With the 32-bit original version from http://de.openoffice.org or http://www.openoffice.org everything looks just fine even in KDE. Font rendering is perfect, with that version, absolutely clear and sharp. Only the menu entries aren't sorted as well as with the Novell derivative. Actually I'd prefer to use the Novell version, because of the automatic (security) updates, and because of the (hoped for) better desktop integration. But the latter seems to be only valid for Gnome.

For me it's easier to keep the original version up-to-date than switch to Gnome... But I am somewhat disappointed about the lazy KDE integration done by Novell. The "old" SuSE used to do be much more careful with such "details"...

gargamel
 
Old 04-02-2008, 03:00 AM   #5
RugbyPete
LQ Newbie
 
Registered: Jan 2007
Posts: 6

Rep: Reputation: 0
I have been trying to sort the very same thing... well, not just in openoffice, but around the whole OS.

Firefox fonts are unbearable, they look blocky and clumsey, swear older suse were very sharp and mac like smoothness.


for examplemy fonts in the opera web bar are clashing and seems like everythings on BOLD

I'm on 10.3 as I cant stand vista and XP wont load on my laptop properly.
 
Old 04-26-2008, 02:04 PM   #6
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Original Poster
Rep: Reputation: 205Reputation: 205Reputation: 205
The problem appears to be gone with the latest OOo 2.4.0 packages from SuSE/Novell. At last I can use Java based functions (which I rarely do, but it's good to know that I could if I would...) on my 64-bit system.

Good job, Novell, this time!

gargamel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Extending OpenOffice.org: Turning OpenOffice.org into a document conversion tool LXer Syndicated Linux News 0 05-09-2007 12:46 PM
Default pagesize on OpenOffice.org on Slackware... Yalla-One Slackware 3 04-19-2006 06:13 PM
Openoffice.org 2 on slackware 10.2 + FRG shadowhunter Slackware 5 01-05-2006 08:24 PM
OpenOffice.org-1.1 on SuSE 8.2 ? Hannes Linux - Software 1 02-10-2004 05:26 PM
Openoffice.org 1.1 presentation -startup fonts thegreatgatsby Linux - Software 0 10-26-2003 05:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration