-   SUSE / openSUSE (
-   -   Older Grub will not boot newer Suse: error 15 File not found (

ronaldv 10-06-2008 04:43 AM

Older Grub will not boot newer Suse: error 15 File not found

I ran into this tricky problem that I thought I better share with you.

I have an Ubuntu (7.10) machine on which I wanted to install OpenSuse 11.0 in dual boot. I thought I could simply add Suse to my existing (Ubuntu) grub-menu. However after installing Suse (I skipped the grub install that suse proposed), adding suse to my grub-menu and booting, grub would fail when I tried to boot Suse. Errors were 'Error 2 : Bad file or directory type' or 'Error 15 : File not found'.

As it worked out Suse had formatted the root-partition with an inode size of 256 (the new default for the ext3 filesystem) but the (legacy) grub can not read this format. :-( See a good explaination of this problem here:

You could try to solve this by installing a newer grub or use the grub that suse 11 comes with but I choose to reinstall Suse and tell the partinioner to format with inode-size=128 (hidden in the expert options)

I really think that the Suse install manual should warn you for this but it does not.

Hope this helps one or two of you.

Cheers, Ronald

sadiqdm 10-07-2008 01:36 PM

I don't think this is an inode problem. I've found the most reliable way to boot multiple Linux installs (and Windows for that matter) is to have the second (3rd, 4th, etc) install their bootloader into their root partition, then set up the first Linux GRUB to boot the 2nd (3rd, 4th, etc) using a chainloader section. This is the top of my GRUB menu list, with Win 2K on the first hard drive, first partition, Suse on the second hard drive, first partition, and Ubuntu on the second hard drive 7th partition. The Suse GRUB was installed to the MBR on hdd 1, and the Ubuntu GRUB to the root of hdd 2 partition 7. Suse boots from it's own GRUB. For Ubuntu, you start with the Suse GRUB which then boots the Ubuntu GRUB.

# Modified by YaST2. Last modification on Sun Oct 5 17:09:34 BST 2008
default 0
timeout 8
gfxmenu (hd1,0)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0
root (hd1,0)
kernel /boot/vmlinuz- root=/dev/disk/by-id (..etc)
initrd /boot/initrd-

###Don't change this comment - YaST2 identifier: Original name: Ubuntu 8.04.1, kernel 2.6.24-19-generic (/dev/sdb7)###
title Ubuntu 8.04.1
rootnoverify (hd1,0)
chainloader (hd1,6)+1

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title Win 2K Pro
rootnoverify (hd1,0)
chainloader (hd0,0)+1
I've edited a couple of long lines so they fit on the page.

colorpurple21859 10-07-2008 07:52 PM

came across the same problem with slack 12.1 and did the same thing.

ronaldv 10-08-2008 04:53 AM


Originally Posted by colorpurple21859 (Post 3303527)
did the same thing.


Do you refer to the inode solution or to the chainloader solution?

All times are GMT -5. The time now is 06:24 PM.