-   SUSE / openSUSE (
-   -   nVidia driver causing small screen (

SchadeBoy 09-12-2005 11:41 AM

nVidia driver causing small screen
Hello, everyone. Nice to be back, for however long I'm here. I've been absent for a while because I haven't had the time to play around with Linux. Now that I have a bit of time on my hands, and I got the bug to play again, I put SUSE 10.0 RC1 on my machine (dual boot with Windows). I'm having a problem which ultimately took me off SUSE 9.3 Pro the last time I tried.

Basically, when I load the nVidia driver that I get from YOU, my screen goes nuts. In the upper left corner, I'll get a fully functioning screen that take about 3/4 of the actual screen size. The remaining 1/4 of the screen on the right is filled with a band of colors like a rainbow. The lower 1/8 of the screen is taken up by a reproduction of the top 1/8 of the screen.

In the functional area, I get a nice desktop with full 3D support. But the fact that the driver is not using the entire screen size is very annoying and somewhat worrisome - I'm afraid that long-term use of this type of setup will ultimately damage my laptop.

I have included a photo I took of the problem for a visual understanding of what's going on. This is not a screen capture, and I apologize for the lack of quality in the image. It was taken with a digital camera.

An image of my problem can be found here.

I know that this subject has been posted here before (and maybe even by myself) but I cannot find it. I admit that my time here at work limits my ability to search in depth, so I apologize that I am posting this again. Please be kind and don't berate me too much for the laziness.

I look forward to the help, and thanks in advance.

Please let me know if you are unable to get to the image links above.


Update: I have made changes to the link for the image. It should now direct you to a better hosting site than my ISP, and display an 800X600 version of the image. Again, please let me know if you have trouble with it.

Simon Bridge 09-13-2005 06:22 AM

"Please let me know if you are unable to get to the image links above."
That's me.

SchadeBoy 09-13-2005 08:37 AM

Not sure what's going on. They were working when I initially posted them. I'll have to check on them a bit later today. No time, now, unfortunately.

Update: Okay, I'm not sure how this happened, but somehow the images were deleted after I posted them. This is very disturbing. They should be back, and if you still have trouble with them, please let me know.

Simon Bridge 09-13-2005 08:45 PM

OK - I see it. It looks like the vertical and horizontal refresh may not be correct in Xorg.conf. - or that sort of thing. (I used to see this effect on old CRT TV sets, only it would move as well.) I think SuSE has a tool for configuring the monitor?

looking at the Official SuSE HOWTO...

Inside YOU enable "Installable and Installed Patches" for "Show Patch
Category" and select "Download NVIDIA(r) Graphics Driver" from the
patches list (usually at the bottom of the list). Note, that you need
to mark it as "Update" (right mouse click) if you already installed it
before and the driver was uninstalled - for any reason. Proceed as
usual now. After YOU has finished restart your Xserver (i.e. logout
from your Xsession) and you're fine.
I take it you didn't do anything different from this?

If not, then your best bet may be to do a source install from the same HOWTO.

"We will have genuine joy and happiness from 13:40 to 15:40 hours today, after which normal levels of happiness will be restored. Citizens who are not happy, please report to the DOA Sector Reactor Level. Thank you."
-- Your Freind The Computer (from "Paranoia" RPG)

SchadeBoy 09-13-2005 09:46 PM

That's correct, this is the result that I get when I use YOU to install and configure the nVidia driver. I didn't get this problem with SUSE 9.1 or 9.2. It started with 9.3 and now has affected 10.0. I do not know if the problem is the nVidia driver itself or something within SUSE or what.

I have considered doing the source install, and will probably do that tonight. As it stands, I'm not using 3D Acceleration, and my screen is full-size with none of the bars or colors I reported earlier. Productivity-wise, I'm fine. But I really want the extra enhancements that come from 3D Acceleration. Namely, the ability to play Tux Racer (of all things).

SchadeBoy 09-16-2005 01:23 PM

Solution Found
Just call me Happy Linux User Schadeboy.

I found a solution to my problem on nVidia's support forum site. If you're having similar problems that I have described here, check out this thread.

Now the problem is, how do I make the modprobe permanent? The solution provided in the thread above works only as long as my next reboot. After that, I have to go through the whole process again.

According to the thread, I hav to make the following a permanent thing:


Can anyone tell me how to do that?


Simon Bridge 09-16-2005 07:57 PM

You can add it to your bootscript.

There's another way but I've forotten.

All times are GMT -5. The time now is 03:28 AM.