LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 01-24-2008, 06:07 AM   #1
riccisit
Member
 
Registered: Jun 2004
Posts: 59

Rep: Reputation: 15
nvidia+compiz= black screen after suspend


Dear

I have a HP Pavillion DV6321eu with Opensuse 10.2

Everything works, included wlan and audio (after some posts and hours of studying.
I even managed to install the Nvidia card and Compiz (emerald).

But now I have a problem, really big. Imy pc must be on 8 hours continously (I'm working with it), but I need, like all human beings, some pause.

After a short pause, I would say 5 minutes) I'm back and the pc is completely black. Always I have to restart the pc manually. I tried to set up no suspension and no screensaver, but this worked just until I didn't have Nvidia drivers. Now I have them and I can't figure out how to do!

Is there a way to block this suspension? Or to fool the system with a script that the user is not away? Or maybe to have the suspension but after, let's say, 20 minutes.

Any idea?

Fabio
 
Old 01-28-2008, 04:07 PM   #2
mikemrh9
Member
 
Registered: Nov 2003
Distribution: Arch
Posts: 136

Rep: Reputation: 21
Hi.

I sometimes get problems with compiz after the screensaver has kicked in, and they can always be solved by forcing the screen to refresh. The way that I do this is to first make sure that the desktop cube is enabled, then when there is a redraw issue, just give it a quick <ctrl><alt><left> <ctrl><alt><right>. (I am suggesting this in case you have your screensaver set to a blank screen!)

If you haven't already tried and are using KDE, you could change your power settings through kpowersave (should be an icon for this on the right hand side of your panel). I don't know what the Gnome equivalent is, but there must be one in the menu somewhere!

If this doesn't work, maybe it would be worth googling to see if there are any known problems with your hardware and ACPI or APM under linux. If so, you could try passing the parameter ACPI=off to the kernel on boot.
 
Old 02-23-2008, 03:23 PM   #3
Stratocastr
LQ Newbie
 
Registered: Feb 2008
Location: West Haven , Connecticut , US
Distribution: FC8
Posts: 4

Rep: Reputation: 0
Yes , i have the same hardware , facing the same problem in FC8 + compiz..
help!
 
Old 02-23-2008, 03:33 PM   #4
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
Not sure what the long term fix would be, but keep checking through the compiz and nvidia settings to see if there are options for power save.

However, in stead of a hard reboot of the system, try restarting the X server using ctrl-alt-backspace. It should restart the X server and get you back to the log on screen. Down side to this is you may lose data in any application that is running at the time, i.e. an open text document.
 
Old 02-24-2008, 01:26 PM   #5
Stratocastr
LQ Newbie
 
Registered: Feb 2008
Location: West Haven , Connecticut , US
Distribution: FC8
Posts: 4

Rep: Reputation: 0
thx

yes! thank u..
ctl+alt+<- works fine..

now i dont have to hard boot everytime it blanks on me...
although i lose my work , but hey , atleast my HDD ain't gonna go bad from all that restarting...

thx again
 
Old 02-26-2008, 05:22 PM   #6
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
Try this command and see if it will help:
setterm -blank 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor powermanagment only sends black screen, doesn't suspend or powerdown. oryan_dunn Linux - Hardware 4 09-07-2006 08:09 AM
nvidia drivers 8178 cause black screen (10.0) duncky SUSE / openSUSE 35 03-24-2006 06:18 AM
Black screen after installing nVidia driver GardarS Linux - Newbie 1 06-23-2005 05:28 PM
HP nx9105 With Latest Nvidia = Black Screen c3nturion Linux - Laptop and Netbook 6 02-03-2005 02:06 PM
nVidia in Xorg=black screen FXRS Slackware 13 07-01-2004 01:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 03:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration