LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-30-2011, 07:10 AM   #1
husten
Member
 
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 56

Rep: Reputation: 16
NTFS usb drives do not mount not as user (suse specific)


SUSE state they do not allow to mount NTFS drives as user.
Other distros do (I have sabayon and mandriva on laptops).

how can I disable this behavior?
I do not want to use entries in fstab - they are hd specific.
And I found NTFS-config not too helpful I believe it messes with fstab as well.
perhaps policykit? - even that got renamed now and it almost rivals Windows registry with enigmatic names (what software is called "org.freedesktop" do, anyone?).
So yes I am useless with policykit and its derivatives, so where do Suse hide their root mount rule for ntfs?

(and is there still a difference between "ntfs 3g" and "ntfs"?

Thanks
husten
 
Old 06-30-2011, 11:56 AM   #2
Karl Godt
Member
 
Registered: Mar 2010
Location: Kiel , Germany
Distribution: once:SuSE6.2,Debian3.1, aurox9.2+3,Mandrake?,DSL? then:W7st,WVHB, #!8.10.02,PUPPY4.3.1 now:Macpup
Posts: 314

Rep: Reputation: 45
/bin/ntfs-3g is a mount helper called by the mount binary if not invoked with "mount -i" .
It depends on libntfs* in /lib ( and /usr/lib ) .
Also other commands invoke ntfs-3g like 'dd' .

"ntfs" should be the fs -t[ype] .

I read about putting "ntfs-3g" into fstab but this does not work for me .
"ntfs" and "auto" worked best .

Would "su root" "sudo mount" "login -f root" work to mount as user ?
 
Old 07-01-2011, 08:44 AM   #3
husten
Member
 
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 56

Original Poster
Rep: Reputation: 16
Mounting as root will work (from a root-dolphin or fstab, or su - mount).

However I would like to mount NTFS usb drives as easily as FAT usb drives e.g. via the pop-up icon in KDE 4.

This is a family PC, can't ask the rest of the family to mess with the root password.

Works fine with mandriva and sabayon.
 
Old 07-03-2011, 05:25 AM   #4
londy
LQ Newbie
 
Registered: Feb 2009
Distribution: openSUSE 11.4
Posts: 28

Rep: Reputation: 3
I saw this sticky at the opensuse forums.

http://forums.opensuse.org/english/g...-notifier.html
 
Old 07-03-2011, 09:55 AM   #5
husten
Member
 
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 56

Original Poster
Rep: Reputation: 16
I had already gone through this, this was a bug where even root could not automount (in a root-dolphin for example).
The issue of automounting as user is not touched by this.
Thanks anyway for bringing this up, I am still holding out for a while.
if I get fed up I will desert suse for sabayon.
 
Old 07-03-2011, 12:28 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,267

Rep: Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457Reputation: 3457
Distro's let one offer the user a set of permissions or privileges. You need to add that ability to the user.

I believe that you can right click on the mounted usb read only and choose to mount it with read write permissions.
 
Old 07-04-2011, 01:12 PM   #7
husten
Member
 
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 56

Original Poster
Rep: Reputation: 16
I bit the bullet and messed with policy kit - e.g. global systems policies.
Under org.freedesktop - 'The udisks project' I set mount and unmount to a user group.

I found this only because i was trying to unmount as a user a root-mounted drive. the error message asking for the password mentioned the 'udisk' stuff.

It does the job. However not the proper solution as Suse was allowing users to mount FATs before, only NTFS was the problem. I was looking for a rule that dealt with mounting on a file-systems basis. Partially solved - anyone else come up with a better way soon, else mods can mark this solved.

Anyway this policy-kit stuff sucks! It almost makes Windows registry look simple. Any KDE developers reading this should hang their head in shame. It should be organized by task or hardware, not by cult, religion, or clan membership.

Thanks all!
 
Old 07-04-2011, 01:20 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
i have never had a problem with ntfs .but i am also running Gnome2 and not kde4 as my desktop

if not listed in fstab then the automount will ask for the root password in a gnome pop-up when i open that folder / drive
 
Old 07-05-2011, 09:59 AM   #9
husten
Member
 
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 56

Original Poster
Rep: Reputation: 16
the kde mount applet will not ask......
 
Old 07-05-2011, 02:54 PM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
must be a bug
i take it is not in the little box in the lower tool bar on the left side
 
Old 07-08-2011, 09:14 AM   #11
husten
Member
 
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 56

Original Poster
Rep: Reputation: 16
John the drive shows up in the icon, but a click on "open with file manager" results in nothing.
Open up a root dolphin and click on the drive there ad it mounts.

Anyway It is Suse's declared policy to ask for root access for external ntfs drives. I have found nothing on the internet on how to re-adjust the original Suse setting for ntfs to the setting for fat.

I don't like it, can't change it in Suse - suppose its either the policykit work-around I described earlier or changing to Sabayon.
 
Old 07-09-2011, 02:25 AM   #12
londy
LQ Newbie
 
Registered: Feb 2009
Distribution: openSUSE 11.4
Posts: 28

Rep: Reputation: 3
Did you try editing /etc/filesystems as instructed in the link I provided? If that didn't fix your problem then you must've fiddled around with some files that's causing your problems.

I have two 11.4 machines and both can mount ntfs usb sticks. I stick it in and click "open with file manager" and it's mounted.
 
Old 07-10-2011, 03:41 AM   #13
husten
Member
 
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 56

Original Poster
Rep: Reputation: 16
Yes, i did catch that
my /etc/filesystems is

Quote:
vfat
ntfs
hfs
minix
reiserfs
*
 
Old 07-17-2011, 01:02 PM   #14
jwlinux
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Rep: Reputation: Disabled
OpenSUSE11.4 problems with usb stick

I cannot believe this is a major issue with linux...Tried Ubuntu, Mint, and now Suse 11.4...when I plug the stick at startup, it mounts the usb device, otherwise is a nightmare. In Ubuntu I had to load policykit, even then, it would not load everytime...had to use the lsusb command to mount the usb device...so I thought to try another distro...
Comes Open Suse, Same thing!!!! but now policykit, nor lsusb works! help! tried looking but seems like regular users like me cannot use linux...
Ok, so whats next? Everyday Windows seems like a better program, it works! everything works, and I am saying this for the main stream users. If linux community likes to win this war, then logically this is not the way...everything has to work, for main stream people, or Windows will always be in the 90% percentile...Ok, now back to my issues, will give it a try for another day, and if not I stilll have my Windows image. Anyone with a simple solution?
 
Old 07-17-2011, 04:24 PM   #15
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
jwlinux
there is no war to win
some fat issues are caused by the Microsoft patents on file names ( fat) and on ntfs

yell at them
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Way to make autofs mount to specific USB flash drive to specific folder? utahnix Linux - Software 2 11-24-2010 06:27 PM
How to auto mount usb drives as a normal user basheer Slackware 3 10-24-2009 11:26 PM
Cannot mount ntfs-3g USB dirve with user permission login console PB0711 SUSE / openSUSE 1 03-11-2009 10:45 AM
Help Me, automatically mount ntfs partitions on USB and Firewire drives RottenMutt Fedora 1 11-01-2006 01:27 PM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 02:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration