-   SUSE / openSUSE (
-   -   No video after first restart!!! PLEASE HELP!!!! (

zac_haryy 10-31-2004 10:26 PM

No video after first restart!!! PLEASE HELP!!!!
I am just converting to Suse from WinXP and I have installed Suse 4 times today. The first time it boots up it always boots up the KDE but when I restart it I am just presented with the terminal. I have read up on this on this forum where one person has the exact same problem:
I have tried everything that they have said in that thread. but also this:

When I type in "init 3" it acts like its going to load but then goes back to the terminal again. Then I type in "init 5" and I can see the X as my cursor and I can move it around on the black screen that I see and then it adventualy goes back to the terminal again. So then I type "startx" and this time it has a white screen (with black sciggle lines on it) and I can see the mouse cursor (arrow) and of course it adventually goes back to the terminal again. If anybody has any ideas on what I can do to get this to wokr please let me know.
I have went through Mandrake and Red Hat and both of those installed prefect and I could use them after rebooting and everything. I only had them on here just for testing. Then I read about Suse and thought that I would give it a try. It actually seems like a huge pain compared to the others.

Please help!!!!!


gromer 11-01-2004 02:57 AM

People need more information.

Dear zac_haryy.
Your post sounds as if the X-Server crashes on your system. This may be due to many different reasons.
The people willing to help you need a bit more information:
- What's the name and model of your graphics card and which driver are you using for it
- Which Mainboard are you using
- Which precise version of SuSE-Linux are you using? (and if differnt kernels are provided, which one are you using: "uname -a" will tell you)

When (trying to) starting up, the X-server puts many messages into a log file
I personally use Debian instead of SuSE. On my system I find this log-file here:

Furthermore helpfull might be the output of

To look at them this command might help you
less /var/log/XFree86.0.log
less /var/log/syslog
dmesg | less

Probably you'll find an error message that explains your problem. My guess is that your system is trying to use a wrong gfx-driver.
Good luck.

mitchcat 11-01-2004 10:21 AM

suse 9.1 install and X
I had different problems when I installed suse 9.1 pro on my old IBM 300GL. The 300GL has integrated graphics, but I previously had installed a nvidia pci card. The problem (i think) was that suse was trying to use the motherboard chips with the nvidia driver. I don't remember the cure off the top of my head (I'm at work, a window$ shop), but i did use sax2 at the terminal to set the driver and tell suse to use the card instead of the motherboard.


man sax2

at the terminal to see how it works. (if you might have a similar problem...)

Good luck,

zac_haryy 11-01-2004 11:02 AM

I have a Geforce MX440 video card (I belive) and I have a ASUS A7V8X-E Deluxe mobo. I am at work right now so once I go home for lunch break I will check everything out and post my details right away. I would really like to get this going because I would really like to start messing around with Suse.

Then to my next problem:
Dual monitor display like I had with WinXP.....


mitchcat 11-01-2004 12:11 PM

I have a PCI version of the GeForce MX440 from Chaintech.

zac_haryy 11-01-2004 12:41 PM

When I type in "uname -a" I get this:
"Linus linux 2.6.5-7.111-defautl #1 Wed Oct 13 15:45:13 UTC 2004 i686 athlon i386 GNU/Linux"

That's what I recieve when I type that.

Then I went ahead and opened this:

The only thing that really looked wrong here was this:
"Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!"

So this is really the only thing that I could see that was wrong to my knowledge.

Then I tried typing the "man sax2" and that bro ugh up a bunch of test and different command options that it said I could try. (How do I exit out of that to type more commands? It just like when viewing the XFree.0.log file....I couldn't figure out how to exit it to type more commands). Well this is everything that I have tried and have gotten nothing successful yet.


winshade 11-01-2004 12:57 PM

try as root

init 3 <enter>

sax2 -l <enter>

this should give you a basic display

if this fails try

vga=normal at the grub screen

sorry if this is repeated info i have not read the other posts!!!


( Linux support at

zac_haryy 11-01-2004 04:56 PM

winshade: I tried that and Sax2 acts like it is going to load up the GUI version of it (I see the cursor and the blue screen with the Sax2 down in the lower right hand corner) and then it goes back to the console again and waits for me to input another command.


mitchcat 11-02-2004 04:04 PM

At the terminal, try:

sax2 -p

You should be asked for the root password and sax2 should print the chipset and driver used to the screen. You should be able to see the MX440 card as at least one of the options, take note of the chip number corresponding to the MX440. Now you're ready to set the chip set and driver...

sax2 -c #, -m driver=nv

Where # is the chip number (probably either 0 or 1). The driver=nv is the 2D driver for nvidia cards. (i may have the -m driver=nv bit incorrect... I'm not always a perfect notekeeper) if you can startx, you'll want to install nvidia's driver to get the 3D acceleration.

It just occured to me that perhaps the problem is the nvidia driver. Look at the installing the nvidia driver how-to from suse and pay special attention to setting the path to the kernel source. find the how-to at: or go to the suse site and search on "nvidia how-to"

tremend0us 11-18-2004 08:52 AM

I'm not sure how this could help, but I broke my head for a couple of weeks wrestling with a video problem and it could be the same. I also have a dual display graphic cards ATI 9000 and, after installing linux (Suse 9.2, Fedora 1 & 2, Mandrake 9 & 10) I had problems with my display. Sometimes the GUI would not load, sometimes it would load but colors would be washed out, sometimes it would display in 640x480. For some weird reason I decided to unplug the cable connecting my video card to the TV (secondary monitor) and it all started working properly.

From there I was able to try to configure the card further with Fedora 2 displaying properly. (I can't say, however, that I've been 100% successful in setting up the dual-mode yet. It seems to be a problem with my card - it's not an original ATI, but a Hercules. Needless to say, I've already asked Santa to bring me a new card.)

Just my 2.


oneiltj 10-07-2005 12:59 PM

Can't start X session after first reboot
I just installed SuSE 9.3 pro on a machine I'had RH9 on. ( tried fedora 4 for an upgrade what POS ) anyway I know this machine will do X all day.

On this install when I startx from RL3 i get:
could not init font path /usr/X11R6/lib/X11/font/local
could not init font path /usr/X11R6/lib/X11/font/CID

I'm assuming this is not a file issue but a monitor config issue.

IBM 300 GL - Default - Default, Mits DiamondPoint V50LCD


oneiltj 10-08-2005 08:30 AM

No Video... !!FIX!!
I may have found your fix on this. For what ever reason the wrong window manager or no window manager is enabled directly just prior to first boot.

If logging in at runlevel 5 ( gui ) left click and start a xterm. As SU edit /etc/inittab look for id:5: blah, blah. Change the 5 to a 3. ---or--- as SU init 3.

Start YaST and hammer thru until you see a line remarking about the initial windows manager. Mine was some odd thing I had seen before. Change this to KDE or Gnome.

Exit out and save the changes.

Do a init 5 to test it.

Something is 'broke' in the install clean up and the window manager SuSE uses for the install is not being switched during clean up prior to first boot.

Good luck!
-t :D

King of Japan 10-12-2005 07:44 PM

Hey, This appears to be exactly the same issue I'm having.
I went back in and started yast and went through it, but I couldn't find anything like initial Windows manager.
Can you aor someone else tell me where in yast it is?

All times are GMT -5. The time now is 12:54 AM.