LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-07-2005, 02:45 PM   #1
Trinity22
Member
 
Registered: Jul 2003
Location: oregon coast
Distribution: Fedora Core 3
Posts: 280

Rep: Reputation: 30
No dsl in Suse 9.2, lots of bash info...


I installed Suse 9.2 from a bootable DVD off of LinuxPro mag the night before last. I've got no dsl though. Set everything up like it was, I'm tapping into my modem just fine. Some things people have told me to look up...

/etc/resolv.conf says
search myhome.westell.com
nameserver 192.168.1.1
nameserver 192.168.1.1

someone suggested I add 209.5.56.2 to it and try pinging, but that failed. Pinging hangs in shell

Sudo ifconfig shows
__
linux: /home/arena #sudo ifconfig
eth0 Link encop: Ethernet HWaddr 00:04:5A:7A:94:F4
inet addr: 192.168.1.147 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr:fe80::204:5aff:fe7a:94f4/64 scope:link
Up broadcast notrailers running multitask MTU:1500 Metric:1
RX Packets: 436 errors:0 dropped: 0 overruns: 0 frame:0
TX Packets: 525 errors: 0 dropped: 0 overruns: 0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:208336 (203.4 kb) TX bytes: 69295 (67.6 kb)
Interrupt:5 Base address:0xd000

lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
Up loopback running MTU:16436 Metric:1
RX Packets:64 errors:0 dropped:0 overruns:0 frame:0
TX Packets: 64 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4152 (4.0 kb) TX bytes:4152 (4.0kb)
__

route shows
__
inux :/home/arena #route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.1 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default dslrouter 0.0.0.0 UG 0 0 0 eth0
__

Dig Shows
__
linux :/home/arena #dig
<<Dig 9.2.4>>
global options: printcmd
Got answer:
->>Header<<- opcode: Query, status: Noerror,
id:14099
flags:qr aa rd ra; Query:1, Answer:1, Authority:0, Additional:1
Question Section:
IN NS
Answer Section:
86400 IN NS localhost.
Additional Section
localhost 86400 IN A 206.46.192.65
Query Time: 132 msec
Server: 192.168.1.1#53(192.168.1.1)
When: Mon Jun 6 22.45.50 2005
MSG size rcvd: 55
__

The error I get when trying to load pages is
An error ocurred while loading
http://www.verizon.com
Timeout on server
Connection to Verizon.com at Port 80


Can anyone help figure out what I can do to get internet running on this thing?

Thanks,
Arena
 
Old 06-08-2005, 09:24 AM   #2
RossB
Novell Adv. Tech. Training Engineer
 
Registered: Jul 2004
Distribution: SUSE 9.3 Pro/Whoppix/SLES
Posts: 46

Rep: Reputation: 15
DSL problems

Arena,

This may not be a problem with SUSE per se, but with your Westell router. I can assume that since you have much the same router config as I am used to seeing, that you have Vzn DSL.

You should either call Verizon DSL support (number in your documentation, not right at hand or I'd include it) and have them walk you through if the router is actually connecting properly, or if you can try to connect with another machine, and then if that machine can connect, it's time to t-shoot SUSE.

I have helped several neighbors and friends who's Westell WAP routers have suddenly dumped their config and won't reach the net.

Ross
 
Old 06-08-2005, 10:44 AM   #3
equinox
Member
 
Registered: Dec 2003
Location: Johannesburg, South Africa
Posts: 846

Rep: Reputation: 30
I don't see any default gateway there? Have you added one?

Code:
rizon:~ # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.85.0    *               255.255.255.0   U     0      0        0 vmnet1
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
192.168.45.0    *               255.255.255.0   U     0      0        0 vmnet8
link-local      *               255.255.0.0     U     0      0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default         192.168.1.2     0.0.0.0         UG    0      0        0 eth0
 
Old 06-08-2005, 11:35 AM   #4
RossB
Novell Adv. Tech. Training Engineer
 
Registered: Jul 2004
Distribution: SUSE 9.3 Pro/Whoppix/SLES
Posts: 46

Rep: Reputation: 15
Oh yeah, I HAVE had the problem with Linux of not getting a proper default gateway.

Here's how to add one (as root):

route add default gw 192.168.1.1

This should add a route for your Westell router.

Ross
 
Old 06-08-2005, 06:33 PM   #5
Trinity22
Member
 
Registered: Jul 2003
Location: oregon coast
Distribution: Fedora Core 3
Posts: 280

Original Poster
Rep: Reputation: 30
Thanks for the replies... actually the Westell is a modem, not a router. And I did call Verizon, they dont have any DNS numbers they give me, says I should be getting them through DHCP, which I've altered my ethernet card to run that way via Yast. He mentioned something about PPoe, which I'm not sure what to do with that though.

As for default gateway.... I'll try adding that, but 192.168.1.1 is <b>everywhere</b> on my machine. I'm doubting that could be it...

Thanks,
Trinity
 
Old 06-08-2005, 07:57 PM   #6
RossB
Novell Adv. Tech. Training Engineer
 
Registered: Jul 2004
Distribution: SUSE 9.3 Pro/Whoppix/SLES
Posts: 46

Rep: Reputation: 15
Ok, when I say router, I mean the same thing you do, it's a DSL Modem/Router/Gateway/Firewall thingie.

If you point your browser to 192.168.1.1 and enter the admin/password combo, does your link say it's up?

Your Westell should be getting an IP address and other information from Verizon, then your internal Router DHCP should assign out an IP, Network Mask and Default Gateway to you, which running the following commands will confirm:

ifconfig
<output should show a 192.168.1.xx address>

route -n
<the output should contain the following line>
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

cat /etc/resolv.conf
<output should contain the following>
search myhome.westell.com
nameserver 192.168.1.1
nameserver 192.168.1.1

There shouldn't be any PPOE confiiguration on your local machine, your local machine's /etc/sysconfig/network/ifcfg-eth-id-MA:CAD:RE:SS file should contain the line:

BOOTPROTO='dhcp'

and not much else. Try setting your machine to DHCP addressing if it's not already.

To re-iterate, I have had SUSE 9.x Pro NOT get a properly configured and valid default gateway, there was a recent update for 9.3 that fixed this.

HTH,

Ross
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Convert an info file(bash.info.gz) to a single html file Darwish Linux - Software 2 09-24-2005 06:51 AM
DSL getting started first get info files from Windwos and connect to net... allinux Linux - Newbie 4 08-18-2005 05:15 AM
AS400 where can I find lots of info? jimdaworm Linux - General 14 02-02-2005 03:32 PM
dsl on demand in suse 8.0, and installing dsl paul62 SUSE / openSUSE 2 01-04-2005 09:32 PM
Learning from shell's info bash ? jamaso Linux - Newbie 7 11-13-2001 09:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 02:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration